aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-13 00:38:47 +0800
committermiwi <miwi@FreeBSD.org>2008-01-13 00:38:47 +0800
commita96a82e53baba6281ef75f40b4053a5a94a16742 (patch)
tree2e29678598048881f4b293e5a02899cfca455b92 /dns
parentfb0ef631a33b334ebf2aebe99235d8ca5d6354fe (diff)
downloadfreebsd-ports-gnome-a96a82e53baba6281ef75f40b4053a5a94a16742.tar.gz
freebsd-ports-gnome-a96a82e53baba6281ef75f40b4053a5a94a16742.tar.zst
freebsd-ports-gnome-a96a82e53baba6281ef75f40b4053a5a94a16742.zip
Net::DNSBL::Statistics is the Perl module that collects statistics on the
interrogation success for a list of IP addresses against a list of DNSBL's. The module is used to implement the reproting script dnsblstat. WWW: http://search.cpan.org/dist/Net-DNSBL-Statistics/ PR: ports/119424 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-Net-DNSBL-Statistics/Makefile28
-rw-r--r--dns/p5-Net-DNSBL-Statistics/distinfo3
-rw-r--r--dns/p5-Net-DNSBL-Statistics/pkg-descr5
-rw-r--r--dns/p5-Net-DNSBL-Statistics/pkg-plist8
5 files changed, 45 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 0dc95d978d65..2a3058a28466 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -84,6 +84,7 @@
SUBDIR += p5-Net-DNS-ZoneFile
SUBDIR += p5-Net-DNS-ZoneFile-Fast
SUBDIR += p5-Net-DNSBL-MultiDaemon
+ SUBDIR += p5-Net-DNSBL-Statistics
SUBDIR += p5-Net-Domain-ExpireDate
SUBDIR += p5-Net-Domain-TLD
SUBDIR += p5-Net-LibIDN
diff --git a/dns/p5-Net-DNSBL-Statistics/Makefile b/dns/p5-Net-DNSBL-Statistics/Makefile
new file mode 100644
index 000000000000..04ca3d078056
--- /dev/null
+++ b/dns/p5-Net-DNSBL-Statistics/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Net-DNSBL-Statistics
+# Date created: 2008-01-07
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DNSBL-Statistics
+PORTVERSION= 0.03
+CATEGORIES= dns mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Gather DNSBL Statistics
+
+RUN_DEPENDS= p5-Net-DNS-Codes>=0.09:${PORTSDIR}/dns/p5-Net-DNS-Codes \
+ p5-Net-DNS-ToolKit>=0.35:${PORTSDIR}/dns/p5-Net-DNS-ToolKit \
+ p5-Net-DNSBL-MultiDaemon>=0.22:${PORTSDIR}/dns/p5-Net-DNSBL-MultiDaemon
+BUILD_DEPENDS= p5-Net-DNS-Codes>=0.09:${PORTSDIR}/dns/p5-Net-DNS-Codes \
+ p5-Net-DNS-ToolKit>=0.35:${PORTSDIR}/dns/p5-Net-DNS-ToolKit \
+ p5-Net-DNSBL-MultiDaemon>=0.22:${PORTSDIR}/dns/p5-Net-DNSBL-MultiDaemon
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::DNSBL::Statistics.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNSBL-Statistics/distinfo b/dns/p5-Net-DNSBL-Statistics/distinfo
new file mode 100644
index 000000000000..56190db234a6
--- /dev/null
+++ b/dns/p5-Net-DNSBL-Statistics/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-DNSBL-Statistics-0.03.tar.gz) = d9ea6b976fafc485862bd5e1d5a8cf9f
+SHA256 (Net-DNSBL-Statistics-0.03.tar.gz) = 2a531b6f763f6be09ffc0b415502367d7d5aa8d9b629699ee8946de4e67fd894
+SIZE (Net-DNSBL-Statistics-0.03.tar.gz) = 34989
diff --git a/dns/p5-Net-DNSBL-Statistics/pkg-descr b/dns/p5-Net-DNSBL-Statistics/pkg-descr
new file mode 100644
index 000000000000..c5ffc9537d87
--- /dev/null
+++ b/dns/p5-Net-DNSBL-Statistics/pkg-descr
@@ -0,0 +1,5 @@
+Net::DNSBL::Statistics is the Perl module that collects statistics on the
+interrogation success for a list of IP addresses against a list of DNSBL's.
+The module is used to implement the reproting script dnsblstat.
+
+WWW: http://search.cpan.org/dist/Net-DNSBL-Statistics/
diff --git a/dns/p5-Net-DNSBL-Statistics/pkg-plist b/dns/p5-Net-DNSBL-Statistics/pkg-plist
new file mode 100644
index 000000000000..1fdde7e3cfb1
--- /dev/null
+++ b/dns/p5-Net-DNSBL-Statistics/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNSBL/Statistics/.packlist
+%%SITE_PERL%%/Net/DNSBL/Statistics.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNSBL/Statistics
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNSBL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/DNSBL
+@dirrmtry %%SITE_PERL%%/Net