aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-08-09 05:59:24 +0800
committerthierry <thierry@FreeBSD.org>2004-08-09 05:59:24 +0800
commite325c2601b6dbfba30dbfe8a2a5e42dc6f94dc06 (patch)
tree2b9d6be4c98ecc61b8e26f085c03d79c33b2fab1 /dns
parentc77a444f0a53a35d5d3a8b3890d96dfec9bf35b3 (diff)
downloadfreebsd-ports-gnome-e325c2601b6dbfba30dbfe8a2a5e42dc6f94dc06.tar.gz
freebsd-ports-gnome-e325c2601b6dbfba30dbfe8a2a5e42dc6f94dc06.tar.zst
freebsd-ports-gnome-e325c2601b6dbfba30dbfe8a2a5e42dc6f94dc06.zip
- Update of sysutils/fastresolve to support BDB ver. 4.2;
- Move to the dns category. PR: ports/70127 & ports/70179 Submitted by: Michael Edenfield & maintainer Repocopied by: marcus.
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/fastresolve/Makefile15
2 files changed, 10 insertions, 6 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 67f5215f204a..3104c85d364e 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -29,6 +29,7 @@
SUBDIR += dnswalk
SUBDIR += domtools
SUBDIR += ez-ipupdate
+ SUBDIR += fastresolve
SUBDIR += firedns
SUBDIR += fpdns
SUBDIR += geta
diff --git a/dns/fastresolve/Makefile b/dns/fastresolve/Makefile
index a43fa467f7b6..e3eaa9f6967c 100644
--- a/dns/fastresolve/Makefile
+++ b/dns/fastresolve/Makefile
@@ -7,8 +7,8 @@
PORTNAME= fastresolve
PORTVERSION= 2.10
-PORTREVISION= 1
-CATEGORIES= sysutils
+PORTREVISION= 2
+CATEGORIES= dns
MASTER_SITES= http://www.djmnet.org/sw/dist/
MAINTAINER= martin@tradex.sk
@@ -31,15 +31,18 @@ WITH_BDB_VER?= 3
.if ${WITH_BDB_VER} == 3
LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
-CONFIGURE_ARGS= --with-bdb-lib=-ldb3_cxx --with-bdb-incdir=${LOCALBASE}/include/db3
+CONFIGURE_ARGS= --with-bdb-lib=-ldb3_cxx --with-bdb-incdir=${LOCALBASE}/include/db3
.elif ${WITH_BDB_VER} == 4
LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
-CONFIGURE_ARGS= --with-bdb-lib=-ldb4_cxx --with-bdb-incdir=${LOCALBASE}/include/db4
+CONFIGURE_ARGS= --with-bdb-lib=-ldb4_cxx --with-bdb-incdir=${LOCALBASE}/include/db4
.elif ${WITH_BDB_VER} == 41
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
-CONFIGURE_ARGS= --with-bdb-lib=-ldb41_cxx --with-bdb-incdir=${LOCALBASE}/include/db41
+CONFIGURE_ARGS= --with-bdb-lib=-ldb41_cxx --with-bdb-incdir=${LOCALBASE}/include/db41
+.elif ${WITH_BDB_VER} == 42
+LIB_DEPENDS+= db-4.2:${PORTSDIR}/databases/db42
+CONFIGURE_ARGS= --with-bdb-lib=-ldb_cxx-4.2 --with-bdb-incdir=${LOCALBASE}/include/db42
.else
-.error WITH_BDB_VER must be one between 3, 4 and 41
+.error WITH_BDB_VER must be one between 3, 4, 41 or 42
.endif
MAN1= dns-terror.1 btree-dump.1 convert-dom-db.1 convert-ip-db.1 \