aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-05-21 05:19:10 +0800
committerpav <pav@FreeBSD.org>2005-05-21 05:19:10 +0800
commitebb150f414b3881b8c8f9fd3b1ff11ccce01db38 (patch)
treed463c12df6b3e359ff30a548a649c67619322b2b /dns
parent34ce8de8f0ef1ff10dd76e5f4d746e3cfabd23bc (diff)
downloadfreebsd-ports-gnome-ebb150f414b3881b8c8f9fd3b1ff11ccce01db38.tar.gz
freebsd-ports-gnome-ebb150f414b3881b8c8f9fd3b1ff11ccce01db38.tar.zst
freebsd-ports-gnome-ebb150f414b3881b8c8f9fd3b1ff11ccce01db38.zip
This program is a domain name server analysis and reporting tool.
It checks and reports whether a domain name, hosted by your organization, is still in use, and if so, reports whether your name servers are still the delegated name servers of the domain name in question. PR: ports/80834 Submitted by: Ozkan KIRIK <ozkan@enderunix.org>
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/checkdns/Makefile28
-rw-r--r--dns/checkdns/distinfo4
-rw-r--r--dns/checkdns/files/patch-Makefile25
-rw-r--r--dns/checkdns/files/pkg-message.in8
-rw-r--r--dns/checkdns/pkg-descr19
-rw-r--r--dns/checkdns/pkg-plist15
7 files changed, 100 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index f6c6c55ce328..9b26da356cc1 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -9,6 +9,7 @@
SUBDIR += bind84
SUBDIR += bind9
SUBDIR += bind9-dlz
+ SUBDIR += checkdns
SUBDIR += crossip
SUBDIR += ddclient
SUBDIR += ddup
diff --git a/dns/checkdns/Makefile b/dns/checkdns/Makefile
new file mode 100644
index 000000000000..2f098f773e08
--- /dev/null
+++ b/dns/checkdns/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: checkdns
+# Date created: 9 May 2005
+# Whom: Ozkan KIRIK <ozkan@enderunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= checkdns
+PORTVERSION= 0.5
+CATEGORIES= dns
+MASTER_SITES= http://www.enderunix.org/checkdns/
+
+MAINTAINER= ozkan@enderunix.org
+COMMENT= A domain name server analysis and reporting tool
+
+USE_REINPLACE= yes
+
+SUB_FILES= pkg-message
+PKG_MESSAGE= ${WRKDIR}/pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/main.c \
+ ${WRKSRC}/INSTALL ${WRKSRC}/README ${WRKSRC}/checkdns.conf-dist
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/dns/checkdns/distinfo b/dns/checkdns/distinfo
new file mode 100644
index 000000000000..39c2ced35a27
--- /dev/null
+++ b/dns/checkdns/distinfo
@@ -0,0 +1,4 @@
+MD5 (checkdns-0.5.tar.gz) = 7420cc7a01217391bb3eb4a2e7da1e96
+SIZE (checkdns-0.5.tar.gz) = 17262
+MD5 (Makefile.patch) = 5c53172699a0e758efee3f9850071236
+SIZE (Makefile.patch) = 616
diff --git a/dns/checkdns/files/patch-Makefile b/dns/checkdns/files/patch-Makefile
new file mode 100644
index 000000000000..292bbd778510
--- /dev/null
+++ b/dns/checkdns/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig Sat Jan 15 21:40:27 2005
++++ Makefile Fri May 20 23:12:20 2005
+@@ -9,7 +9,15 @@
+ $(CC) -o checkdns $(OBJS)
+
+ install:
+- cp checkdns /usr/local/bin/checkdns
++ cp checkdns ${PREFIX}/bin/checkdns
++ chown root ${PREFIX}/bin/checkdns
++ chmod 700 ${PREFIX}/bin/checkdns
++ cp -pf checkdns.conf-dist ${PREFIX}/etc/checkdns.conf
++ mkdir -p ${PREFIX}/share/checkdns/lang
++ cp -f README THANKS TODO AUTHORS COPYING INSTALL ChangeLog uninstall.sh ${PREFIX}/share/checkdns
++ cp -f lang/* ${PREFIX}/share/checkdns/lang
++
++
+
+ clean:
+ rm -f $(OBJS) checkdns
+@@ -17,4 +25,4 @@
+ uninstall: clean
+ rm /usr/local/bin/checkdns
+
+-all: compile install clean
++all: compile
diff --git a/dns/checkdns/files/pkg-message.in b/dns/checkdns/files/pkg-message.in
new file mode 100644
index 000000000000..e44e163e4f29
--- /dev/null
+++ b/dns/checkdns/files/pkg-message.in
@@ -0,0 +1,8 @@
+ --------------------------------------------------------------------
+ | >>> ATTENTION PLEASE <<< |
+ | |
+ | Please don't forget these : |
+ | - editing %%PREFIX%%/etc/checkdns.conf file ! |
+ | - copying checkdns.css file to Html Output Directory ! |
+ | |
+ --------------------------------------------------------------------
diff --git a/dns/checkdns/pkg-descr b/dns/checkdns/pkg-descr
new file mode 100644
index 000000000000..7c049999d508
--- /dev/null
+++ b/dns/checkdns/pkg-descr
@@ -0,0 +1,19 @@
+This program is a domain name server analysis and reporting tool.
+It checks and reports whether a domain name, hosted by your organization,
+is still in use, and if so, reports whether your name servers are
+still the delegated name servers of the domain name in question.
+
+Reports are generated both to the console and as HTML output.
+HTMLs also include information about the MX and WWW records of the domain name.
+
+The tool is expected to be of great use for Internet Service Providers
+who are in need of keeping track of lame dns records.
+
+Project Page:
+WWW: http://www.enderunix.org/checkdns
+
+Author:
+ Atilim BOY
+ aboy@enderunix.org
+ EnderUNIX SDT @ Turkey
+http://www.enderunix.org/
diff --git a/dns/checkdns/pkg-plist b/dns/checkdns/pkg-plist
new file mode 100644
index 000000000000..050ea2911956
--- /dev/null
+++ b/dns/checkdns/pkg-plist
@@ -0,0 +1,15 @@
+bin/checkdns
+etc/checkdns.conf
+%%DATADIR%%/README
+%%DATADIR%%/THANKS
+%%DATADIR%%/TODO
+%%DATADIR%%/AUTHORS
+%%DATADIR%%/COPYING
+%%DATADIR%%/INSTALL
+%%DATADIR%%/ChangeLog
+%%DATADIR%%/uninstall.sh
+%%DATADIR%%/lang/english
+%%DATADIR%%/lang/spanish
+%%DATADIR%%/lang/turkish
+@dirrm %%DATADIR%%/lang
+@dirrm %%DATADIR%%