aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-29 18:04:43 +0800
committermat <mat@FreeBSD.org>2016-04-29 18:04:43 +0800
commit07e6da8a827d435372f137335ed75255d1318295 (patch)
treee7bc9daa463e81a5722164b85ba285a4207a8a15 /dns
parent4fa08fa839075edfbe60ec10ecc39947624b0cc9 (diff)
downloadfreebsd-ports-gnome-07e6da8a827d435372f137335ed75255d1318295.tar.gz
freebsd-ports-gnome-07e6da8a827d435372f137335ed75255d1318295.tar.zst
freebsd-ports-gnome-07e6da8a827d435372f137335ed75255d1318295.zip
Update to 9.9.9.
While there, update the root hints file. Sponsored by: Absolight
Diffstat (limited to 'dns')
-rw-r--r--dns/bind99/Makefile4
-rw-r--r--dns/bind99/distinfo8
-rw-r--r--dns/bind99/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind99/files/named.root6
-rw-r--r--dns/bind99/files/patch-configure8
5 files changed, 21 insertions, 21 deletions
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 79af9b0024ca..02b168d776e3 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -2,7 +2,7 @@
# pkg-help formatted with fmt 59 63
PORTNAME= bind
-PORTVERSION= ${ISCVERSION:S/-P/P/}
+PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/}
PORTREVISION= 0
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
@@ -15,7 +15,7 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= ISCL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.9.8-P4
+ISCVERSION= 9.9.9
MAKE_JOBS_UNSAFE= yes
diff --git a/dns/bind99/distinfo b/dns/bind99/distinfo
index 4833e8612f89..f8a0f683baba 100644
--- a/dns/bind99/distinfo
+++ b/dns/bind99/distinfo
@@ -1,4 +1,4 @@
-SHA256 (bind-9.9.8-P4.tar.gz) = 5ed0b852e4d1dc90e10751c7fa70a9ee29a619bad61d97250eac8161009d89f2
-SIZE (bind-9.9.8-P4.tar.gz) = 7999697
-SHA256 (9.9.8-P4-rpz2+rl.14038.05.patch.xz) = 5415559171c03a9a02e31284552a4888911eeb692d57def8d631b7d0564dc5f0
-SIZE (9.9.8-P4-rpz2+rl.14038.05.patch.xz) = 39240
+SHA256 (bind-9.9.9.tar.gz) = 981c95f9702105007ef29764dd086a7c9cf0d01143012ae429dd78714dc51871
+SIZE (bind-9.9.9.tar.gz) = 8781170
+SHA256 (9.9.9-rpz2+rl.14038.05.patch.xz) = 863808da519dfa9e0f0cc74b2f66f5cfd3af564c54c1157b20922d58776d1811
+SIZE (9.9.9-rpz2+rl.14038.05.patch.xz) = 39300
diff --git a/dns/bind99/files/extrapatch-bind-min-override-ttl b/dns/bind99/files/extrapatch-bind-min-override-ttl
index 1492257ce5bc..a015dcee2657 100644
--- a/dns/bind99/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind99/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2016-02-29 00:30:52 UTC
+--- bin/named/config.c.orig 2016-04-20 20:11:30 UTC
+++ bin/named/config.c
@@ -141,6 +141,8 @@ options {\n\
min-roots 2;\n\
@@ -9,9 +9,9 @@
max-cache-ttl 604800; /* 1 week */\n\
transfer-format many-answers;\n\
max-cache-size 0;\n\
---- bin/named/server.c.orig 2016-02-29 00:30:52 UTC
+--- bin/named/server.c.orig 2016-04-20 20:11:30 UTC
+++ bin/named/server.c
-@@ -2554,6 +2554,16 @@ configure_view(dns_view_t *view, cfg_obj
+@@ -2559,6 +2559,16 @@ configure_view(dns_view_t *view, cfg_obj
}
obj = NULL;
@@ -28,7 +28,7 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2016-02-29 00:30:52 UTC
+--- lib/dns/include/dns/view.h.orig 2016-04-20 20:11:30 UTC
+++ lib/dns/include/dns/view.h
@@ -148,6 +148,8 @@ struct dns_view {
isc_boolean_t provideixfr;
@@ -39,9 +39,9 @@
dns_ttl_t maxncachettl;
in_port_t dstport;
dns_aclenv_t aclenv;
---- lib/dns/resolver.c.orig 2016-02-29 00:30:52 UTC
+--- lib/dns/resolver.c.orig 2016-04-20 20:11:30 UTC
+++ lib/dns/resolver.c
-@@ -5088,6 +5088,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5114,6 +5114,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -60,9 +60,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl)
---- lib/isccfg/namedconf.c.orig 2016-02-29 00:30:52 UTC
+--- lib/isccfg/namedconf.c.orig 2016-04-20 20:11:30 UTC
+++ lib/isccfg/namedconf.c
-@@ -1448,6 +1448,8 @@ view_clauses[] = {
+@@ -1459,6 +1459,8 @@ view_clauses[] = {
{ "lame-ttl", &cfg_type_uint32, 0 },
{ "max-acache-size", &cfg_type_sizenodefault, 0 },
{ "max-cache-size", &cfg_type_sizenodefault, 0 },
diff --git a/dns/bind99/files/named.root b/dns/bind99/files/named.root
index 159213fc33e6..21ec7ca71f9b 100644
--- a/dns/bind99/files/named.root
+++ b/dns/bind99/files/named.root
@@ -13,8 +13,8 @@
; on server FTP.INTERNIC.NET
; -OR- RS.INTERNIC.NET
;
-; last update: December 01, 2015
-; related version of root zone: 2015120100
+; last update: March 23, 2016
+; related version of root zone: 2016032301
;
; formerly NS.INTERNIC.NET
;
@@ -84,7 +84,7 @@ K.ROOT-SERVERS.NET. 3600000 AAAA 2001:7fd::1
;
. 3600000 NS L.ROOT-SERVERS.NET.
L.ROOT-SERVERS.NET. 3600000 A 199.7.83.42
-L.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:3::42
+L.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:9f::42
;
; OPERATED BY WIDE
;
diff --git a/dns/bind99/files/patch-configure b/dns/bind99/files/patch-configure
index 5cca844933f5..42c161ce0616 100644
--- a/dns/bind99/files/patch-configure
+++ b/dns/bind99/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2015-12-06 12:12:21 UTC
+--- configure.orig 2016-04-20 20:11:30 UTC
+++ configure
-@@ -14289,27 +14289,9 @@ done
+@@ -14329,27 +14329,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14352,47 +14334,7 @@ $as_echo "no" >&6; } ;;
+@@ -14392,47 +14374,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -20342,7 +20284,7 @@ $as_echo "" >&6; }
+@@ -20477,7 +20419,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).