aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-03-21 20:04:47 +0800
committerdinoex <dinoex@FreeBSD.org>2004-03-21 20:04:47 +0800
commit77a4b1998e5c1e10abbab8bc43644b3b3b232d4b (patch)
tree5b28e9cf2bf6f9dc74944c787072668feb3820d1 /dns
parentf4ac4030b80a1cb6344114accb8ced4bad711fc8 (diff)
downloadfreebsd-ports-gnome-77a4b1998e5c1e10abbab8bc43644b3b3b232d4b.tar.gz
freebsd-ports-gnome-77a4b1998e5c1e10abbab8bc43644b3b3b232d4b.tar.zst
freebsd-ports-gnome-77a4b1998e5c1e10abbab8bc43644b3b3b232d4b.zip
- fix openldap22 dependency
Reported by: eik - move configure dialog target
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-dlz/Makefile6
-rw-r--r--dns/bind9-dlz/files/configure.bind9-dlz3
2 files changed, 6 insertions, 3 deletions
diff --git a/dns/bind9-dlz/Makefile b/dns/bind9-dlz/Makefile
index b6124ca8e6d9..1559c8fbb100 100644
--- a/dns/bind9-dlz/Makefile
+++ b/dns/bind9-dlz/Makefile
@@ -64,8 +64,8 @@ CONFIGURE_ARGS+= --with-dlz-mysql
.if defined(WITH_LDAP)
LDAP_PORT?= net/openldap21-client
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
-LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
+LIB_DEPENDS+= ldap.${OPENLDAP_LIB_VER}:${PORTSDIR}/${LDAP_PORT}
+LIB_DEPENDS+= lber.${OPENLDAP_LIB_VER}:${PORTSDIR}/${LDAP_PORT}
CONFIGURE_ARGS+= --with-dlz-ldap
.endif
@@ -148,7 +148,7 @@ MAN8= dnssec-keygen.8 dnssec-makekeyset.8 dnssec-signkey.8 dnssec-signzone.8 \
lwresd.8 named-checkconf.8 named-checkzone.8 named.8 nsupdate.8 \
rndc-confgen.8 rndc.8
-pre-everything::
+pre-fetch:
@ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.bind9-dlz
pre-configure:
diff --git a/dns/bind9-dlz/files/configure.bind9-dlz b/dns/bind9-dlz/files/configure.bind9-dlz
index 7166c1b66cb3..9805a4cc5103 100644
--- a/dns/bind9-dlz/files/configure.bind9-dlz
+++ b/dns/bind9-dlz/files/configure.bind9-dlz
@@ -69,14 +69,17 @@ while [ "$1" ]; do
\"OpenLDAP20\")
echo WITH_LDAP=YES
echo LDAP_PORT?=net/openldap20-client
+ echo OPENLDAP_LIB_VER?=2
;;
\"OpenLDAP21\")
echo WITH_LDAP=YES
echo LDAP_PORT?=net/openldap21-client
+ echo OPENLDAP_LIB_VER?=2
;;
\"OpenLDAP22\")
echo WITH_LDAP=YES
echo LDAP_PORT?=net/openldap22-client
+ echo OPENLDAP_LIB_VER?=202
;;
\"BerkleyDB41\")
echo WITH_BERKLEYDB_DRIVER=YES