aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /dns
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'dns')
-rw-r--r--dns/py-adns/Makefile1
-rw-r--r--dns/py-dns/Makefile1
-rw-r--r--dns/py-twistedNames/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
index e0719a378cb3..27aa4acff9d4 100644
--- a/dns/py-adns/Makefile
+++ b/dns/py-adns/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= adns-python
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
post-patch:
diff --git a/dns/py-dns/Makefile b/dns/py-dns/Makefile
index 062513da92aa..08b8b7ae5108 100644
--- a/dns/py-dns/Makefile
+++ b/dns/py-dns/Makefile
@@ -20,6 +20,7 @@ COMMENT= DNS (Domain Name Service) library for Python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= pydns
DOCS= README.txt README-guido.txt
DOCSDIR= ${PREFIX}/share/doc/py-dns
diff --git a/dns/py-twistedNames/Makefile b/dns/py-twistedNames/Makefile
index a9ecdd6d4777..4317b5b89214 100644
--- a/dns/py-twistedNames/Makefile
+++ b/dns/py-twistedNames/Makefile
@@ -21,5 +21,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= Twisted_Names
.include <bsd.port.mk>