aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-02-07 03:17:51 +0800
committerdanilo <danilo@FreeBSD.org>2014-02-07 03:17:51 +0800
commit942cbf6fb8e54bd2039d735cce26d7e0a7732c9c (patch)
tree2d82bd146a3a407970ee56889a0e8bdbe41e5524 /dns
parent5b7b52d7128b750b4cba9bd3cab2a6b306e93178 (diff)
downloadfreebsd-ports-gnome-942cbf6fb8e54bd2039d735cce26d7e0a7732c9c.tar.gz
freebsd-ports-gnome-942cbf6fb8e54bd2039d735cce26d7e0a7732c9c.tar.zst
freebsd-ports-gnome-942cbf6fb8e54bd2039d735cce26d7e0a7732c9c.zip
dns/ldns
- Convert LIB_DEPENDS to new syntax dns/py-ldns - Add stage support [1] Reported by: mat [1]
Diffstat (limited to 'dns')
-rw-r--r--dns/ldns/Makefile4
-rw-r--r--dns/py-ldns/Makefile1
2 files changed, 2 insertions, 3 deletions
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index ea076a1f68a1..57556b7d4b4a 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -45,7 +45,7 @@ ALL_TARGET= pyldns
INSTALL_TARGET= install-pyldns
CONFIGURE_ARGS+=--with-pyldns
-LIB_DEPENDS+= ldns:${PORTSDIR}/dns/ldns
+LIB_DEPENDS+= libldns.so:${PORTSDIR}/dns/ldns
BUILD_DEPENDS+= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
post-patch:
@@ -58,7 +58,7 @@ ALL_TARGET= p5-dns-ldns
INSTALL_TARGET= install-p5-dns-ldns
CONFIGURE_ARGS+=--with-p5-dns-ldns
-LIB_DEPENDS+= ldns:${PORTSDIR}/dns/ldns
+LIB_DEPENDS+= libldns.so:${PORTSDIR}/dns/ldns
post-patch:
@${SED} -i '' -e 's=-I./include/ldns=-I${LOCALBASE}/include/ldns=' ${WRKSRC}/Makefile.in
diff --git a/dns/py-ldns/Makefile b/dns/py-ldns/Makefile
index 8f77890830fb..bf98311a7a2c 100644
--- a/dns/py-ldns/Makefile
+++ b/dns/py-ldns/Makefile
@@ -7,5 +7,4 @@ BUILD_PYLDNS=yes
PLIST= ${.CURDIR}/pkg-plist
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"