aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-05-31 13:01:00 +0800
committerdinoex <dinoex@FreeBSD.org>2004-05-31 13:01:00 +0800
commitced65d2f1be6ef514a5041139adb0b0aea03c4c6 (patch)
treef45d5bf6e6f36cce6948e8042989a09cd4117fdf /dns
parenta703c8d5a821f437c54b6525f1553e69cf5b69f5 (diff)
downloadfreebsd-ports-gnome-ced65d2f1be6ef514a5041139adb0b0aea03c4c6.tar.gz
freebsd-ports-gnome-ced65d2f1be6ef514a5041139adb0b0aea03c4c6.tar.zst
freebsd-ports-gnome-ced65d2f1be6ef514a5041139adb0b0aea03c4c6.zip
- fix supoort fop OpenLDAP
- allow override by "OPENLDAP_LIB" - substitute LIB_DEPENDS
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-dlz/Makefile4
-rw-r--r--dns/bind9-dlz/files/configure.bind9-dlz4
2 files changed, 4 insertions, 4 deletions
diff --git a/dns/bind9-dlz/Makefile b/dns/bind9-dlz/Makefile
index f344c084c283..33c90fb08b84 100644
--- a/dns/bind9-dlz/Makefile
+++ b/dns/bind9-dlz/Makefile
@@ -66,8 +66,8 @@ CONFIGURE_ARGS+= --with-dlz-mysql
.if defined(WITH_LDAP)
LDAP_SUFFIX= +ldap
LDAP_PORT?= net/openldap21-client
-LIB_DEPENDS+= ldap.${OPENLDAP_LIB_VER}:${PORTSDIR}/${LDAP_PORT}
-LIB_DEPENDS+= lber.${OPENLDAP_LIB_VER}:${PORTSDIR}/${LDAP_PORT}
+BUILD_DEPENDS+= ${LOCALBASE}/lib/${OPENLDAP_LIB}:${PORTSDIR}/${LDAP_PORT}
+RUN_DEPENDS+= ${LOCALBASE}/lib/${OPENLDAP_LIB}:${PORTSDIR}/${LDAP_PORT}
CONFIGURE_ARGS+= --with-dlz-ldap
.endif
diff --git a/dns/bind9-dlz/files/configure.bind9-dlz b/dns/bind9-dlz/files/configure.bind9-dlz
index 2fb6b8a27550..ac582c0cf040 100644
--- a/dns/bind9-dlz/files/configure.bind9-dlz
+++ b/dns/bind9-dlz/files/configure.bind9-dlz
@@ -68,12 +68,12 @@ while [ "$1" ]; do
\"OpenLDAP21\")
echo WITH_LDAP=YES
echo LDAP_PORT?=net/openldap21-client
- echo OPENLDAP_LIB_VER?=2
+ echo OPENLDAP_LIB?=libldap.so.2
;;
\"OpenLDAP22\")
echo WITH_LDAP=YES
echo LDAP_PORT?=net/openldap22-client
- echo OPENLDAP_LIB_VER?=202
+ echo OPENLDAP_LIB?=libldap-2.2.so.7
;;
\"BerkleyDB41\")
echo WITH_BERKLEYDB_DRIVER=YES