aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2017-01-10 21:34:42 +0800
committerzi <zi@FreeBSD.org>2017-01-10 21:34:42 +0800
commit0083cce9e8b72ea8ffa07a35b66f14d081a64b9e (patch)
tree6328671e06a13a1eb8e23f0765a87edf8d1cd0cc /dns
parent25e0956483c9efcff296bebea43fee42e17dd5e9 (diff)
downloadfreebsd-ports-gnome-0083cce9e8b72ea8ffa07a35b66f14d081a64b9e.tar.gz
freebsd-ports-gnome-0083cce9e8b72ea8ffa07a35b66f14d081a64b9e.tar.zst
freebsd-ports-gnome-0083cce9e8b72ea8ffa07a35b66f14d081a64b9e.zip
- Add OPTION (default to off) to install diagnostic tool(s)
- Do not bump PORTREVISION as this is a noop PR: 215937 Requested by: pi@
Diffstat (limited to 'dns')
-rw-r--r--dns/getdns/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/dns/getdns/Makefile b/dns/getdns/Makefile
index 4ae98b6d9bf8..63baad221403 100644
--- a/dns/getdns/Makefile
+++ b/dns/getdns/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libldns.so:dns/ldns \
libunbound.so:dns/unbound
-USES= libtool pathfix
+USES= libtool pathfix ssl
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libidn=${LOCALBASE} --docdir=${DOCSDIR} \
@@ -31,8 +31,9 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
SUB_FILES+= pkg-message
OPTIONS_SUB= yes
-OPTIONS_DEFINE= EXAMPLES DOCS LIBEV LIBUV LIBEVENT
+OPTIONS_DEFINE= DOCS DIAGS EXAMPLES LIBEV LIBUV LIBEVENT
+DIAGS_DESC= Build diagnostic tools
LIBEV_DESC= Build with libev extension
LIBUV_DESC= Build with libuv extension
LIBEVENT_DESC= Build with libevent extension
@@ -43,6 +44,13 @@ LIBUV_LIB_DEPENDS= libuv.so:devel/libuv
LIBUV_CONFIGURE_WITH= libuv
LIBEVENT_LIB_DEPENDS= libevent.so:devel/libevent2
LIBEVENT_CONFIGURE_WITH=libevent
+DIAGS_VARS= PLIST_FILES+=bin/${PORTNAME}_query
+
+do-build-DIAGS-on:
+ (cd ${WRKSRC}/src/test && ${MAKE})
+
+do-install-DIAGS-on:
+ (cd ${WRKSRC}/src/test && ${MAKE} DESTDIR=${STAGEDIR} install)
post-patch:
${REINPLACE_CMD} -Ee 's,^(sharedoc = ).*,\1${WRKDIR}/doc,' \
@@ -51,6 +59,9 @@ post-patch:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgetdns.so.*
+post-install-DIAGS-on:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/getdns_query
+
post-install-EXAMPLES-on:
(cd ${WRKSRC}/spec/example && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/)