aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2010-12-04 07:01:37 +0800
committerdougb <dougb@FreeBSD.org>2010-12-04 07:01:37 +0800
commit01b9338d981a8e379a07ea8d9fecae2e80a2964c (patch)
tree48813ba4d0dd3baf22408748f112787a2d9b68ef /dns
parent9f5643d8b36405b92937bf98596a66ec2172ed4c (diff)
downloadfreebsd-ports-gnome-01b9338d981a8e379a07ea8d9fecae2e80a2964c.tar.gz
freebsd-ports-gnome-01b9338d981a8e379a07ea8d9fecae2e80a2964c.tar.zst
freebsd-ports-gnome-01b9338d981a8e379a07ea8d9fecae2e80a2964c.zip
For the port:
1. Add CONFLICT for the ../bind-tools port 2. Remove CONFLICT for the removed ../bind9 port 3. Remove OPTION for threads on < RELENG_7 4. Remove MD5 from distinfo 5. Switch to pkg-install to create the symlinks to /etc/namedb/ as requested in [1] PR: ports/151635 [1] Submitted by: Benjamin Lee <ben@b1c1l1.com> [1]
Diffstat (limited to 'dns')
-rw-r--r--dns/bind95/Makefile19
1 files changed, 4 insertions, 15 deletions
diff --git a/dns/bind95/Makefile b/dns/bind95/Makefile
index 14fdb93aa158..b350a28c5593 100644
--- a/dns/bind95/Makefile
+++ b/dns/bind95/Makefile
@@ -33,7 +33,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random
-CONFLICTS= bind9*-9.[3467].* bind9-sdb-* host-*
+CONFLICTS= bind9*-9.[467].* bind9-sdb-* host-* bind-tools-9.*
OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
LINKS "Create conf file symlinks in ${PREFIX}" on \
@@ -43,6 +43,7 @@ OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
LARGE_FILE "64-bit file support" off \
SIGCHASE "dig/host/nslookup will do DNSSEC validation" off \
IPV6 "IPv6 Support (autodetected by default)" off \
+ THREADS "Compile with thread support" on \
DLZ_POSTGRESQL "DLZ Postgres driver" off \
DLZ_MYSQL "DLZ MySQL driver (single-threaded BIND)" off \
DLZ_BDB "DLZ BDB driver" off \
@@ -59,14 +60,6 @@ USE_OPENSSL= yes
ARCH= x86_64
.endif
-# We are ok by default from 7.0-RELEASE on
-.if ${OSVERSION} >= 700055
-OPTIONS+= THREADS "Compile with thread support" on
-.else
-OPTIONS+= THREADS "Compile w/threads (Not Recommended <FreeBSD-7)" off
-.endif
-
-
.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.else
@@ -205,6 +198,7 @@ post-patch:
${WRKSRC}/bin/${FILE}.Dist > ${WRKSRC}/bin/${FILE}
.endfor
+PKGINSTALL= ${.CURDIR}/../bind97/pkg-install
post-install:
${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
${BIND_DESTETC}/rndc.conf.sample
@@ -218,12 +212,7 @@ post-install:
${DOCSDIR}/
.endif
.if !defined(WITHOUT_LINKS) && !defined(WITH_REPLACE_BASE)
- ${MKDIR} /var/named${PREFIX}/etc
-.for DIR in ${PREFIX}/etc /var/named${PREFIX}/etc
-.for FILE in named.conf rndc.key
- ${LN} -sf /etc/namedb/${FILE} ${DIR}/${FILE}
-.endfor
-.endfor
+ PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
@${CAT} ${PKGMESSAGE}