aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2011-02-16 22:34:14 +0800
committermandree <mandree@FreeBSD.org>2011-02-16 22:34:14 +0800
commit76fcab07142a1b88540ff3eb6408f3edc5bfa2f9 (patch)
treededd0485f0013a6361dcd2b140b2c873878ad542 /dns
parent791e85d1f5d91334febe412a30b55b68813e80f9 (diff)
downloadfreebsd-ports-gnome-76fcab07142a1b88540ff3eb6408f3edc5bfa2f9.tar.gz
freebsd-ports-gnome-76fcab07142a1b88540ff3eb6408f3edc5bfa2f9.tar.zst
freebsd-ports-gnome-76fcab07142a1b88540ff3eb6408f3edc5bfa2f9.zip
Fix regression in config parser.
http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2011q1/004750.html
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsmasq/Makefile1
-rw-r--r--dns/dnsmasq/files/patch-aa11
2 files changed, 12 insertions, 0 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index 67edb47cc5ee..0b99c807fc06 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dnsmasq
PORTVERSION= 2.56
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/ \
diff --git a/dns/dnsmasq/files/patch-aa b/dns/dnsmasq/files/patch-aa
new file mode 100644
index 000000000000..b3537516efb1
--- /dev/null
+++ b/dns/dnsmasq/files/patch-aa
@@ -0,0 +1,11 @@
+--- src/util.c 2011-01-18 22:23:57.000000000 +0000
++++ src/util.c 2011-02-16 09:37:37.000000000 +0000
+@@ -379,7 +379,7 @@
+ while (maxlen == -1 || i < maxlen)
+ {
+ for (r = in; *r != 0 && *r != ':' && *r != '-'; r++)
+- if (!isxdigit((int)*r))
++ if (*r != '*' && !isxdigit((int)*r))
+ return -1;
+
+ if (*r == 0)