aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2018-02-15 14:56:11 +0800
committertruckman <truckman@FreeBSD.org>2018-02-15 14:56:11 +0800
commit7a2af4f7dfaba1cd7a8dc4aca2523a35ba67d1c5 (patch)
treebb24bbf96a033c49ab376ddbb9f10eb221dd545b /dns
parente3441609f8fdc1db44159b2992955d90a05e1a8a (diff)
downloadfreebsd-ports-gnome-7a2af4f7dfaba1cd7a8dc4aca2523a35ba67d1c5.tar.gz
freebsd-ports-gnome-7a2af4f7dfaba1cd7a8dc4aca2523a35ba67d1c5.tar.zst
freebsd-ports-gnome-7a2af4f7dfaba1cd7a8dc4aca2523a35ba67d1c5.zip
New port dnsdb/dnsdbq.
This is a pure C program that accesses the DNSDB API server at Farsight Security. An API key is required for operation. The command syntax was inspired by a python script called dnsdb_query, but significant departure has occured, largely inspired by a modern understanding of "time fencing" and a desire for new features such as CSV output and JSON reprocessing. Sponsored by: Farsight Security, Inc.
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/dnsdbq/Makefile30
-rw-r--r--dns/dnsdbq/distinfo3
-rw-r--r--dns/dnsdbq/pkg-descr7
4 files changed, 41 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 9dd2893c778b..b080c47ed309 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -39,6 +39,7 @@
SUBDIR += dnscrypt-proxy
SUBDIR += dnscrypt-wrapper
SUBDIR += dnsdbck
+ SUBDIR += dnsdbq
SUBDIR += dnsdist
SUBDIR += dnsenum
SUBDIR += dnsflood
diff --git a/dns/dnsdbq/Makefile b/dns/dnsdbq/Makefile
new file mode 100644
index 000000000000..eaa52ad5c3a9
--- /dev/null
+++ b/dns/dnsdbq/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= dnsdbq
+PORTVERSION= 0.0.20180215
+CATEGORIES= dns
+
+MAINTAINER= truckman@FreeBSD.org
+COMMENT= Shortened version of the dnsdb query testing tool
+
+LICENSE= APACHE20 ISCL
+LICENSE_COMB= multi
+LICENSE_FILE_APACHE20= ${WRKSRC}/Apache-2.0
+LICENSE_FILE_ISCL= ${WRKSRC}/ISC
+
+LIB_DEPENDS= libjansson.so:devel/jansson \
+ libcurl.so:ftp/curl
+
+USES= localbase
+USE_GITHUB= yes
+GH_ACCOUNT= dnsdb
+GH_TAGNAME= 273f985f03a4b92a8d641f064dc54faf28222e36
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${STAGEDIR}${PREFIX}/share/man/man1/${PORTNAME}.1
+
+PLIST_FILES= bin/${PORTNAME} share/man/man1/${PORTNAME}.1
+
+.include <bsd.port.mk>
diff --git a/dns/dnsdbq/distinfo b/dns/dnsdbq/distinfo
new file mode 100644
index 000000000000..984fc8a91093
--- /dev/null
+++ b/dns/dnsdbq/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518672234
+SHA256 (dnsdb-dnsdbq-0.0.20180215-273f985f03a4b92a8d641f064dc54faf28222e36_GH0.tar.gz) = 557c756fbbf064894fa17513b56c121e0011ccc4ee5a75627464dcd65596e424
+SIZE (dnsdb-dnsdbq-0.0.20180215-273f985f03a4b92a8d641f064dc54faf28222e36_GH0.tar.gz) = 22012
diff --git a/dns/dnsdbq/pkg-descr b/dns/dnsdbq/pkg-descr
new file mode 100644
index 000000000000..f528a0068c57
--- /dev/null
+++ b/dns/dnsdbq/pkg-descr
@@ -0,0 +1,7 @@
+This is a pure C program that accesses the DNSDB API server at Farsight
+Security. An API key is required for operation. The command syntax was
+inspired by a python script called dnsdb_query, but significant departure
+has occured, largely inspired by a modern understanding of "time fencing"
+and a desire for new features such as CSV output and JSON reprocessing.
+
+WWW: https://github.com/dnsdb/dnsdbq