aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-10-19 22:50:26 +0800
committertijl <tijl@FreeBSD.org>2016-10-19 22:50:26 +0800
commit7b80293f580b2c2cf97b82acd6bcb0d9a48cdb46 (patch)
tree3e3556f1e26a35be0250e7f749680b9fc30e9c6b /dns
parent101296dbd3ff02a5ab22526d0cfcd944432ddfe0 (diff)
downloadfreebsd-ports-gnome-7b80293f580b2c2cf97b82acd6bcb0d9a48cdb46.tar.gz
freebsd-ports-gnome-7b80293f580b2c2cf97b82acd6bcb0d9a48cdb46.tar.zst
freebsd-ports-gnome-7b80293f580b2c2cf97b82acd6bcb0d9a48cdb46.zip
Add Linux CentOS 7 infrastructure ports.
Mk/Uses/linux.mk changes: - Add support for architecture neutral (noarch) distfiles. - Add support for 64-bit only ports: set IGNORE on i386 and don't install 32-bit compat libraries on amd64. Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Differential Revision: https://reviews.freebsd.org/D7886
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/linux-c7-libasyncns/Makefile20
-rw-r--r--dns/linux-c7-libasyncns/distinfo.i3865
-rw-r--r--dns/linux-c7-libasyncns/distinfo.x86_647
-rw-r--r--dns/linux-c7-libasyncns/pkg-descr20
-rw-r--r--dns/linux-c7-libasyncns/pkg-plist.i3864
-rw-r--r--dns/linux-c7-libasyncns/pkg-plist.x86_646
7 files changed, 63 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index eb88cc0dbc77..136f4b899f8e 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -91,6 +91,7 @@
SUBDIR += libidn2
SUBDIR += libpsl
SUBDIR += linux-c6-libasyncns
+ SUBDIR += linux-c7-libasyncns
SUBDIR += linux-f10-libasyncns
SUBDIR += mDNSResponder_nss
SUBDIR += maradns
diff --git a/dns/linux-c7-libasyncns/Makefile b/dns/linux-c7-libasyncns/Makefile
new file mode 100644
index 000000000000..22f06aecc6de
--- /dev/null
+++ b/dns/linux-c7-libasyncns/Makefile
@@ -0,0 +1,20 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= libasyncns
+PORTVERSION= 0.8
+CATEGORIES= dns devel linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Library for executing DNS queries (Linux CentOS ${LINUX_DIST_VER})
+
+LICENSE= LGPL21+
+
+CONFLICTS= linux-c6-libasyncns-[0-9]*
+
+RPMVERSION= 7.el7
+USES= linux:c7
+USE_LDCONFIG= yes
+USE_LINUX_RPM= yes
+
+.include <bsd.port.mk>
diff --git a/dns/linux-c7-libasyncns/distinfo.i386 b/dns/linux-c7-libasyncns/distinfo.i386
new file mode 100644
index 000000000000..3d1c3164868f
--- /dev/null
+++ b/dns/linux-c7-libasyncns/distinfo.i386
@@ -0,0 +1,5 @@
+TIMESTAMP = 1473356058
+SHA256 (rpm/centos/7.2.1511/i386/libasyncns-0.8-7.el7.i686.rpm) = 86006ec7b6b5bc63c4225d98fe3d309d75d5b5f43f75bb81274e379e3f4573f1
+SIZE (rpm/centos/7.2.1511/i386/libasyncns-0.8-7.el7.i686.rpm) = 26592
+SHA256 (rpm/centos/7.2.1511/i386/libasyncns-0.8-7.el7.src.rpm) = ada6388ee1a4198ca82fe18a0333937d4c9d72715106c46aa2413d5dc27982ab
+SIZE (rpm/centos/7.2.1511/i386/libasyncns-0.8-7.el7.src.rpm) = 347143
diff --git a/dns/linux-c7-libasyncns/distinfo.x86_64 b/dns/linux-c7-libasyncns/distinfo.x86_64
new file mode 100644
index 000000000000..c8aff90f4a7d
--- /dev/null
+++ b/dns/linux-c7-libasyncns/distinfo.x86_64
@@ -0,0 +1,7 @@
+TIMESTAMP = 1473674952
+SHA256 (rpm/centos/7.2.1511/x86_64/libasyncns-0.8-7.el7.i686.rpm) = 86006ec7b6b5bc63c4225d98fe3d309d75d5b5f43f75bb81274e379e3f4573f1
+SIZE (rpm/centos/7.2.1511/x86_64/libasyncns-0.8-7.el7.i686.rpm) = 26592
+SHA256 (rpm/centos/7.2.1511/x86_64/libasyncns-0.8-7.el7.x86_64.rpm) = 1acf01399f6d5ea5f9bbbac18e67e77dc277551a24ad53de06f404205cb51206
+SIZE (rpm/centos/7.2.1511/x86_64/libasyncns-0.8-7.el7.x86_64.rpm) = 26816
+SHA256 (rpm/centos/7.2.1511/x86_64/libasyncns-0.8-7.el7.src.rpm) = ada6388ee1a4198ca82fe18a0333937d4c9d72715106c46aa2413d5dc27982ab
+SIZE (rpm/centos/7.2.1511/x86_64/libasyncns-0.8-7.el7.src.rpm) = 347143
diff --git a/dns/linux-c7-libasyncns/pkg-descr b/dns/linux-c7-libasyncns/pkg-descr
new file mode 100644
index 000000000000..36b59b4cd45c
--- /dev/null
+++ b/dns/linux-c7-libasyncns/pkg-descr
@@ -0,0 +1,20 @@
+libasyncns is a C library for Linux/Unix for executing name service queries
+asynchronously. It is an asynchronous wrapper around getaddrinfo(3),
+getnameinfo(3), res_query(3) and res_search(3) from libc and libresolv.
+
+In contrast to GNU's asynchronous name resolving API getaddrinfo_a(),
+libasyncns does not make use of UNIX signals for reporting completion of name
+queries. Instead, the API exports a standard UNIX file descriptor which may be
+integerated cleanly into custom main loops.
+
+In contrast to asynchronous DNS resolving libraries like libdenise, skadns,
+adns, libasyncns is just an asynchronous wrapper around the libc's synchronous
+getaddrinfo() API, which has the advantage of allowing name resolution using
+techniques like Multicast DNS, LDAP or NIS using standard libc NSS (Name
+Service Switch) modules. libasyncns is compatible with IPv6 if the underlying
+libc is.
+
+libasyncns is very tiny, consisting of just one header and one source file. It
+has no dependencies besides libc.
+
+WWW: http://0pointer.de/lennart/projects/libasyncns/
diff --git a/dns/linux-c7-libasyncns/pkg-plist.i386 b/dns/linux-c7-libasyncns/pkg-plist.i386
new file mode 100644
index 000000000000..a36ce6cd3ae7
--- /dev/null
+++ b/dns/linux-c7-libasyncns/pkg-plist.i386
@@ -0,0 +1,4 @@
+usr/lib/libasyncns.so.0
+usr/lib/libasyncns.so.0.3.1
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
diff --git a/dns/linux-c7-libasyncns/pkg-plist.x86_64 b/dns/linux-c7-libasyncns/pkg-plist.x86_64
new file mode 100644
index 000000000000..0023e7a7bc7c
--- /dev/null
+++ b/dns/linux-c7-libasyncns/pkg-plist.x86_64
@@ -0,0 +1,6 @@
+usr/lib/libasyncns.so.0
+usr/lib/libasyncns.so.0.3.1
+usr/lib64/libasyncns.so.0
+usr/lib64/libasyncns.so.0.3.1
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README