aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-10-07 05:56:53 +0800
committermandree <mandree@FreeBSD.org>2013-10-07 05:56:53 +0800
commitbffc57ad747c7f6ba3dd898f52039e6421db82fc (patch)
treec1e2b65796ed2885ef2aec067859e12ef99bf7ed /dns
parent6aacb0802363aa35dac505c128c38faa8a5ea0ee (diff)
downloadfreebsd-ports-gnome-bffc57ad747c7f6ba3dd898f52039e6421db82fc.tar.gz
freebsd-ports-gnome-bffc57ad747c7f6ba3dd898f52039e6421db82fc.tar.zst
freebsd-ports-gnome-bffc57ad747c7f6ba3dd898f52039e6421db82fc.zip
Update to 2.67 release candidate #3.
While here, support staging. Changelog for RC1: <http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2013q4/007572.html> Git commit log with newer rc2/rc3 tags: <http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=shortlog>
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsmasq-devel/Makefile46
-rw-r--r--dns/dnsmasq-devel/distinfo4
-rw-r--r--dns/dnsmasq-devel/pkg-plist3
3 files changed, 22 insertions, 31 deletions
diff --git a/dns/dnsmasq-devel/Makefile b/dns/dnsmasq-devel/Makefile
index 9907c8e5fce5..17ef5f66943d 100644
--- a/dns/dnsmasq-devel/Makefile
+++ b/dns/dnsmasq-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dnsmasq
-DISTVERSION= 2.66rc5
+DISTVERSION= 2.67rc3
CATEGORIES= dns ipv6
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/release-candidates/
PKGNAMESUFFIX= -devel
@@ -12,12 +12,8 @@ COMMENT= Lightweight DNS forwarder, DHCP, and TFTP server
LICENSE= GPLv2
-IGNORE= has no distfile available. Use dns/dnsmasq instead.
-
CONFLICTS_INSTALL=dnsmasq-2*
-MAN8= dnsmasq.8
-
PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
SUB_FILES= pkg-message
@@ -33,7 +29,6 @@ NLS_DESC= National Language Support (NLS, enables IDN)
IDN_DESC= International Domain Names (IDN) WITHOUT NLS
LUA_DESC= Support lease-change scripts in LUA
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if empty(PORT_OPTIONS:MIPV6)
@@ -41,22 +36,21 @@ CFLAGS+= -DNO_IPV6
.endif
.if ${PORT_OPTIONS:MNLS}
-USES+= pkgconfig
-LIB_DEPENDS+= idn:${PORTSDIR}/dns/libidn
+USES+= pkgconfig gettext
+LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
PLIST_SUB+= NLS=""
ALL_TARGET= all-i18n
-USES+= gettext
-USE_GMAKE= yes
+USES+= gmake
.else
PLIST_SUB+= NLS="@comment "
.if ${PORT_OPTIONS:MIDN}
CFLAGS+= -DHAVE_IDN
-LIB_DEPENDS+= idn:${PORTSDIR}/dns/libidn
+LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
.endif
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus
USES+= pkgconfig
CFLAGS+= -DHAVE_DBUS
.endif
@@ -88,28 +82,24 @@ pre-configure:
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${PREFIX}/etc
- ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.8 ${PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${STAGEDIR}${PREFIX}/etc
+ ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.8 ${STAGEDIR}${PREFIX}/man/man8
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MNLS}
.for i in de es fi fr id it no pl pt_BR ro
- ${MKDIR} ${PREFIX}/share/locale/${i}/LC_MESSAGES
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${i}/LC_MESSAGES
${INSTALL_DATA} ${WRKSRC}/src/${i}.mo \
- ${PREFIX}/share/locale/${i}/LC_MESSAGES/${PORTNAME}.mo
+ ${STAGEDIR}${PREFIX}/share/locale/${i}/LC_MESSAGES/${PORTNAME}.mo
.endfor
.endif
- ${MKDIR} ${EXAMPLESDIR}/dynamic-dnsmasq ${EXAMPLESDIR}/dnslist
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl ${EXAMPLESDIR}/dynamic-dnsmasq/
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/dnslist/dnslist.pl ${EXAMPLESDIR}/dnslist/
- ${INSTALL_DATA} ${WRKSRC}/contrib/dnslist/dhcp.css ${EXAMPLESDIR}/dnslist/
- ${INSTALL_DATA} ${WRKSRC}/contrib/dnslist/dnslist.tt2 ${EXAMPLESDIR}/dnslist/
- if [ ! -f ${PREFIX}/etc/dnsmasq.conf ]; then \
- ${CP} -p ${PREFIX}/etc/dnsmasq.conf.example ${PREFIX}/etc/dnsmasq.conf; \
- fi
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/dynamic-dnsmasq ${STAGEDIR}${EXAMPLESDIR}/dnslist
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl ${STAGEDIR}${EXAMPLESDIR}/dynamic-dnsmasq/
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/dnslist/dnslist.pl ${STAGEDIR}${EXAMPLESDIR}/dnslist/
+ ${INSTALL_DATA} ${WRKSRC}/contrib/dnslist/dhcp.css ${STAGEDIR}${EXAMPLESDIR}/dnslist/
+ ${INSTALL_DATA} ${WRKSRC}/contrib/dnslist/dnslist.tt2 ${STAGEDIR}${EXAMPLESDIR}/dnslist/
.include <bsd.port.post.mk>
diff --git a/dns/dnsmasq-devel/distinfo b/dns/dnsmasq-devel/distinfo
index 1233a27b6ee0..b8c077e0aa3a 100644
--- a/dns/dnsmasq-devel/distinfo
+++ b/dns/dnsmasq-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dnsmasq-2.66rc5.tar.xz) = 4f38cbae7daa9cc45c5a2f3fb0255b7529ce6989e8fadbaf930cb3416f26f0ed
-SIZE (dnsmasq-2.66rc5.tar.xz) = 412300
+SHA256 (dnsmasq-2.67rc3.tar.xz) = 2db4a3d8d7358a91ecf2ec9127ccc9ba878cf7c000337570a14434ee8628d153
+SIZE (dnsmasq-2.67rc3.tar.xz) = 427608
diff --git a/dns/dnsmasq-devel/pkg-plist b/dns/dnsmasq-devel/pkg-plist
index a6881d038e9d..d5ae548e866b 100644
--- a/dns/dnsmasq-devel/pkg-plist
+++ b/dns/dnsmasq-devel/pkg-plist
@@ -1,7 +1,8 @@
sbin/dnsmasq
-@exec if [ ! -f %D/etc/dnsmasq.conf ]; then cp -p %D/%F %B/dnsmasq.conf; fi
@unexec if cmp -s %D/etc/dnsmasq.conf %D/etc/dnsmasq.conf.example ; then rm -f %D/etc/dnsmasq.conf ; fi
etc/dnsmasq.conf.example
+@exec if [ ! -f %D/etc/dnsmasq.conf ]; then cp -p %D/%F %B/dnsmasq.conf; fi
+man/man8/dnsmasq.8.gz
%%EXAMPLESDIR%%/dnslist/dhcp.css
%%EXAMPLESDIR%%/dnslist/dnslist.pl
%%EXAMPLESDIR%%/dnslist/dnslist.tt2