aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-01-16 01:17:27 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-01-16 01:17:27 +0800
commitdfa946f4e679108709f45d19965a798a3c0a4da5 (patch)
treeb8e1287acfe187cce350739b2b714ede0d43589b /dns
parent5c456334fa0a6058db8ba2301af46d5cbc644dfc (diff)
downloadfreebsd-ports-gnome-dfa946f4e679108709f45d19965a798a3c0a4da5.tar.gz
freebsd-ports-gnome-dfa946f4e679108709f45d19965a798a3c0a4da5.tar.zst
freebsd-ports-gnome-dfa946f4e679108709f45d19965a798a3c0a4da5.zip
Add libdecaf support
- Mark CONFLICTS_INSTALL with dns/powerdns-recursor - Chase shlib change of security/botan2 - Bump PORTREVISION for dependency change PR: 225178 Submitted by: Ralf van der Enden <tremere@cainites.net> (maintainer)
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-recursor40/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/dns/powerdns-recursor40/Makefile b/dns/powerdns-recursor40/Makefile
index 26a7a0753d26..e6d81f518987 100644
--- a/dns/powerdns-recursor40/Makefile
+++ b/dns/powerdns-recursor40/Makefile
@@ -3,6 +3,7 @@
PORTNAME= recursor
DISTVERSION= 4.0.8
+PORTREVISION= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
PKGNAMEPREFIX= powerdns-
@@ -23,6 +24,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libboost_context.so:devel/boost-libs \
libprotobuf.so:devel/protobuf
+CONFLICTS_INSTALL= powerdns-recursor
+
USES= compiler:c++11-lib cpe gmake localbase:ldflags pkgconfig ssl tar:bzip2
GNU_CONFIGURE= YES
CXXFLAGS+= -D_GLIBCXX_USE_C99
@@ -39,7 +42,7 @@ OPTIONS_RADIO= LUA_RG
OPTIONS_RADIO_LUA_RG= LUA LUAJIT
LUAJIT_DESC= Enable LuaJIT
LUA_RG_DESC= Lua Engine
-OPTALGO_DESC= Enable optional algorithms (12 & 15)
+OPTALGO_DESC= Enable optional algorithms (12, 15 & 16)
SETUID_DESC= Run as pdns_recursor user
LUA_CONFIGURE_WITH= lua
@@ -49,8 +52,10 @@ LUAJIT_CONFIGURE_WITH= luajit
LUAJIT_LIB_DEPENDS= libluajit-5.1.so.2:lang/luajit
OPTALGO_CONFIGURE_ON= --enable-botan \
+ --enable-libdecaf \
--enable-libsodium
OPTALGO_LIB_DEPENDS= libbotan-2.so:security/botan2 \
+ libdecaf.so:security/libdecaf \
libsodium.so:security/libsodium
SETUID_VARS= USERS=pdns_recursor GROUPS=pdns