aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2014-02-12 18:46:24 +0800
committererwin <erwin@FreeBSD.org>2014-02-12 18:46:24 +0800
commit15a91e0d2deb48f98295a1c56b742d277229328c (patch)
treed474a19fda3ff435f4a612d93eb7204b5c8a03c1 /dns
parent2423fddbb07a4a8bc8b239e388ed26b5d3815fe5 (diff)
downloadfreebsd-ports-gnome-15a91e0d2deb48f98295a1c56b742d277229328c.tar.gz
freebsd-ports-gnome-15a91e0d2deb48f98295a1c56b742d277229328c.tar.zst
freebsd-ports-gnome-15a91e0d2deb48f98295a1c56b742d277229328c.zip
There was a wrong rc script in the port preventing the daemon to run.
Added STAGING support Added LICENSE (NSD3CLAUSE) statement Other small changes to make portlint more happy PR: 186631 Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer)
Diffstat (limited to 'dns')
-rw-r--r--dns/nsd/Makefile14
-rw-r--r--dns/nsd/files/nsd.in13
-rw-r--r--dns/nsd/pkg-message2
3 files changed, 16 insertions, 13 deletions
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index 29244e40f51f..f04ee2bc0496 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nsd
PORTVERSION= 4.0.1
+PORTREVISION= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/ \
ftp://ftp.rhnet.is/pub/nsd/
@@ -10,7 +11,9 @@ MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/ \
MAINTAINER= jaap@NLnetLabs.nl
COMMENT= An authoritative only non-recursive name server
-CONFLICTS= nsd-[0-]* nsd3-*
+LICENSE= BSD3CLAUSE
+
+CONFLICTS= nsd-[0-3]* nsd3-[0-9]*
USE_RC_SUBR= nsd
@@ -46,7 +49,7 @@ PORTDOCS= CREDITS ChangeLog LICENSE NSD-DATABASE NSD-DIFFFILE \
differences.tex
OPTIONS_DEFINE= ROOT_SERVER LARGEFILE IPV6 BIND8_STATS CHECKING \
- MINRESPSIZE NSEC3 NSEC3PREHASH MMAP MAXIPS DOCS EUI_RRTYPES
+ MINRESPSIZE NSEC3 NSEC3PREHASH MMAP MAXIPS DOCS RRL EUI_RRTYPES
OPTIONS_DEFAULT= LARGEFILE IPV6 NSEC3 NSEC3PREHASH MINRESPSIZE RRL \
EUI_RRTYPES
@@ -62,7 +65,6 @@ MAXIPS_DESC= Raise max-ips from 8 to ${NSDMAX_IPS}
RRL_DESC= Response Rate Limiting
EUI_RRTYPES_DESC= EUI48 and EUI64 RRtypes support
-NO_STAGE= yes
.include <bsd.port.options.mk>
LIB_DEPENDS+= event-1:${PORTSDIR}/devel/libevent
@@ -132,11 +134,11 @@ pre-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/nsd.conf.sample \
- ${PREFIX}/etc/nsd/nsd.conf.sample
+ ${STAGEDIR}${PREFIX}/etc/nsd/nsd.conf.sample
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}/${f}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}/${f}
.endfor
.endif
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/dns/nsd/files/nsd.in b/dns/nsd/files/nsd.in
index 985435328fe2..18ab7879a3cb 100644
--- a/dns/nsd/files/nsd.in
+++ b/dns/nsd/files/nsd.in
@@ -12,21 +12,22 @@
# nsd_enable="YES"
#
+: ${nsd_enable="NO"}
+
. /etc/rc.subr
name=nsd
-rcvar=${name}_enable
+rcvar=nsd_enable
config=${nsd_config:=%%PREFIX%%/etc/nsd/nsd.conf}
required_files=${config}
-
-command=%%PREFIX%%/sbin/nsd-control
-command_args="start"
pidfile=`%%PREFIX%%/sbin/nsd-checkconf -o pidfile ${config}`
-procname=%%PREFIX%%/sbin/${name}
-
+command="%%PREFIX%%/sbin/${name}"
+command_args="-c ${required_files}"
extra_commands="reload"
+load_rc_config $name
+
run_rc_command "$1"
diff --git a/dns/nsd/pkg-message b/dns/nsd/pkg-message
index 3f45189f528e..705ce0043580 100644
--- a/dns/nsd/pkg-message
+++ b/dns/nsd/pkg-message
@@ -1,6 +1,6 @@
**************************************************************************
*
-* To run nsd from startup, add nsd_enable="YES" to your /etc/rc.conf
+* To run nsd from startup, add nsd_enable="YES" to your etc/rc.conf
*
* Starting with nsd version 4 the old nsdc control program has been
* replaced by nsd-control. This requires some manual setup with