aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2016-08-15 09:39:33 +0800
committerjunovitch <junovitch@FreeBSD.org>2016-08-15 09:39:33 +0800
commit706a19389521f042bbb312f047476646e83bcd17 (patch)
tree2d23b0e0e9d54c11e2447e2e3f50a89a8162b061 /dns
parente96de93dcbd58a18df4986a5145417c2558372a6 (diff)
downloadfreebsd-ports-gnome-706a19389521f042bbb312f047476646e83bcd17.tar.gz
freebsd-ports-gnome-706a19389521f042bbb312f047476646e83bcd17.tar.zst
freebsd-ports-gnome-706a19389521f042bbb312f047476646e83bcd17.zip
dns/powerdns-recursor: update 3.7.3 -> 4.0.1
- Mark BROKEN on FreeBSD 9 - Remove STATIC option, add LUAJIT option - Cleanup LUA option, SETUID, and BROKEN_sparc64 usage; use option helpers Changes: https://doc.powerdns.com/md/changelog/#powerdns-recursor-400 https://doc.powerdns.com/md/changelog/#powerdns-recursor-401 PR: 211148 Submitted by: Ralf van der Enden <tremere@cainites.net> (maintainer) Security: CVE-2016-6172 Security: https://vuxml.FreeBSD.org/freebsd/7d08e608-5e95-11e6-b334-002590263bf5.html
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-recursor/Makefile61
-rw-r--r--dns/powerdns-recursor/distinfo5
-rw-r--r--dns/powerdns-recursor/files/pdns-recursor.in1
3 files changed, 25 insertions, 42 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index b4367d51118a..34d3fd8836ae 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= recursor
-PORTVERSION= 3.7.3
+PORTVERSION= 4.0.1
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
PKGNAMEPREFIX= powerdns-
@@ -13,62 +13,43 @@ COMMENT= Advanced DNS recursor
LICENSE= GPLv2
-BUILD_DEPENDS= bjam:devel/boost-jam \
- ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
-USES= cpe gmake tar:bzip2
+BROKEN_sparc64= Does not compile on sparc64
+BROKEN_FreeBSD_9= linker error
+
+USES= compiler:c++11-lib cpe gmake pkgconfig ssl tar:bzip2
GNU_CONFIGURE= YES
CPE_VENDOR= powerdns
-OPTIONS_DEFINE= SETUID LUA STATIC
-OPTIONS_DEFAULT= SETUID
+OPTIONS_DEFINE= SETUID
+OPTIONS_DEFAULT= LUA SETUID
+OPTIONS_RADIO= LUA_RG
+OPTIONS_RADIO_LUA_RG= LUA LUAJIT
+LUAJIT_DESC= Enable LuaJIT
+LUA_RG_DESC= Lua Engine
SETUID_DESC= Run as pdns_recursor user
-STATIC_DESC= Build static binaries
-CXXFLAGS+= -I${PREFIX}/include
-LDFLAGS+= -L${PREFIX}/lib
+CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc/pdns
SUB_FILES= pkg-message
-.include <bsd.port.options.mk>
+LUA_CONFIGURE_WITH= lua
+LUA_USES= lua
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
+LUAJIT_CONFIGURE_WITH= luajit
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so.2:lang/luajit
+
+SETUID_EXTRA_PATCHES= ${PATCHDIR}/extrapatch-setuid
USE_RC_SUBR+= pdns-recursor
+.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:MSETUID}
-EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-setuid
USERS= pdns_recursor
GROUPS= pdns
.endif
-.if ${PORT_OPTIONS:MLUA}
-USES+= lua
-MAKE_ENV+=LUA=1
-MAKE_ENV+="LUA_CPPFLAGS_CONFIG=-I${LUA_INCDIR}"
-MAKE_ENV+="LUA_LIBS_CONFIG=-L${LUA_LIBDIR} -llua-${LUA_VER}"
-.endif
-
-.if ${PORT_OPTIONS:MSTATIC}
-MAKE_ENV+=STATIC=full
-.endif
-
-.if exists(/usr/include/ucontext.h)
-UCONTEXT!= ${AWK} '/setcontext/ { print "YES" }' \
- /usr/include/ucontext.h
-.if ${UCONTEXT} == ""
-BROKEN= requires setcontext()
-.endif
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's;SBINDIR=/usr/sbin/;SBINDIR=${PREFIX}/sbin/;' \
- -e 's;BINDIR=/usr/bin/;BINDIR=${PREFIX}/bin/;' \
- -e 's;SYSCONFDIR=/etc/powerdns/;SYSCONFDIR=${PREFIX}/etc/pdns/;' \
- -e 's;/usr/share;${MANPREFIX};' \
- ${WRKSRC}/Makefile.in
-
.include <bsd.port.mk>
diff --git a/dns/powerdns-recursor/distinfo b/dns/powerdns-recursor/distinfo
index 05148449f88f..3635c9139d1a 100644
--- a/dns/powerdns-recursor/distinfo
+++ b/dns/powerdns-recursor/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pdns-recursor-3.7.3.tar.bz2) = 859ca6071147dd2e2ac1b2a5c3d5c2cbff0f5cbc501660db4259e7cbf27fea11
-SIZE (pdns-recursor-3.7.3.tar.bz2) = 245192
+TIMESTAMP = 1470038617
+SHA256 (pdns-recursor-4.0.1.tar.bz2) = 472db541307c8ca83a846d260ecfc854fd8e879c1bb2ce5683a8df5d21e860b0
+SIZE (pdns-recursor-4.0.1.tar.bz2) = 1035584
diff --git a/dns/powerdns-recursor/files/pdns-recursor.in b/dns/powerdns-recursor/files/pdns-recursor.in
index 8c3310be695a..cfa9cb5c772f 100644
--- a/dns/powerdns-recursor/files/pdns-recursor.in
+++ b/dns/powerdns-recursor/files/pdns-recursor.in
@@ -23,6 +23,7 @@ name=pdns_recursor
rcvar=pdns_recursor_enable
command=%%PREFIX%%/sbin/pdns_recursor
+command_args="--daemon=yes"
# set defaults