aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-09-30 20:44:27 +0800
committermat <mat@FreeBSD.org>2016-09-30 20:44:27 +0800
commita83fa33eb880ddbfae0341f7f3eca6ad48a2010d (patch)
tree1e3816c6b0431d5bf2b413ecba00304335db56d2 /dns
parentb5518104a595200686b9df31ffd79183e3df9d20 (diff)
downloadfreebsd-ports-gnome-a83fa33eb880ddbfae0341f7f3eca6ad48a2010d.tar.gz
freebsd-ports-gnome-a83fa33eb880ddbfae0341f7f3eca6ad48a2010d.tar.zst
freebsd-ports-gnome-a83fa33eb880ddbfae0341f7f3eca6ad48a2010d.zip
So, on 9, it is failing to build it with jobs.
It builds .a before all the .o that are supposed to go in the .a are built. Imagine what happens after that... Reported by: Craig Leres Sponsored by: Absolight
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind910/Makefile4
-rw-r--r--dns/bind911/Makefile4
-rw-r--r--dns/bind99/Makefile4
4 files changed, 16 insertions, 0 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index b6306abb7c51..24be501569a7 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -238,6 +238,10 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
+.if ${OSVERSION} <= 1000000
+MAKE_JOBS_UNSAFE= yes
+.endif
+
.if ( ${PORT_OPTIONS:MGOST} || ${PORT_OPTIONS:MGOST_ASN1} ) && ${SSL_DEFAULT} == base
BROKEN= OpenSSL from the base system does not support GOST, add \
DEFAULT_VERSIONS+=ssl=openssl to your /etc/make.conf and rebuild everything \
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 9d1ed1347d3f..cde596102c3d 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -225,6 +225,10 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
+.if ${OSVERSION} <= 1000000
+MAKE_JOBS_UNSAFE= yes
+.endif
+
.if ( ${PORT_OPTIONS:MGOST} || ${PORT_OPTIONS:MGOST_ASN1} ) && ${SSL_DEFAULT} == base
BROKEN= OpenSSL from the base system does not support GOST, add \
DEFAULT_VERSIONS+=ssl=openssl to your /etc/make.conf and rebuild everything \
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index f74fea7f0887..2164bfa479f1 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -236,6 +236,10 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
+.if ${OSVERSION} <= 1000000
+MAKE_JOBS_UNSAFE= yes
+.endif
+
.if ( ${PORT_OPTIONS:MGOST} || ${PORT_OPTIONS:MGOST_ASN1} ) && ${SSL_DEFAULT} == base
BROKEN= OpenSSL from the base system does not support GOST, add \
DEFAULT_VERSIONS+=ssl=openssl to your /etc/make.conf and rebuild everything \
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 33adeba891ea..28ac8d26d7bc 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -190,6 +190,10 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
+.if ${OSVERSION} <= 1000000
+MAKE_JOBS_UNSAFE= yes
+.endif
+
.if ( ${PORT_OPTIONS:MGOST} ) && ${SSL_DEFAULT} == base
BROKEN= OpenSSL from the base system does not support GOST, add \
DEFAULT_VERSIONS+=ssl=openssl to your /etc/make.conf and rebuild everything \