aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-04-03 16:28:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-04-03 16:28:12 +0800
commit00f55ac3205f2d03536826167231b65ab8129409 (patch)
treebbddb37eb3a5c563b09b87e985b16e4d02debc4f /dns
parentcf7f1079ec5364d0607814f6ad44dd513d756f16 (diff)
downloadfreebsd-ports-gnome-00f55ac3205f2d03536826167231b65ab8129409.tar.gz
freebsd-ports-gnome-00f55ac3205f2d03536826167231b65ab8129409.tar.zst
freebsd-ports-gnome-00f55ac3205f2d03536826167231b65ab8129409.zip
- Add p5-Mozilla-PublicSuffix 0.1.6
Mozilla::PublicSuffix provides a single function that returns the public suffix of a domain name by referencing a parsed copy of Mozilla's Public Suffix List. From the official website at http://publicsuffix.org: A "public suffix" is one under which Internet users can directly register names. Some examples of public suffixes are .com, .co.uk and pvt.k12.wy.us. The Public Suffix List is a list of all known public suffixes. A copy of the official list is bundled with the distribution. As the official list continues to be updated, the bundled copy will inevitably fall out of date. Therefore, if the bundled copy of found to be over thirty days old, this distribution's installer provides the option to check for a new version of the list and download/use it if one is found. WWW: http://search.cpan.org/dist/Mozilla-PublicSuffix/ Feature safe: yes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-Mozilla-PublicSuffix/Makefile31
-rw-r--r--dns/p5-Mozilla-PublicSuffix/distinfo2
-rw-r--r--dns/p5-Mozilla-PublicSuffix/pkg-descr15
-rw-r--r--dns/p5-Mozilla-PublicSuffix/pkg-plist2
5 files changed, 51 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 7d85c2a18e14..fe77be3e297e 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -89,6 +89,7 @@
SUBDIR += p5-DNS-Zone
SUBDIR += p5-DNS-ZoneParse
SUBDIR += p5-Data-Validate-Domain
+ SUBDIR += p5-Mozilla-PublicSuffix
SUBDIR += p5-Net-Amazon-Route53
SUBDIR += p5-Net-Bonjour
SUBDIR += p5-Net-DNS
diff --git a/dns/p5-Mozilla-PublicSuffix/Makefile b/dns/p5-Mozilla-PublicSuffix/Makefile
new file mode 100644
index 000000000000..3ccbcb2b485f
--- /dev/null
+++ b/dns/p5-Mozilla-PublicSuffix/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Mozilla-PublicSuffix
+# Date created: 2012-03-14
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mozilla-PublicSuffix
+PORTVERSION= 0.1.6
+CATEGORIES= dns perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Get public suffix of domain name via Mozilla Public Suffix List
+
+BUILD_DEPENDS= p5-HTTP-Tiny>=0:${PORTSDIR}/www/p5-HTTP-Tiny \
+ p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
+
+PERL_MODBUILD= yes
+
+MAN3= Mozilla::PublicSuffix.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Mozilla-PublicSuffix/distinfo b/dns/p5-Mozilla-PublicSuffix/distinfo
new file mode 100644
index 000000000000..f0954e76ed6c
--- /dev/null
+++ b/dns/p5-Mozilla-PublicSuffix/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Mozilla-PublicSuffix-v0.1.6.tar.gz) = 9fa73542c425b8436007253b1079b3444f400acaf4c2384e5d73b93f8d1def30
+SIZE (Mozilla-PublicSuffix-v0.1.6.tar.gz) = 48136
diff --git a/dns/p5-Mozilla-PublicSuffix/pkg-descr b/dns/p5-Mozilla-PublicSuffix/pkg-descr
new file mode 100644
index 000000000000..7dda33d6d794
--- /dev/null
+++ b/dns/p5-Mozilla-PublicSuffix/pkg-descr
@@ -0,0 +1,15 @@
+Mozilla::PublicSuffix provides a single function that returns the public suffix
+of a domain name by referencing a parsed copy of Mozilla's Public Suffix List.
+From the official website at http://publicsuffix.org:
+
+A "public suffix" is one under which Internet users can directly register names.
+Some examples of public suffixes are .com, .co.uk and pvt.k12.wy.us. The Public
+Suffix List is a list of all known public suffixes.
+
+A copy of the official list is bundled with the distribution. As the official
+list continues to be updated, the bundled copy will inevitably fall out of date.
+Therefore, if the bundled copy of found to be over thirty days old, this
+distribution's installer provides the option to check for a new version of the
+list and download/use it if one is found.
+
+WWW: http://search.cpan.org/dist/Mozilla-PublicSuffix/
diff --git a/dns/p5-Mozilla-PublicSuffix/pkg-plist b/dns/p5-Mozilla-PublicSuffix/pkg-plist
new file mode 100644
index 000000000000..2603ef630854
--- /dev/null
+++ b/dns/p5-Mozilla-PublicSuffix/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Mozilla/PublicSuffix.pm
+@dirrmtry %%SITE_PERL%%/Mozilla