aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authordbaio <dbaio@FreeBSD.org>2017-10-14 21:15:15 +0800
committerdbaio <dbaio@FreeBSD.org>2017-10-14 21:15:15 +0800
commit447165356b5559730cb0bc724316b72dcbe94640 (patch)
tree85b12c6f3deff9ddcb822f9b18093482ccb825a8 /dns
parentef8f4349c1a79b6c3ab8e9cf56fd8109c2877ef9 (diff)
downloadfreebsd-ports-gnome-447165356b5559730cb0bc724316b72dcbe94640.tar.gz
freebsd-ports-gnome-447165356b5559730cb0bc724316b72dcbe94640.tar.zst
freebsd-ports-gnome-447165356b5559730cb0bc724316b72dcbe94640.zip
New port dns/dns2blackhole: Malware Prevention through Domain Blocking
dns2blackhole is a set of Bourne Shell csh scripts that fetch host files from public host file providers that contain the FQDN [ Fully Qualified Domain Names ] of sites that fall into the following categories, adware, malware, exploit, hijackers, harvesters, tracking, phishing, fake news, fraud, spam, sex, porn, gambling, advertisements, misleading marketing, illegal pharmacy, warez/piracy and others. The output of the dns2blackhole scripts is fed directly into the ports/package versions of unbound, named, and dnsmask DNS servers to block those FQDN thus protecting user devices from being compromised or bothered seeing things of no interest. The base built-in version of unbound titled "local_unbound" can also be configured to work using the dns2blackhole method. This black hole method is another layer of protection that you can customize to your needs. WWW: http://dns2blackhole.sourceforge.net/ PR: 222805 Submitted by: joeb1@a1poweruser.com
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/dns2blackhole/Makefile34
-rw-r--r--dns/dns2blackhole/distinfo3
-rw-r--r--dns/dns2blackhole/files/pkg-message.in10
-rw-r--r--dns/dns2blackhole/pkg-descr16
-rw-r--r--dns/dns2blackhole/pkg-plist7
6 files changed, 71 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 7c96baa3d040..be3e5618b946 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -29,6 +29,7 @@
SUBDIR += djbdns-tools
SUBDIR += dlint
SUBDIR += dnrd
+ SUBDIR += dns2blackhole
SUBDIR += dns2tcp
SUBDIR += dns_balance
SUBDIR += dnscap
diff --git a/dns/dns2blackhole/Makefile b/dns/dns2blackhole/Makefile
new file mode 100644
index 000000000000..e0ab9551c6ac
--- /dev/null
+++ b/dns/dns2blackhole/Makefile
@@ -0,0 +1,34 @@
+# Created by: Joe Barbish
+# $FreeBSD$
+
+PORTNAME= dns2blackhole
+PORTVERSION= 0.0
+CATEGORIES= dns
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= dns2blackhole1@a1poweruser.com
+COMMENT= Malware Prevention through Domain Blocking
+
+LICENSE= BSD2CLAUSE
+
+USES= tar:bzip2
+NO_BUILD= yes
+NO_ARCH= yes
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+.for f in dns2blackhole-update1 dns2blackhole-update2 dns2blackhole-sanitize \
+ dns2blackhole-sanitize dns2blackhole-sort-fqdn dns2blackhole-whitelist
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
+.endfor
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dns2blackhole-unbound.conf \
+ ${STAGEDIR}${ETCDIR}/dns2blackhole-unbound.conf.sample
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dns2blackhole-intro ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/dns/dns2blackhole/distinfo b/dns/dns2blackhole/distinfo
new file mode 100644
index 000000000000..578113900d76
--- /dev/null
+++ b/dns/dns2blackhole/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507239011
+SHA256 (dns2blackhole-0.0.tar.bz2) = ef5d9e36bcc4cfdac7edaab8d115102a4145cd6deba24f013898bf915c989990
+SIZE (dns2blackhole-0.0.tar.bz2) = 8993
diff --git a/dns/dns2blackhole/files/pkg-message.in b/dns/dns2blackhole/files/pkg-message.in
new file mode 100644
index 000000000000..00f230790cbf
--- /dev/null
+++ b/dns/dns2blackhole/files/pkg-message.in
@@ -0,0 +1,10 @@
+########################################################################
+
+ dns2blackhole
+
+ Malware Prevention through Domain Blocking (Black Hole)
+
+ For configuration and usage information read
+ %%DOCSDIR%%/dns2blackhole-intro
+
+########################################################################
diff --git a/dns/dns2blackhole/pkg-descr b/dns/dns2blackhole/pkg-descr
new file mode 100644
index 000000000000..1fac482a448c
--- /dev/null
+++ b/dns/dns2blackhole/pkg-descr
@@ -0,0 +1,16 @@
+Malware Prevention through Domain Blocking (Black Hole)
+
+dns2blackhole is a set of Bourne Shell csh scripts that fetch host files
+from public host file providers that contain the FQDN [ Fully Qualified
+Domain Names ] of sites that fall into the following categories, adware,
+malware, exploit, hijackers, harvesters, tracking, phishing, fake news,
+fraud, spam, sex, porn, gambling, advertisements, misleading marketing,
+illegal pharmacy, warez/piracy and others. The output of the dns2blackhole
+scripts is fed directly into the ports/package versions of unbound, named,
+and dnsmask DNS servers to block those FQDN thus protecting user
+devices from being compromised or bothered seeing things of no interest.
+The base built-in version of unbound titled "local_unbound" can also be
+configured to work using the dns2blackhole method. This black hole method
+is another layer of protection that you can customize to your needs.
+
+WWW: http://dns2blackhole.sourceforge.net/
diff --git a/dns/dns2blackhole/pkg-plist b/dns/dns2blackhole/pkg-plist
new file mode 100644
index 000000000000..0a3e80f47a6a
--- /dev/null
+++ b/dns/dns2blackhole/pkg-plist
@@ -0,0 +1,7 @@
+bin/dns2blackhole-update1
+bin/dns2blackhole-update2
+bin/dns2blackhole-sanitize
+bin/dns2blackhole-sort-fqdn
+bin/dns2blackhole-whitelist
+@sample %%ETCDIR%%/dns2blackhole-unbound.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/dns2blackhole-intro