aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-05-28 17:47:31 +0800
committermat <mat@FreeBSD.org>2018-05-28 17:47:31 +0800
commit46c6008c9f6695b13f6c83f2facf7d5d45dd567e (patch)
treeaf3076c3f871e053eedade878350952062d5674f /dns
parentac22010d902ec3b44408c9393e4e4e93b9e7e994 (diff)
downloadfreebsd-ports-gnome-46c6008c9f6695b13f6c83f2facf7d5d45dd567e.tar.gz
freebsd-ports-gnome-46c6008c9f6695b13f6c83f2facf7d5d45dd567e.tar.zst
freebsd-ports-gnome-46c6008c9f6695b13f6c83f2facf7d5d45dd567e.zip
Update to latest commit.
Sponsored by: Absolight
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind9-devel/files/patch-configure8
4 files changed, 17 insertions, 17 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index b5244addb202..561fda2785f7 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -34,13 +34,13 @@ LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.0a0.2018.05.18
+ISCVERSION= 9.13.0a0.2018.05.25
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= e8dd921ef96582c1dbed099015f8e45e00ede439
+GL_COMMIT= 58ad54e7a1f1725c2c6956813e23169b911a05b8
# XXX: remove tar:bz2
USES= cpe libedit ssl tar:bz2
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index fb2a6f2c8b7a..a0edf677ce38 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1526897763
-SHA256 (isc-projects-bind9-e8dd921ef96582c1dbed099015f8e45e00ede439_GL0.tar.gz) = 986f430c0e814dfd06ed457eb8c39955e6e61a3b628a03f5ffd103de4313bdfb
-SIZE (isc-projects-bind9-e8dd921ef96582c1dbed099015f8e45e00ede439_GL0.tar.gz) = 8922126
+TIMESTAMP = 1527498897
+SHA256 (isc-projects-bind9-58ad54e7a1f1725c2c6956813e23169b911a05b8_GL0.tar.gz) = 4dee3ec7653cce209cb1bf932fc3c08205a975948e126fbe05a289264a05fa9c
+SIZE (isc-projects-bind9-58ad54e7a1f1725c2c6956813e23169b911a05b8_GL0.tar.gz) = 8929489
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index d659e08099dc..978b23a02cd4 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2018-05-18 05:44:02 UTC
+--- bin/named/config.c.orig 2018-05-25 19:58:32 UTC
+++ bin/named/config.c
@@ -174,12 +174,14 @@ options {\n\
max-recursion-queries 75;\n\
@@ -15,9 +15,9 @@
provide-ixfr true;\n\
query-source address *;\n\
query-source-v6 address *;\n\
---- bin/named/server.c.orig 2018-05-18 05:44:02 UTC
+--- bin/named/server.c.orig 2018-05-25 19:58:32 UTC
+++ bin/named/server.c
-@@ -4072,6 +4072,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4074,6 +4074,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -34,7 +34,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-05-18 05:44:02 UTC
+--- lib/dns/include/dns/view.h.orig 2018-05-25 19:58:32 UTC
+++ lib/dns/include/dns/view.h
@@ -149,6 +149,8 @@ struct dns_view {
isc_boolean_t requestnsid;
@@ -45,9 +45,9 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-05-18 05:44:02 UTC
+--- lib/dns/resolver.c.orig 2018-05-25 19:58:32 UTC
+++ lib/dns/resolver.c
-@@ -5746,6 +5746,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5748,6 +5748,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -66,9 +66,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-05-18 05:44:02 UTC
+--- lib/isccfg/namedconf.c.orig 2018-05-25 19:58:32 UTC
+++ lib/isccfg/namedconf.c
-@@ -1916,6 +1916,8 @@ view_clauses[] = {
+@@ -1915,6 +1915,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index bcc648ba45e4..254e2d165364 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-05-18 05:44:02 UTC
+--- configure.orig 2018-05-25 19:58:32 UTC
+++ configure
-@@ -14770,27 +14770,9 @@ done
+@@ -14757,27 +14757,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14833,47 +14815,7 @@ $as_echo "no" >&6; } ;;
+@@ -14820,47 +14802,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23338,7 +23280,7 @@ $as_echo "" >&6; }
+@@ -23329,7 +23271,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).