aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-08-06 07:19:36 +0800
committerdougb <dougb@FreeBSD.org>2012-08-06 07:19:36 +0800
commitf0d9f58b7f1825fb95236f427a6400ad54ad4b5e (patch)
tree1ed78841e1757014ccc09581c61c3683992d3f77 /dns
parent37b2a027341f57b44383efc005905ca41779dce6 (diff)
downloadfreebsd-ports-gnome-f0d9f58b7f1825fb95236f427a6400ad54ad4b5e.tar.gz
freebsd-ports-gnome-f0d9f58b7f1825fb95236f427a6400ad54ad4b5e.tar.zst
freebsd-ports-gnome-f0d9f58b7f1825fb95236f427a6400ad54ad4b5e.zip
Move the rc.d scripts of the form *.sh.in to *.in
Where necessary add $FreeBSD$ to the file No PORTREVISION bump necessary because this is a no-op
Diffstat (limited to 'dns')
-rw-r--r--dns/dnrd/Makefile2
-rw-r--r--dns/dnrd/files/dnrd.in (renamed from dns/dnrd/files/dnrd.sh.in)7
-rw-r--r--dns/dns_balance/Makefile2
-rw-r--r--dns/dns_balance/files/dns_balance.in (renamed from dns/dns_balance/files/dns_balance.sh.in)0
-rw-r--r--dns/dnsmasq/Makefile2
-rw-r--r--dns/dnsmasq/files/dnsmasq.in (renamed from dns/dnsmasq/files/dnsmasq.sh.in)4
-rw-r--r--dns/dualserver/Makefile2
-rw-r--r--dns/dualserver/files/dualserver.in (renamed from dns/dualserver/files/dualserver.sh.in)3
-rw-r--r--dns/ez-ipupdate/Makefile2
-rw-r--r--dns/ez-ipupdate/files/ez-ipupdate.in (renamed from dns/ez-ipupdate/files/ez-ipupdate.sh.in)0
-rw-r--r--dns/mydns/Makefile2
-rw-r--r--dns/mydns/files/mydns.in (renamed from dns/mydns/files/mydns.sh.in)0
12 files changed, 14 insertions, 12 deletions
diff --git a/dns/dnrd/Makefile b/dns/dnrd/Makefile
index efa4da7ba749..c02818b35e1d 100644
--- a/dns/dnrd/Makefile
+++ b/dns/dnrd/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= natanael.copa@gmail.com
COMMENT= A proxy DNS daemon
USE_GMAKE= yes
-USE_RC_SUBR= ${PORTNAME}.sh
+USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
diff --git a/dns/dnrd/files/dnrd.sh.in b/dns/dnrd/files/dnrd.in
index 1e801c5d493d..9afbe2e77632 100644
--- a/dns/dnrd/files/dnrd.sh.in
+++ b/dns/dnrd/files/dnrd.in
@@ -1,5 +1,6 @@
-#! /bin/sh
-#
+#!/bin/sh
+
+# $FreeBSD$
#
# PROVIDE: dnrd
# REQUIRE: DAEMON NETWORKING SERVERS
@@ -7,7 +8,6 @@
# Add the following line to /etc/rc.conf to enable dnrd:
#
# dnrd_enable="YES"
-#
# override these variables in /etc/rc.conf
dnrd_enable=${dnrd_enable-"NO"}
@@ -31,4 +31,3 @@ case $1 in
run_rc_command "$1"
;;
esac
-
diff --git a/dns/dns_balance/Makefile b/dns/dns_balance/Makefile
index 6de617276799..7bb64354719d 100644
--- a/dns/dns_balance/Makefile
+++ b/dns/dns_balance/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A dynamic load-balancing DNS server
USE_RUBY= yes
-USE_RC_SUBR= dns_balance.sh
+USE_RC_SUBR= dns_balance
NO_BUILD= yes
diff --git a/dns/dns_balance/files/dns_balance.sh.in b/dns/dns_balance/files/dns_balance.in
index 50a51098631c..50a51098631c 100644
--- a/dns/dns_balance/files/dns_balance.sh.in
+++ b/dns/dns_balance/files/dns_balance.in
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index 9c66f98caa72..9c61e28991c0 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -71,7 +71,7 @@ CFLAGS+= -DHAVE_LUASCRIPT
USE_LUA= 5.1
.endif
-USE_RC_SUBR= dnsmasq.sh
+USE_RC_SUBR= dnsmasq
.include <bsd.port.pre.mk>
diff --git a/dns/dnsmasq/files/dnsmasq.sh.in b/dns/dnsmasq/files/dnsmasq.in
index 26d7b267d301..ae752c379bae 100644
--- a/dns/dnsmasq/files/dnsmasq.sh.in
+++ b/dns/dnsmasq/files/dnsmasq.in
@@ -1,4 +1,6 @@
-#! /bin/sh
+#!/bin/sh
+
+# $FreeBSD$
#
# PROVIDE: dnsmasq
# REQUIRE: SERVERS
diff --git a/dns/dualserver/Makefile b/dns/dualserver/Makefile
index 2391995f85be..e9266018788a 100644
--- a/dns/dualserver/Makefile
+++ b/dns/dualserver/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Combined DHCP/DNS server for small LANs
USE_DOS2UNIX= yes
-USE_RC_SUBR= dualserver.sh
+USE_RC_SUBR= dualserver
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= sbin/dualserver etc/dualserver.conf.sample
diff --git a/dns/dualserver/files/dualserver.sh.in b/dns/dualserver/files/dualserver.in
index 9c90a19714bd..b094232a491b 100644
--- a/dns/dualserver/files/dualserver.sh.in
+++ b/dns/dualserver/files/dualserver.in
@@ -1,6 +1,7 @@
#!/bin/sh
-#
+# $FreeBSD$
+#
# PROVIDE: dualserver
# REQUIRE: SERVERS
# BEFORE:
diff --git a/dns/ez-ipupdate/Makefile b/dns/ez-ipupdate/Makefile
index 134617547a0b..4aacc06d47e3 100644
--- a/dns/ez-ipupdate/Makefile
+++ b/dns/ez-ipupdate/Makefile
@@ -16,7 +16,7 @@ MASTER_SITES= http://dyn.pl/client/UNIX/ez-ipupdate/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Update your host name on any dynamic DNS service
-USE_RC_SUBR= ez-ipupdate.sh
+USE_RC_SUBR= ez-ipupdate
GNU_CONFIGURE= yes
post-install:
diff --git a/dns/ez-ipupdate/files/ez-ipupdate.sh.in b/dns/ez-ipupdate/files/ez-ipupdate.in
index 1209b62e4770..1209b62e4770 100644
--- a/dns/ez-ipupdate/files/ez-ipupdate.sh.in
+++ b/dns/ez-ipupdate/files/ez-ipupdate.in
diff --git a/dns/mydns/Makefile b/dns/mydns/Makefile
index 565c27ad5ecc..fdc188b079c8 100644
--- a/dns/mydns/Makefile
+++ b/dns/mydns/Makefile
@@ -19,7 +19,7 @@ CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc
USE_ICONV= yes
USE_BZIP2= yes
-USE_RC_SUBR= mydns.sh
+USE_RC_SUBR= mydns
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/dns/mydns/files/mydns.sh.in b/dns/mydns/files/mydns.in
index 896a550fda4b..896a550fda4b 100644
--- a/dns/mydns/files/mydns.sh.in
+++ b/dns/mydns/files/mydns.in