aboutsummaryrefslogtreecommitdiffstats
path: root/editors/aee
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-05 03:17:37 +0800
committerpawel <pawel@FreeBSD.org>2014-04-05 03:17:37 +0800
commitbb4b3cf9a2a19006df9f06b2dba2391e5c94af0b (patch)
treebfa38d7e156e289ad7db3d0c0141c8c6ca70fbdf /editors/aee
parent9bb326f3e03a3ff8315e88d9b531dc5d4ffbcb1d (diff)
downloadfreebsd-ports-gnome-bb4b3cf9a2a19006df9f06b2dba2391e5c94af0b.tar.gz
freebsd-ports-gnome-bb4b3cf9a2a19006df9f06b2dba2391e5c94af0b.tar.zst
freebsd-ports-gnome-bb4b3cf9a2a19006df9f06b2dba2391e5c94af0b.zip
Add staging support
Diffstat (limited to 'editors/aee')
-rw-r--r--editors/aee/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/editors/aee/Makefile b/editors/aee/Makefile
index 41524cafce75..c9e2a46eebe3 100644
--- a/editors/aee/Makefile
+++ b/editors/aee/Makefile
@@ -17,11 +17,9 @@ XAE_DESC= Build X11 version 'xae'
MAKE_JOBS_UNSAFE= yes
-MAN1= aee.1
-PLIST_FILES= bin/aee bin/rae %%DATADIR%%/help.ae
+PLIST_FILES= bin/aee bin/rae man/man1/aee.1.gz %%DATADIR%%/help.ae
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MXAE}
@@ -46,14 +44,14 @@ post-patch:
.endfor
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} aee ${PREFIX}/bin)
- (cd ${PREFIX}/bin && ${LN} aee rae)
- (cd ${WRKSRC} && ${INSTALL_MAN} aee.1 ${MANPREFIX}/man/man1)
- @${MKDIR} ${DATADIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} help.ae ${DATADIR})
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} aee ${STAGEDIR}${PREFIX}/bin)
+ (cd ${STAGEDIR}${PREFIX}/bin && ${LN} aee rae)
+ (cd ${WRKSRC} && ${INSTALL_MAN} aee.1 ${STAGEDIR}${MANPREFIX}/man/man1)
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} help.ae ${STAGEDIR}${DATADIR})
.if ${PORT_OPTIONS:MXAE}
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} xae ${PREFIX}/bin)
- (cd ${PREFIX}/bin && ${LN} xae rxae)
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} xae ${STAGEDIR}${PREFIX}/bin)
+ (cd ${STAGEDIR}${PREFIX}/bin && ${LN} xae rxae)
.endif
.include <bsd.port.mk>