aboutsummaryrefslogtreecommitdiffstats
path: root/editors/apel
diff options
context:
space:
mode:
authorshige <shige@FreeBSD.org>1999-09-08 22:53:08 +0800
committershige <shige@FreeBSD.org>1999-09-08 22:53:08 +0800
commit8d52b50186ef93c27dc763607ceb7a0ada31715a (patch)
treee794a6b0ae0245c7ce69abfbfda60f6fa684510e /editors/apel
parent1983f61d6275af721e44c3ffc829b4de1481e837 (diff)
downloadfreebsd-ports-gnome-8d52b50186ef93c27dc763607ceb7a0ada31715a.tar.gz
freebsd-ports-gnome-8d52b50186ef93c27dc763607ceb7a0ada31715a.tar.zst
freebsd-ports-gnome-8d52b50186ef93c27dc763607ceb7a0ada31715a.zip
Depend on custom-emacs or custom-mule.
We use a custom library instead of tinycustom.el included in apel.
Diffstat (limited to 'editors/apel')
-rw-r--r--editors/apel/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/editors/apel/Makefile b/editors/apel/Makefile
index ac2a866ddcbd..cfb84bd18f10 100644
--- a/editors/apel/Makefile
+++ b/editors/apel/Makefile
@@ -53,6 +53,13 @@ RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}-common
.else
RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
.endif
+
+# depends on custom: emacs-19.34 or mule-19.34
+.if (${EMACS_VER} == "19.34")
+BUILD_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT}
+RUN_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT}
+.endif
+
SCRIPTS_ENV= EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER} \
EMACS_LIBDIR_WITH_VER=${EMACS_LIBDIR_WITH_VER} \
TARGETS="${APEL_SETUPEL}"