aboutsummaryrefslogtreecommitdiffstats
path: root/editors/apel
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2014-06-22 17:22:52 +0800
committernobutaka <nobutaka@FreeBSD.org>2014-06-22 17:22:52 +0800
commitfd1d9d7543b7b950cf92bd7db82a9f9c42f5411a (patch)
tree5386f97639a0696dd57c0770e5fa8f31160dff58 /editors/apel
parentfa78310563279485ee3bfc4fd8724f747cfd3c56 (diff)
downloadfreebsd-ports-gnome-fd1d9d7543b7b950cf92bd7db82a9f9c42f5411a.tar.gz
freebsd-ports-gnome-fd1d9d7543b7b950cf92bd7db82a9f9c42f5411a.tar.zst
freebsd-ports-gnome-fd1d9d7543b7b950cf92bd7db82a9f9c42f5411a.zip
Support staging.
Diffstat (limited to 'editors/apel')
-rw-r--r--editors/apel/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/editors/apel/Makefile b/editors/apel/Makefile
index 33b353729a82..cf5996557414 100644
--- a/editors/apel/Makefile
+++ b/editors/apel/Makefile
@@ -27,14 +27,13 @@ DESCR= ${PKGDIR}/pkg-descr
# target name for make build
ALL_TARGET?= elc
# environments
-MAKE_ARGS+= PREFIX="${LOCALBASE}" \
- LISPDIR="${APEL_LISPDIR}" \
- VERSION_SPECIFIC_LISPDIR="${APEL_VERSION_SPECIFIC_LISPDIR}"
+MAKE_ARGS+= PREFIX="${STAGEDIR}${LOCALBASE}" \
+ LISPDIR="${STAGEDIR}${APEL_LISPDIR}" \
+ VERSION_SPECIFIC_LISPDIR="${STAGEDIR}${APEL_VERSION_SPECIFIC_LISPDIR}"
OPTIONS_DEFINE= DOCS
OPTINOS_DEFAULT= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
@@ -46,10 +45,10 @@ PLIST_SUB+= EMACS23="@comment " NOEMACS23=""
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC} ; \
for i in ChangeLog README.* ; do \
- ${INSTALL_DATA} $${i} ${DOCSDIR} ; \
+ ${INSTALL_DATA} $${i} ${STAGEDIR}${DOCSDIR} ; \
done)
.endif