aboutsummaryrefslogtreecommitdiffstats
path: root/editors/bed
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-09-19 09:44:48 +0800
committerleeym <leeym@FreeBSD.org>2004-09-19 09:44:48 +0800
commit5465f1bc8921ffee2299184d035cda56b975c33b (patch)
treea7c7990abc0a89c0c1cb1f01b9f8072b46a9c22e /editors/bed
parentd712d959a71459e80504386200b023489f48fff8 (diff)
downloadfreebsd-ports-gnome-5465f1bc8921ffee2299184d035cda56b975c33b.tar.gz
freebsd-ports-gnome-5465f1bc8921ffee2299184d035cda56b975c33b.tar.zst
freebsd-ports-gnome-5465f1bc8921ffee2299184d035cda56b975c33b.zip
- add USE_GCC=2.95 and unbreak this port
- reorder Makefile and make portlint happier - indent Makefile PR: 71850 Submitted by: leeym Approved by: portmgr (marcus)
Diffstat (limited to 'editors/bed')
-rw-r--r--editors/bed/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/editors/bed/Makefile b/editors/bed/Makefile
index 1d1e53c5d08f..43c9317b1a86 100644
--- a/editors/bed/Makefile
+++ b/editors/bed/Makefile
@@ -9,26 +9,27 @@ PORTNAME= bed
PORTVERSION= 0.2.19
PORTREVISION= 2
CATEGORIES= editors
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/editors/terminal
-EXTRACT_SUFX= .src.tar.gz
+EXTRACT_SUFX= .src.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Variable dataformat binary editor
+BUILD_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash2
+
# Cannot guarantee rxvt will have menubar enabled on bento.
.if defined(PACKAGE_BUILDING)
WITHOUT_X11= yes
.endif
-BUILD_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash2
.if !defined(WITHOUT_X11)
PATCH_DEPENDS+= ${X11BASE}/bin/rxvt:${PORTSDIR}/x11/rxvt
-RUN_DEPENDS= ${X11BASE}/bin/rxvt:${PORTSDIR}/x11/rxvt
+RUN_DEPENDS+= ${X11BASE}/bin/rxvt:${PORTSDIR}/x11/rxvt
.endif
GNU_CONFIGURE= yes
-
+USE_GCC= 2.95
USE_GMAKE= yes
MAN1= bed.1 xbed.1
@@ -49,10 +50,10 @@ BROKEN= "Hangs during configure"
.endif
.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+= --without-x
-PLIST_SUB+= X11="@comment "
+CONFIGURE_ARGS+=--without-x
+PLIST_SUB+= X11="@comment "
.else
-PLIST_SUB+= X11=""
+PLIST_SUB+= X11=""
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
pre-configure: