aboutsummaryrefslogtreecommitdiffstats
path: root/editors/bitmap
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2006-11-05 19:53:47 +0800
committerume <ume@FreeBSD.org>2006-11-05 19:53:47 +0800
commit22fc5cc3fc1147e8a65d3d3f45c275e04a8a25af (patch)
tree1e286752a7eee9ee9a9e4c3f0730778e6dfb1e4d /editors/bitmap
parent5b8dd41652e08e14358112b9429e6b32c1fe0a40 (diff)
downloadfreebsd-ports-gnome-22fc5cc3fc1147e8a65d3d3f45c275e04a8a25af.tar.gz
freebsd-ports-gnome-22fc5cc3fc1147e8a65d3d3f45c275e04a8a25af.tar.zst
freebsd-ports-gnome-22fc5cc3fc1147e8a65d3d3f45c275e04a8a25af.zip
Obey user setting of EMACS_PORT_NAME to be friendry for emacs22.
Diffstat (limited to 'editors/bitmap')
-rw-r--r--editors/bitmap/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/editors/bitmap/Makefile b/editors/bitmap/Makefile
index d65acf2706cf..a39243142827 100644
--- a/editors/bitmap/Makefile
+++ b/editors/bitmap/Makefile
@@ -41,8 +41,8 @@ PORTCLASS?= master
# Setup EMACS_PORT_NAME variable.
.if (${PORTCLASS} == "master")
USE_EMACS= yes
-EMACS_PORT_NAME= emacs21
-DEPPORT_SUFFIX=
+EMACS_PORT_NAME?= emacs21
+DEPPORT_SUFFIX=
.else
DEPPORT_SUFFIX= -${EMACS_PORT_NAME}
.endif
@@ -67,6 +67,10 @@ MAKE_ARGS= PREFIX="${LOCALBASE}" \
# depends on apel
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX}
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX}
+.if (${EMACS_PORT_NAME} == "emacs21") || (${EMACS_PORT_NAME} == "emacs22")
+DESCR= ${PKGDIR}/pkg-descr.emacs21
+PLIST= ${PKGDIR}/pkg-plist.emacs21
+.endif
.else
.BEGIN:
@${ECHO} "Error: Bad port."