aboutsummaryrefslogtreecommitdiffstats
path: root/editors/bitmap
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-02-03 12:55:50 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-02-03 12:55:50 +0800
commit3d413c3550145ce82f7fe9fdb60c91d215155cba (patch)
tree75ecd0066d3d1f3baa83236af19eea020aab77ca /editors/bitmap
parent756a6c41882635290ee5b81b9bbae27f4cff2124 (diff)
downloadfreebsd-ports-gnome-3d413c3550145ce82f7fe9fdb60c91d215155cba.tar.gz
freebsd-ports-gnome-3d413c3550145ce82f7fe9fdb60c91d215155cba.tar.zst
freebsd-ports-gnome-3d413c3550145ce82f7fe9fdb60c91d215155cba.zip
- Fix compilation without update-coding-systems-internal function.
- Allow build with emacs-devel port. Obtained from: debian
Diffstat (limited to 'editors/bitmap')
-rw-r--r--editors/bitmap/Makefile4
-rw-r--r--editors/bitmap/files/patch-bitmap-ci.el12
2 files changed, 14 insertions, 2 deletions
diff --git a/editors/bitmap/Makefile b/editors/bitmap/Makefile
index a2e368858b74..0ce868aa17f5 100644
--- a/editors/bitmap/Makefile
+++ b/editors/bitmap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bitmap
PORTVERSION= ${BITMAP_VER}
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= editors elisp
MASTER_SITES= ftp://ftp.jpl.org/pub/elisp/bitmap/ \
ftp://ftp.jpl.org/pub/elisp/bitmap/snapshots/
@@ -66,7 +66,7 @@ MAKE_ARGS= PREFIX="${LOCALBASE}" \
# depends on apel
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX}
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX}
-.if (${EMACS_PORT_NAME} == "emacs21") || (${EMACS_PORT_NAME} == "emacs22")
+.if (${EMACS_PORT_NAME} == "emacs21") || (${EMACS_PORT_NAME} == "emacs22") || (${EMACS_PORT_NAME} == "emacs-devel")
DESCR= ${PKGDIR}/pkg-descr.emacs21
PLIST= ${PKGDIR}/pkg-plist.emacs21
.endif
diff --git a/editors/bitmap/files/patch-bitmap-ci.el b/editors/bitmap/files/patch-bitmap-ci.el
new file mode 100644
index 000000000000..8a2f44391bed
--- /dev/null
+++ b/editors/bitmap/files/patch-bitmap-ci.el
@@ -0,0 +1,12 @@
+--- bitmap-ci.el.orig 2009-02-03 11:09:09.000000000 +0900
++++ bitmap-ci.el 2009-02-03 11:09:36.000000000 +0900
+@@ -50,7 +50,8 @@
+ "BITMAP" "BITMAP.8x16" "8x16 bitmap elements"])
+ ;; `define-charset' won't call `update-coding-systems-internal'
+ ;; if the released version of Emacs 21.1 is running.
+- (update-coding-systems-internal))
++ (if (fboundp 'update-coding-systems-internal)
++ (update-coding-systems-internal)))
+ (let ((alterable (and (charsetp bitmap-alterable-charset)
+ (eq 2 (charset-dimension bitmap-alterable-charset))
+ (eq 1 (charset-width bitmap-alterable-charset)))))