aboutsummaryrefslogtreecommitdiffstats
path: root/editors/bless
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2006-02-19 14:35:53 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2006-02-19 14:35:53 +0800
commitdb78c8ac36997ede730909b859040f3be961f2cb (patch)
tree93f633bcf725f5abf583a09c689c692ffa091d83 /editors/bless
parent4feedccd71c9ab33c68cc7774417a162361cb409 (diff)
downloadfreebsd-ports-gnome-db78c8ac36997ede730909b859040f3be961f2cb.tar.gz
freebsd-ports-gnome-db78c8ac36997ede730909b859040f3be961f2cb.tar.zst
freebsd-ports-gnome-db78c8ac36997ede730909b859040f3be961f2cb.zip
Fix for namespace changes in Mono 1.1.13
Mono.Unix.Statvfs => Mono.Unix.Native.Statvfs Mono.Unix.Syscall.statvfs => Mono.Unix.Native.Syscall.statvfs Project by: BSD# <http://www.mono-project.com/Mono:FreeBSD>
Diffstat (limited to 'editors/bless')
-rw-r--r--editors/bless/Makefile1
-rw-r--r--editors/bless/files/patch-src_ByteBuffer_SaveAsOperation.cs13
-rw-r--r--editors/bless/files/patch-src_ByteBuffer_SaveOperation.cs13
3 files changed, 27 insertions, 0 deletions
diff --git a/editors/bless/Makefile b/editors/bless/Makefile
index daa553e20db4..8c98d763a16e 100644
--- a/editors/bless/Makefile
+++ b/editors/bless/Makefile
@@ -8,6 +8,7 @@
PORTNAME= bless
PORTVERSION= 0.4.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= editors
MASTER_SITES= http://download.gna.org/bless/
diff --git a/editors/bless/files/patch-src_ByteBuffer_SaveAsOperation.cs b/editors/bless/files/patch-src_ByteBuffer_SaveAsOperation.cs
new file mode 100644
index 000000000000..98d3c014b3ce
--- /dev/null
+++ b/editors/bless/files/patch-src_ByteBuffer_SaveAsOperation.cs
@@ -0,0 +1,13 @@
+--- src/ByteBuffer/SaveAsOperation.cs.orig Sun Sep 11 12:22:16 2005
++++ src/ByteBuffer/SaveAsOperation.cs Sat Feb 18 15:31:08 2006
+@@ -63,8 +63,8 @@
+ {
+ #if ENABLE_UNIX_SPECIFIC
+ // get info about the device the file will be saved on
+- Mono.Unix.Statvfs stat=new Mono.Unix.Statvfs();
+- Mono.Unix.Syscall.statvfs(Path.GetDirectoryName(fn), out stat);
++ Mono.Unix.Native.Statvfs stat=new Mono.Unix.Native.Statvfs();
++ Mono.Unix.Native.Syscall.statvfs(Path.GetDirectoryName(fn), out stat);
+
+ long freeSpace=(long)(stat.f_bavail*stat.f_bsize);
+
diff --git a/editors/bless/files/patch-src_ByteBuffer_SaveOperation.cs b/editors/bless/files/patch-src_ByteBuffer_SaveOperation.cs
new file mode 100644
index 000000000000..7d2c178e1f30
--- /dev/null
+++ b/editors/bless/files/patch-src_ByteBuffer_SaveOperation.cs
@@ -0,0 +1,13 @@
+--- src/ByteBuffer/SaveOperation.cs.orig Wed May 11 16:10:19 2005
++++ src/ByteBuffer/SaveOperation.cs Sat Feb 18 15:41:21 2006
+@@ -53,8 +53,8 @@
+ // get info about the device the file will be saved on
+ FileInfo fi=new FileInfo(bb.Filename);
+
+- Mono.Unix.Statvfs stat=new Mono.Unix.Statvfs();
+- Mono.Unix.Syscall.statvfs(bb.Filename, out stat);
++ Mono.Unix.Native.Statvfs stat=new Mono.Unix.Native.Statvfs();
++ Mono.Unix.Native.Syscall.statvfs(bb.Filename, out stat);
+
+ long freeSpace=(long)(stat.f_bavail*stat.f_bsize) + fi.Length;
+