aboutsummaryrefslogtreecommitdiffstats
path: root/editors/calligra
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
committertcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
commita5fddeafcdb2cab1016827038e317a262dad4857 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /editors/calligra
parent3832b190ef3ea2bbefdd61450bff8af422a2e9ae (diff)
downloadfreebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.gz
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.zst
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Diffstat (limited to 'editors/calligra')
-rw-r--r--editors/calligra/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 59483126b7db..daf8eb176539 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -37,13 +37,13 @@ RUN_DEPENDS= pstoedit:graphics/pstoedit
USE_GL= glew
USE_GNOME= glib20 libxml2 libxslt
-USE_KDE4= kactivities kdelibs libkdcraw \
+USE_KDE= kactivities kdelibs libkdcraw \
okular pimlibs attica automoc4 soprano
USE_QT4= corelib dbus designer_build gui opengl phonon \
qtestlib_build script sql svg webkit xml \
moc_build qmake_build rcc_build uic_build
USES= cmake:outsource cpe compiler:c++11-lang iconv:translit jpeg \
- perl5 pkgconfig shared-mime-info sqlite tar:xz
+ kde:4 perl5 pkgconfig shared-mime-info sqlite tar:xz
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
-DPRODUCTSET:STRING="DESKTOP"
USE_LDCONFIG= yes
@@ -63,7 +63,7 @@ GMIC_CMAKE_ON= -DWITH_GMIC:BOOL=ON
GMIC_CMAKE_OFF= -DWITH_GMIC:BOOL=OFF
MARBLE_DESC= World globe widget support via Marble
-MARBLE_USE= KDE4=marble
+MARBLE_USE= KDE=marble
MARBLE_CMAKE_OFF=-DWITH_Marble:BOOL=FALSE
MYSQL_DESC= MySQL database support in Kexi