aboutsummaryrefslogtreecommitdiffstats
path: root/editors/calligra
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-11-05 19:19:58 +0800
committerlofi <lofi@FreeBSD.org>2005-11-05 19:19:58 +0800
commit00de3f31a1ff9c2a6cf084063cb82998246d8f3e (patch)
treebc2706cf04d0653b9eda5eb10e4f39f6d02b447a /editors/calligra
parentd8a9fc2c8ef2a48979c4c3913a711ec74d4d27d6 (diff)
downloadfreebsd-ports-gnome-00de3f31a1ff9c2a6cf084063cb82998246d8f3e.tar.gz
freebsd-ports-gnome-00de3f31a1ff9c2a6cf084063cb82998246d8f3e.tar.zst
freebsd-ports-gnome-00de3f31a1ff9c2a6cf084063cb82998246d8f3e.zip
Update to KDE 3.4.3 / KOffice 1.4.2
Diffstat (limited to 'editors/calligra')
-rw-r--r--editors/calligra/Makefile8
-rw-r--r--editors/calligra/distinfo4
-rw-r--r--editors/calligra/files/patch-filters_kword_rtf_import-rtfimport_tokenizer325
-rw-r--r--editors/calligra/files/patch-kpresenter-imageEffectBase.ui23
-rw-r--r--editors/calligra/files/patch-krita_plugins_colorspaceconversion-wdgconvertcolorspace.ui10
-rw-r--r--editors/calligra/files/patch-krita_plugins_convolutionfilters-kis_custom_convolution_filter_configuration_base_widget.ui10
-rw-r--r--editors/calligra/files/patch-krita_plugins_screenshot-ksnapshotwidget.ui10
-rw-r--r--editors/calligra/files/patch-krita_ui-kis_previewwidgetbase.ui11
-rw-r--r--editors/calligra/files/patch-krita_ui-wdgcolorsettings.ui11
-rw-r--r--editors/calligra/files/patch-krita_ui-wdglayerbox.ui11
-rw-r--r--editors/calligra/files/patch-krita_ui-wdgnewimage.ui11
-rw-r--r--editors/calligra/files/patch-krita_ui_widgets-kis_wdg_autogradient.ui11
-rw-r--r--editors/calligra/pkg-plist11
13 files changed, 11 insertions, 445 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index dd9fb61c41ef..185bec6793ac 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= koffice
-PORTVERSION= 1.4.1
-PORTREVISION= 1
+PORTVERSION= 1.4.2
PORTEPOCH= 1
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
@@ -53,14 +52,13 @@ CONFIGURE_ARGS+=--with-pgsqlincdir=${PG_INCDIR} --with-pgsqllibdir=${PG_LIBDIR}
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-kexi-main-keximainwindowimpl.cpp
.endif
-post-patch:
- @env TZ=UTC ${TOUCH} -t 200507191955.36 ${WRKSRC}/config.h.in
-
post-configure:
.if ${OSVERSION} < 500035
${REINPLACE_CMD} -e 's|\(^CPPFLAGS =.*\)|\1 -I${LOCALBASE}/include/stlport|g' \
-e 's|\(^LDFLAGS =.*\)|\1 -L${LOCALBASE}/lib -lstlport_gcc ${PTHREAD_LIBS}|g' \
${WRKSRC}/filters/kspread/excel/sidewinder/Makefile \
+ ${WRKSRC}/kchart/Makefile \
+ ${WRKSRC}/kchart/kdchart/Makefile \
${WRKSRC}/kexi/kexidb/drivers/pqxx/Makefile \
${WRKSRC}/kexi/migration/pqxx/Makefile
.endif
diff --git a/editors/calligra/distinfo b/editors/calligra/distinfo
index 7f9ee95864a2..61d5478c3f57 100644
--- a/editors/calligra/distinfo
+++ b/editors/calligra/distinfo
@@ -1,2 +1,2 @@
-MD5 (KDE/koffice/koffice-1.4.1.tar.bz2) = 91a7b68757addc5934c5a8209a4926d5
-SIZE (KDE/koffice/koffice-1.4.1.tar.bz2) = 19364338
+MD5 (KDE/koffice/koffice-1.4.2.tar.bz2) = 6b456fb7d54c84b11396b27a96ae0cf8
+SIZE (KDE/koffice/koffice-1.4.2.tar.bz2) = 19486852
diff --git a/editors/calligra/files/patch-filters_kword_rtf_import-rtfimport_tokenizer b/editors/calligra/files/patch-filters_kword_rtf_import-rtfimport_tokenizer
deleted file mode 100644
index 78be2fe6f9ce..000000000000
--- a/editors/calligra/files/patch-filters_kword_rtf_import-rtfimport_tokenizer
+++ /dev/null
@@ -1,325 +0,0 @@
-Index: filters/kword/rtf/import/rtfimport_tokenizer.cpp
-===================================================================
---- filters/kword/rtf/import/rtfimport_tokenizer.cpp (revision 463235)
-+++ filters/kword/rtf/import/rtfimport_tokenizer.cpp (working copy)
-@@ -16,7 +16,7 @@
-
- RTFTokenizer::RTFTokenizer()
- {
-- tokenText.resize( 4112 );
-+ tokenText.resize( 4113 );
- fileBuffer.resize( 4096 );
- infile = 0L;
- }
-@@ -30,8 +30,25 @@
- fileBufferPtr = 0L;
- fileBufferEnd = 0L;
- infile = in;
-+ type = RTFTokenizer::PlainText;
- }
-
-+int RTFTokenizer::nextChar()
-+{
-+ if ( fileBufferPtr == fileBufferEnd ) {
-+ int n = infile->readBlock( fileBuffer.data(), fileBuffer.size() );
-+ fileBufferPtr = ( uchar* ) fileBuffer.data();
-+ fileBufferEnd = fileBufferPtr;
-+
-+ if ( n <= 0 )
-+ return -1;
-+
-+ fileBufferEnd = fileBufferPtr + n;
-+ }
-+ return *fileBufferPtr++;
-+}
-+
-+
- /**
- * Reads the next token.
- */
-@@ -42,22 +59,15 @@
- if (!infile)
- return;
-
-- do
-- {
-- if (fileBufferPtr == fileBufferEnd)
-- {
-- int n = infile->readBlock( fileBuffer.data(), fileBuffer.size() );
-+ do {
-+ int n = nextChar();
-
-- if (n <= 0)
-- {
-- // Return CloseGroup on EOF
-- ch = '}';
-- break;
-- }
-- fileBufferPtr = (uchar *)fileBuffer.data();
-- fileBufferEnd = (fileBufferPtr + n);
-- }
-- ch = *fileBufferPtr++;
-+ if ( n <= 0 ) {
-+ ch = '}';
-+ break;
-+ }
-+
-+ ch = n;
- }
- while (ch == '\n' || ch == '\r' && ch != 0);
-
-@@ -67,6 +77,7 @@
-
- uchar *_text = (uchar *)text;
-
-+
- if (ch == '{')
- type = RTFTokenizer::OpenGroup;
- else if (ch == '}')
-@@ -75,20 +86,14 @@
- {
- type = RTFTokenizer::ControlWord;
-
-- if (fileBufferPtr == fileBufferEnd)
-- {
-- int n = infile->readBlock( fileBuffer.data(), fileBuffer.size() );
-+ int n = nextChar();
-
-- if (n <= 0)
-- {
-- // Return CloseGroup on EOF
-- type = RTFTokenizer::CloseGroup;
-- return;
-- }
-- fileBufferPtr = (uchar *)fileBuffer.data();
-- fileBufferEnd = (fileBufferPtr + n);
-- }
-- ch = *fileBufferPtr++;
-+ if ( n <= 0 ) {
-+ // Return CloseGroup on EOF
-+ type = RTFTokenizer::CloseGroup;
-+ return;
-+ }
-+ ch = n;
-
- // Type is either control word or control symbol
- if ((ch >= 'a' && ch <= 'z') || (ch >= 'A' && ch <= 'Z'))
-@@ -96,64 +101,41 @@
- int v = 0;
-
- // Read alphabetic string (command)
-- while ((ch >= 'a' && ch <= 'z') || (ch >= 'A' && ch <= 'Z'))
-+ while (_text < ( uchar* )tokenText.data()+tokenText.size()-3 &&
-+ ((ch >= 'a' && ch <= 'z') || (ch >= 'A' && ch <= 'Z')) )
- {
- *_text++ = ch;
-
-- if (fileBufferPtr == fileBufferEnd)
-- {
-- int n = infile->readBlock( fileBuffer.data(), fileBuffer.size() );
--
-- if (n <= 0)
-- {
-- ch = ' ';
-- break;
-- }
-- fileBufferPtr = (uchar *)fileBuffer.data();
-- fileBufferEnd = (fileBufferPtr + n);
-- }
-- ch = *fileBufferPtr++;
-+ int n = nextChar();
-+ if ( n <= 0 ) {
-+ ch = ' ';
-+ break;
-+ }
-+ ch = n;
- }
-
- // Read numeric parameter (param)
- bool isneg = (ch == '-');
-
-- if (isneg)
-- {
-- if (fileBufferPtr == fileBufferEnd)
-- {
-- int n = infile->readBlock( fileBuffer.data(), fileBuffer.size() );
--
-- if (n <= 0)
-- {
-- // Return CloseGroup on EOF
-- type = RTFTokenizer::CloseGroup;
-- return;
-- }
-- fileBufferPtr = (uchar *)fileBuffer.data();
-- fileBufferEnd = (fileBufferPtr + n);
-- }
-- ch = *fileBufferPtr++;
-+ if (isneg) {
-+ int n = nextChar();
-+ if ( n <= 0 ) {
-+ type = RTFTokenizer::CloseGroup;
-+ return;
-+ }
-+ ch = n;
- }
-- while (ch >= '0' && ch <= '9')
-- {
-+
-+ while (ch >= '0' && ch <= '9') {
- v = (10 * v) + ch - '0';
- hasParam = true;
-
-- if (fileBufferPtr == fileBufferEnd)
-- {
-- int n = infile->readBlock( fileBuffer.data(), fileBuffer.size() );
-+ int n = nextChar();
-
-- if (n <= 0)
-- {
-- ch = ' ';
-- break;
-- }
-- fileBufferPtr = (uchar *)fileBuffer.data();
-- fileBufferEnd = (fileBufferPtr + n);
-- }
-- ch = *fileBufferPtr++;
-- }
-+ if ( n <= 0 )
-+ n = ' ';
-+ ch = n;
-+ }
- value = isneg ? -v : v;
-
- // If delimiter is a space, it's part of the control word
-@@ -163,7 +145,7 @@
- }
-
- *_text = 0; // Just put an end of string for the test, it can then be over-written again
-- if ( !qstrncmp( tokenText.data()+1, "bin", 4 ) ) // Test the NULL too to avoid catching keywords starting with "bin"
-+ if ( !memcmp( tokenText.data()+1, "bin", 4 ) )
- { // We have \bin, so we need to read the bytes
- kdDebug(30515) << "Token:" << tokenText << endl;
- if (value > 0)
-@@ -173,26 +155,15 @@
- binaryData.resize(value);
- for (int i=0; i<value; i++)
- {
-- if (fileBufferPtr == fileBufferEnd)
-- {
-- const int n = infile->readBlock( fileBuffer.data(), fileBuffer.size() );
--
-- if (n <= 0)
-- {
-- kdError(30515) << "\\bin stream hit end of file." << endl;
-- type = RTFTokenizer::CloseGroup;
-- break;
-- }
-- fileBufferPtr = (uchar *)fileBuffer.data();
-- fileBufferEnd = (fileBufferPtr + n);
-+ int n = nextChar();
-+ if ( n <= 0 ) {
-+ type = RTFTokenizer::CloseGroup;
-+ break;
- }
-- binaryData[i]=*fileBufferPtr++;
-+
-+ binaryData[i] = n;
- }
- }
-- else
-- {
-- kdError(30515) << "\\bin with negative value skipping" << endl;
-- }
- }
-
- }
-@@ -200,19 +171,13 @@
- {
- type = RTFTokenizer::ControlWord;
- *_text++ = ch;
-- if (fileBufferPtr == fileBufferEnd)
-- {
-- int n = infile->readBlock( fileBuffer.data(), fileBuffer.size() );
-
-- if (n <= 0)
-- {
-- // Return CloseGroup on EOF
-- type = RTFTokenizer::CloseGroup;
-- return;
-- }
-- fileBufferPtr = (uchar *)fileBuffer.data();
-- fileBufferEnd = (fileBufferPtr + n);
-- }
-+ int n = nextChar();
-+
-+ if ( n <= 0 ) {
-+ type = RTFTokenizer::CloseGroup;
-+ return;
-+ }
- ch = *fileBufferPtr++;
- for(int i=0;i<2;i++)
- {
-@@ -220,22 +185,16 @@
- value<<=4;
- value=value|((ch + ((ch & 16) ? 0 : 9)) & 0xf);
-
-- if (fileBufferPtr == fileBufferEnd)
-- {
-- int n = infile->readBlock( fileBuffer.data(), fileBuffer.size() );
-+ int n = nextChar();
-
-- if (n <= 0)
-- {
-- ch = ' ';
-- break;
-- }
-- fileBufferPtr = (uchar *)fileBuffer.data();
-- fileBufferEnd = (fileBufferPtr + n);
-- }
-+ if ( n <= 0 ) {
-+ ch = ' ';
-+ break;
-+ }
- ch = *fileBufferPtr++;
- }
-- --fileBufferPtr;
-- }
-+ --fileBufferPtr;
-+ }
- else
- {
- type = RTFTokenizer::ControlWord;
-@@ -248,14 +207,16 @@
-
- // Everything until next backslash, opener or closer
- while ( ch != '\\' && ch != '{' && ch != '}' && ch != '\n' &&
-- ch != '\r' && fileBufferPtr <= fileBufferEnd )
-+ ch != '\r')
- {
- *_text++ = ch;
-+ if(fileBufferPtr >= fileBufferEnd)
-+ break;
- ch = *fileBufferPtr++;
- }
--
-- // Give back last char
-- --fileBufferPtr;
-+ if(fileBufferPtr < fileBufferEnd)
-+ --fileBufferPtr; // give back the last char
- }
- *_text++ = 0;
-+
- }
-Index: filters/kword/rtf/import/rtfimport_tokenizer.h
-===================================================================
---- filters/kword/rtf/import/rtfimport_tokenizer.h (revision 463235)
-+++ filters/kword/rtf/import/rtfimport_tokenizer.h (working copy)
-@@ -50,6 +50,8 @@
-
- // tokenizer (private) data
- private:
-+ int nextChar();
-+
- QFile *infile;
- QByteArray fileBuffer;
- QCString tokenText;
diff --git a/editors/calligra/files/patch-kpresenter-imageEffectBase.ui b/editors/calligra/files/patch-kpresenter-imageEffectBase.ui
deleted file mode 100644
index 30cc64533dac..000000000000
--- a/editors/calligra/files/patch-kpresenter-imageEffectBase.ui
+++ /dev/null
@@ -1,23 +0,0 @@
---- kpresenter/imageEffectBase.ui.orig Fri Sep 16 18:02:09 2005
-+++ kpresenter/imageEffectBase.ui Fri Sep 16 18:02:24 2005
-@@ -1461,20 +1461,5 @@
- <layoutdefaults spacing="6" margin="11"/>
- <includehints>
- <includehint>kcolorbutton.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kcolorbutton.h</includehint>
-- <includehint>kcolorbutton.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
-- <includehint>kdoublenuminput.h</includehint>
- </includehints>
- </UI>
diff --git a/editors/calligra/files/patch-krita_plugins_colorspaceconversion-wdgconvertcolorspace.ui b/editors/calligra/files/patch-krita_plugins_colorspaceconversion-wdgconvertcolorspace.ui
deleted file mode 100644
index 13b35119f744..000000000000
--- a/editors/calligra/files/patch-krita_plugins_colorspaceconversion-wdgconvertcolorspace.ui
+++ /dev/null
@@ -1,10 +0,0 @@
---- krita/plugins/colorspaceconversion/wdgconvertcolorspace.ui.orig Thu Sep 15 12:38:33 2005
-+++ krita/plugins/colorspaceconversion/wdgconvertcolorspace.ui Thu Sep 15 12:38:52 2005
-@@ -265,7 +265,4 @@
- <tabstop>radioPerceptual</tabstop>
- </tabstops>
- <layoutdefaults spacing="6" margin="11"/>
--<includehints>
-- <includehint>kiscmbidlist.h</includehint>
--</includehints>
- </UI>
diff --git a/editors/calligra/files/patch-krita_plugins_convolutionfilters-kis_custom_convolution_filter_configuration_base_widget.ui b/editors/calligra/files/patch-krita_plugins_convolutionfilters-kis_custom_convolution_filter_configuration_base_widget.ui
deleted file mode 100644
index 5daa5a578d1c..000000000000
--- a/editors/calligra/files/patch-krita_plugins_convolutionfilters-kis_custom_convolution_filter_configuration_base_widget.ui
+++ /dev/null
@@ -1,10 +0,0 @@
---- krita/plugins/convolutionfilters/kis_custom_convolution_filter_configuration_base_widget.ui.orig Thu Sep 15 12:36:52 2005
-+++ krita/plugins/convolutionfilters/kis_custom_convolution_filter_configuration_base_widget.ui Thu Sep 15 12:37:07 2005
-@@ -186,7 +186,4 @@
- </image>
- </images>
- <layoutdefaults spacing="6" margin="11"/>
--<includehints>
-- <includehint>kismatrixwidget.h</includehint>
--</includehints>
- </UI>
diff --git a/editors/calligra/files/patch-krita_plugins_screenshot-ksnapshotwidget.ui b/editors/calligra/files/patch-krita_plugins_screenshot-ksnapshotwidget.ui
deleted file mode 100644
index 73a75418a8f8..000000000000
--- a/editors/calligra/files/patch-krita_plugins_screenshot-ksnapshotwidget.ui
+++ /dev/null
@@ -1,10 +0,0 @@
---- krita/plugins/screenshot/ksnapshotwidget.ui.orig Thu Sep 15 12:30:37 2005
-+++ krita/plugins/screenshot/ksnapshotwidget.ui Thu Sep 15 12:30:56 2005
-@@ -332,7 +332,4 @@
- <pixmapfunction>SmallIconSet</pixmapfunction>
- <layoutdefaults spacing="6" margin="11"/>
- <layoutfunctions spacing="KDialog::spacingHint" margin="KDialog::marginHint"/>
--<includehints>
-- <includehint>ksnapshotthumb.h</includehint>
--</includehints>
- </UI>
diff --git a/editors/calligra/files/patch-krita_ui-kis_previewwidgetbase.ui b/editors/calligra/files/patch-krita_ui-kis_previewwidgetbase.ui
deleted file mode 100644
index cc47b73ac622..000000000000
--- a/editors/calligra/files/patch-krita_ui-kis_previewwidgetbase.ui
+++ /dev/null
@@ -1,11 +0,0 @@
---- krita/ui/kis_previewwidgetbase.ui.orig Thu Sep 15 18:26:35 2005
-+++ krita/ui/kis_previewwidgetbase.ui Thu Sep 15 18:26:43 2005
-@@ -201,8 +201,4 @@
- </connection>
- </connections>
- <layoutdefaults spacing="6" margin="11"/>
--<includehints>
-- <includehint>kispreviewview.h</includehint>
-- <includehint>kispreviewview.h</includehint>
--</includehints>
- </UI>
diff --git a/editors/calligra/files/patch-krita_ui-wdgcolorsettings.ui b/editors/calligra/files/patch-krita_ui-wdgcolorsettings.ui
deleted file mode 100644
index 26e6a62d0f28..000000000000
--- a/editors/calligra/files/patch-krita_ui-wdgcolorsettings.ui
+++ /dev/null
@@ -1,11 +0,0 @@
---- krita/ui/wdgcolorsettings.ui.orig Thu Sep 15 18:25:18 2005
-+++ krita/ui/wdgcolorsettings.ui Thu Sep 15 18:25:26 2005
-@@ -361,8 +361,4 @@
- <tabstop>radioPerceptual</tabstop>
- </tabstops>
- <layoutdefaults spacing="6" margin="11"/>
--<includehints>
-- <includehint>kiscmbidlist.h</includehint>
-- <includehint>kiscmbidlist.h</includehint>
--</includehints>
- </UI>
diff --git a/editors/calligra/files/patch-krita_ui-wdglayerbox.ui b/editors/calligra/files/patch-krita_ui-wdglayerbox.ui
deleted file mode 100644
index 3731c16a580a..000000000000
--- a/editors/calligra/files/patch-krita_ui-wdglayerbox.ui
+++ /dev/null
@@ -1,11 +0,0 @@
---- krita/ui/wdglayerbox.ui.orig Thu Sep 15 21:07:24 2005
-+++ krita/ui/wdglayerbox.ui Thu Sep 15 21:09:24 2005
-@@ -250,8 +250,6 @@
- </images>
- <layoutdefaults spacing="6" margin="11"/>
- <includehints>
-- <includehint>kiscmbcomposite.h</includehint>
-- <includehint>knuminput.h</includehint>
- <includehint>knuminput.h</includehint>
- <includehint>klistbox.h</includehint>
- </includehints>
diff --git a/editors/calligra/files/patch-krita_ui-wdgnewimage.ui b/editors/calligra/files/patch-krita_ui-wdgnewimage.ui
deleted file mode 100644
index 80cd21454be2..000000000000
--- a/editors/calligra/files/patch-krita_ui-wdgnewimage.ui
+++ /dev/null
@@ -1,11 +0,0 @@
---- krita/ui/wdgnewimage.ui.orig Thu Sep 15 18:22:50 2005
-+++ krita/ui/wdgnewimage.ui Thu Sep 15 18:23:08 2005
-@@ -319,8 +319,6 @@
- <layoutdefaults spacing="6" margin="11"/>
- <includehints>
- <includehint>knuminput.h</includehint>
-- <includehint>knuminput.h</includehint>
-- <includehint>kiscmbidlist.h</includehint>
- <includehint>kcolorcombo.h</includehint>
- </includehints>
- </UI>
diff --git a/editors/calligra/files/patch-krita_ui_widgets-kis_wdg_autogradient.ui b/editors/calligra/files/patch-krita_ui_widgets-kis_wdg_autogradient.ui
deleted file mode 100644
index 83d940e4cd16..000000000000
--- a/editors/calligra/files/patch-krita_ui_widgets-kis_wdg_autogradient.ui
+++ /dev/null
@@ -1,11 +0,0 @@
---- krita/ui/widgets/kis_wdg_autogradient.ui.orig Thu Sep 15 12:28:25 2005
-+++ krita/ui/widgets/kis_wdg_autogradient.ui Thu Sep 15 12:28:43 2005
-@@ -406,8 +406,6 @@
- </tabstops>
- <layoutdefaults spacing="6" margin="11"/>
- <includehints>
-- <includehint>kisgradientsliderwidget.h</includehint>
-- <includehint>kcolorbutton.h</includehint>
- <includehint>kcolorbutton.h</includehint>
- </includehints>
- </UI>
diff --git a/editors/calligra/pkg-plist b/editors/calligra/pkg-plist
index d8e94f3f81bc..13735f8f01b8 100644
--- a/editors/calligra/pkg-plist
+++ b/editors/calligra/pkg-plist
@@ -590,19 +590,20 @@ lib/libkwordexportfilters.la
lib/libkwordexportfilters.so
lib/libkwordexportfilters.so.1
share/applications/kde/kexi.desktop
+share/applications/kde/kformdesigner.desktop
share/applications/kde/kivio.desktop
+share/applications/kde/krita.desktop
share/applnk/Office/KThesaurus.desktop
share/applnk/Office/karbon.desktop
share/applnk/Office/kchart.desktop
share/applnk/Office/kformula.desktop
share/applnk/Office/koshell.desktop
share/applnk/Office/kpresenter.desktop
-share/applnk/Office/krita.desktop
+share/applnk/Office/krita_magick.desktop
share/applnk/Office/kspread.desktop
share/applnk/Office/kudesigner.desktop
share/applnk/Office/kugar.desktop
share/applnk/Office/kword.desktop
-share/applnk/Utilities/kformdesigner.desktop
share/apps/karbon/gradients/allcolors.kgr
share/apps/karbon/gradients/simple.kgr
share/apps/karbon/icons/crystalsvg/16x16/actions/14_layer_deletelayer.png
@@ -945,6 +946,7 @@ share/apps/kivio/icons/crystalsvg/22x22/actions/arrowheads.png
share/apps/kivio/icons/crystalsvg/22x22/actions/font_bold.png
share/apps/kivio/icons/crystalsvg/22x22/actions/font_italic.png
share/apps/kivio/icons/crystalsvg/22x22/actions/font_under.png
+share/apps/kivio/icons/crystalsvg/22x22/actions/kivio_connector.png
share/apps/kivio/icons/crystalsvg/22x22/actions/open_stencilset.png
share/apps/kivio/icons/crystalsvg/32x32/actions/arrowheads.png
share/apps/kivio/icons/crystalsvg/48x48/actions/template_basicflow.png
@@ -1007,6 +1009,7 @@ share/apps/kivio/icons/hicolor/22x22/actions/font_bold.png
share/apps/kivio/icons/hicolor/22x22/actions/font_italic.png
share/apps/kivio/icons/hicolor/22x22/actions/font_under.png
share/apps/kivio/icons/hicolor/22x22/actions/group_stencils.png
+share/apps/kivio/icons/hicolor/22x22/actions/kivio_connector.png
share/apps/kivio/icons/hicolor/22x22/actions/linestyle.png
share/apps/kivio/icons/hicolor/22x22/actions/linewidth.png
share/apps/kivio/icons/hicolor/22x22/actions/open_stencilset.png
@@ -4041,12 +4044,10 @@ share/templates/TextDocument.desktop
@exec /bin/mkdir -p %D/share/doc/HTML/en/koffice-apidocs/kdgantt/html
@exec /bin/mkdir -p %D/share/doc/HTML/en/koffice-apidocs/kdgantt/html
@exec /bin/mkdir -p %D/share/doc/HTML/en/koffice-apidocs/lib/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/koffice-apidocs/kspread/html
@exec /bin/mkdir -p %D/share/doc/HTML/en/koffice-apidocs/kdgantt/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/koffice-apidocs/kspread/html
@dirrm share/services/kformdesigner
@dirrm share/services/kexi
-@dirrm share/icons/hicolor/scalable/apps
-@dirrm share/icons/hicolor/scalable
@dirrm share/doc/HTML/en/thesaurus
@dirrm share/doc/HTML/en/kword
@dirrm share/doc/HTML/en/kugar