aboutsummaryrefslogtreecommitdiffstats
path: root/editors/cle
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-07-26 19:31:46 +0800
committergarga <garga@FreeBSD.org>2006-07-26 19:31:46 +0800
commit54711ff6906ddc932b21335d7d54ea216bf45d4c (patch)
treeb0d4585087d9504c3e0d70325fce5f0994291549 /editors/cle
parentb7b734f5880cff5c9920d6113038d90d7988d5b2 (diff)
downloadfreebsd-ports-gnome-54711ff6906ddc932b21335d7d54ea216bf45d4c.tar.gz
freebsd-ports-gnome-54711ff6906ddc932b21335d7d54ea216bf45d4c.tar.zst
freebsd-ports-gnome-54711ff6906ddc932b21335d7d54ea216bf45d4c.zip
Cle is a Command Line Editor. It provides the editing/history/completion
commands of the GNU readline package to any line-oriented Unix command. WWW: http://kaolin.unice.fr/Cle/ PR: ports/100855 Submitted by: Timothy Bourke <timbob at bigpond.com>
Diffstat (limited to 'editors/cle')
-rw-r--r--editors/cle/Makefile26
-rw-r--r--editors/cle/distinfo3
-rw-r--r--editors/cle/files/patch-configure11
-rw-r--r--editors/cle/files/patch-src_cle.c14
-rw-r--r--editors/cle/pkg-descr9
5 files changed, 63 insertions, 0 deletions
diff --git a/editors/cle/Makefile b/editors/cle/Makefile
new file mode 100644
index 000000000000..fce07c6deb05
--- /dev/null
+++ b/editors/cle/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: cle
+# Date created: 25 July 2006
+# Whom: Timothy Bourke <timbob@bigpond.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cle
+PORTVERSION= 0.4
+CATEGORIES= editors
+MASTER_SITES= ftp://kaolin.unice.fr/pub/Cle/
+
+MAINTAINER= timbob@bigpond.com
+COMMENT= Command Line Editor (based on readline)
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/cle
+
+MAN1= cle.1
+
+post-extract:
+ ${CHMOD} ug+x ${WRKSRC}/missing
+
+.include <bsd.port.mk>
diff --git a/editors/cle/distinfo b/editors/cle/distinfo
new file mode 100644
index 000000000000..b3309245bca1
--- /dev/null
+++ b/editors/cle/distinfo
@@ -0,0 +1,3 @@
+MD5 (cle-0.4.tar.gz) = 53e316e6d8dacc22985c26c4818e28af
+SHA256 (cle-0.4.tar.gz) = 27fb52f7f1a09d880d7d7f39ba66c12474153df2cb1c57ab512a6e2d27e7b620
+SIZE (cle-0.4.tar.gz) = 374763
diff --git a/editors/cle/files/patch-configure b/editors/cle/files/patch-configure
new file mode 100644
index 000000000000..af87e3a57b1d
--- /dev/null
+++ b/editors/cle/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Nov 19 01:24:25 1999
++++ configure Wed Jul 26 17:02:11 2006
+@@ -1328,7 +1328,7 @@
+
+
+
+-(cd readline; configure $prefix $curses)
++(cd readline; ./configure --prefix="$prefix" $curses)
+
+
+
diff --git a/editors/cle/files/patch-src_cle.c b/editors/cle/files/patch-src_cle.c
new file mode 100644
index 000000000000..df620bdaa6e0
--- /dev/null
+++ b/editors/cle/files/patch-src_cle.c
@@ -0,0 +1,14 @@
+--- src/cle.c Sat Dec 4 00:41:14 1999
++++ src/cle.c Fri Mar 24 15:46:07 2006
+@@ -147,8 +147,10 @@
+ rl_prep_terminal(_rl_meta_flag); /* Place the terminal in raw mode */
+ } else {
+ /* We are still in echo mode. Register the line in the history */
+- add_history(s);
+ len= strlen(s);
++ if (len > 0) {
++ add_history(s);
++ }
+ s[len]= '\n';
+ write(fd, s, len+1);
+ }
diff --git a/editors/cle/pkg-descr b/editors/cle/pkg-descr
new file mode 100644
index 000000000000..93eae33b2962
--- /dev/null
+++ b/editors/cle/pkg-descr
@@ -0,0 +1,9 @@
+Cle is a Command Line Editor. It provides the editing/history/completion
+commands of the GNU readline package to any line-oriented Unix command. For
+instance,
+
+$ cle ftp foo.bar.org
+
+adds editing/history/completion commands to the ftp command.
+
+WWW: http://kaolin.unice.fr/Cle/