aboutsummaryrefslogtreecommitdiffstats
path: root/editors/emacs-devel
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2011-09-08 14:16:32 +0800
committerashish <ashish@FreeBSD.org>2011-09-08 14:16:32 +0800
commitfb0cd930b9bf0ba8f0dbba1f49bc888f80dcdd9b (patch)
treebb1fad96c315b9b8a28184f6233e32a0bcecbc6a /editors/emacs-devel
parentd94fdabbf99f4cfe1f4628c1fac3e130aaaf59e9 (diff)
downloadfreebsd-ports-gnome-fb0cd930b9bf0ba8f0dbba1f49bc888f80dcdd9b.tar.gz
freebsd-ports-gnome-fb0cd930b9bf0ba8f0dbba1f49bc888f80dcdd9b.tar.zst
freebsd-ports-gnome-fb0cd930b9bf0ba8f0dbba1f49bc888f80dcdd9b.zip
- Update to bzr revision 105651
- Add fix for GNU Emacs bug report# 8522 which affects users of euc-japan keyboard-coding-system[1] - Restrict INSTALLS_ICONS knob to GTK2/3 section as it installs GTK+ dependencies[2] - Update MASTER_SITES - Fix portlint warnings Submitted by: hrs[1] Reported by: Yue Wu <vanopen@gmail.com>[2]
Diffstat (limited to 'editors/emacs-devel')
-rw-r--r--editors/emacs-devel/Makefile14
-rw-r--r--editors/emacs-devel/distinfo4
-rw-r--r--editors/emacs-devel/files/patch-src_coding.c51
3 files changed, 60 insertions, 9 deletions
diff --git a/editors/emacs-devel/Makefile b/editors/emacs-devel/Makefile
index c83aa6b08a45..c01001bc991a 100644
--- a/editors/emacs-devel/Makefile
+++ b/editors/emacs-devel/Makefile
@@ -9,13 +9,16 @@ PORTNAME= emacs
PORTVERSION= ${EMACS_VER}.${EMACS_REV}
PORTEPOCH= 1
CATEGORIES= editors ipv6
-MASTER_SITES= http://wahjava.users.sourceforge.net/%SUBDIR%/ \
+MASTER_SITES= http://distfiles.pirateparty.in/%SUBDIR%/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ashish
MAINTAINER= ashish@FreeBSD.org
COMMENT= GNU editing macros
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
MAKE_JOBS_UNSAFE= yes
CONFLICTS= emacs-19.* emacs-21.* emacs-22.* emacs-23.* \
@@ -24,13 +27,13 @@ CONFLICTS= emacs-19.* emacs-21.* emacs-22.* emacs-23.* \
emacs-nox11-[0-9]*
EMACS_VER= 24.0.50
-EMACS_REV= 105418
+EMACS_REV= 105651
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_XZ= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --localstatedir=/var
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_AUTOTOOLS= autoconf:env automake:env aclocal:env autoheader:env
@@ -38,9 +41,6 @@ USE_AUTOTOOLS= autoconf:env automake:env aclocal:env autoheader:env
EMACS_DIRS= ${DATADIR}/${EMACS_VER}/leim ${DATADIR}/${EMACS_VER}/lisp ${DATADIR}/${EMACS_VER}/src \
${PREFIX}/libexec/${PORTNAME}
-LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
-
MAN1= ctags.1 ebrowse.1 emacs.1 emacsclient.1 etags.1 \
grep-changelog.1 rcs-checkin.1
MANCOMPRESSED= yes
@@ -89,7 +89,6 @@ DBUS_PTHREAD_LIBS= ${CC} -dumpspecs | ${GREP} -m 1 pthread: | ${SED} -e 's|^.*%{
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-x
.else
-INSTALLS_ICONS= yes
USE_XORG= x11
USE_GNOME=
@@ -122,6 +121,7 @@ IGNORE= please choose a toolkit: GTK+/GTK+3/Motif/Xaw/Xaw3d, or build without X1
.if defined(WITH_XAW) || defined(WITH_XAW3D) || defined(WITH_MOTIF)
IGNORE= please choose only one toolkit: GTK+/GTK+3/Motif/Xaw/Xaw3d
.endif
+INSTALLS_ICONS= yes
.if defined(WITH_GTK3) && defined(WITHOUT_GTK2)
USE_GNOME+= gtk30
CONFIGURE_ARGS+= --with-x-toolkit=gtk3
diff --git a/editors/emacs-devel/distinfo b/editors/emacs-devel/distinfo
index edf53445d59f..8085fba19a86 100644
--- a/editors/emacs-devel/distinfo
+++ b/editors/emacs-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (emacs-24.0.50.105418.tar.xz) = d80050509f8c44a86332d8c09ad07ce9be0147b5333632b4236df5dccc10eb8f
-SIZE (emacs-24.0.50.105418.tar.xz) = 23522628
+SHA256 (emacs-24.0.50.105651.tar.xz) = 719bc38998a9e1f52269f14641da15f59d6f5dcd22bf1d85266ad07183b21862
+SIZE (emacs-24.0.50.105651.tar.xz) = 23313912
diff --git a/editors/emacs-devel/files/patch-src_coding.c b/editors/emacs-devel/files/patch-src_coding.c
new file mode 100644
index 000000000000..05c5cc1a6eab
--- /dev/null
+++ b/editors/emacs-devel/files/patch-src_coding.c
@@ -0,0 +1,51 @@
+
+$FreeBSD$
+
+--- src/coding.c.orig
++++ src/coding.c
+@@ -3717,8 +3717,20 @@
+ else
+ charset = CHARSET_FROM_ID (charset_id_2);
+ ONE_MORE_BYTE (c1);
+- if (c1 < 0x20 || (c1 >= 0x80 && c1 < 0xA0))
+- goto invalid_code;
++ /*
++ * <ESC>N sequence is recognized as SS2 in some ISO2022
++ * encodings. As a workaround, mark invalid only if
++ * <ESC>N + GR in a 7-bit encoding or <ESC>N + GL in an 8-bit
++ * encoding.
++ */
++ if (CODING_ISO_FLAGS (coding) & CODING_ISO_FLAG_SEVEN_BITS) {
++ if (c1 < 0x20 || c1 >= 0x80)
++ goto invalid_code;
++ }
++ else {
++ if (c1 < 0xA0)
++ goto invalid_code;
++ }
+ break;
+
+ case 'O': /* invocation of single-shift-3 */
+@@ -3731,8 +3743,20 @@
+ else
+ charset = CHARSET_FROM_ID (charset_id_3);
+ ONE_MORE_BYTE (c1);
+- if (c1 < 0x20 || (c1 >= 0x80 && c1 < 0xA0))
+- goto invalid_code;
++ /*
++ * <ESC>O sequence by arrow keys is recognized as SS3 in
++ * some ISO2022 encodings. As a workaround, mark invalid only if
++ * <ESC>O + GR in a 7-bit encoding or <ESC>O + GL in an 8-bit
++ * encoding.
++ */
++ if (CODING_ISO_FLAGS (coding) & CODING_ISO_FLAG_SEVEN_BITS) {
++ if (c1 < 0x20 || c1 >= 0x80)
++ goto invalid_code;
++ }
++ else {
++ if (c1 < 0xA0)
++ goto invalid_code;
++ }
+ break;
+
+ case '0': case '2': case '3': case '4': /* start composition */