aboutsummaryrefslogtreecommitdiffstats
path: root/editors/emacs19
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-03-08 15:28:36 +0800
committerasami <asami@FreeBSD.org>1999-03-08 15:28:36 +0800
commit04f6beab8f8083412efad3eadf4e32bffa85bbe2 (patch)
tree907e6a967f7d00919c4dc13b6a581739f386e7ef /editors/emacs19
parent755e63021c52f5292b5284c5d10c05274df15811 (diff)
downloadfreebsd-ports-gnome-04f6beab8f8083412efad3eadf4e32bffa85bbe2.tar.gz
freebsd-ports-gnome-04f6beab8f8083412efad3eadf4e32bffa85bbe2.tar.zst
freebsd-ports-gnome-04f6beab8f8083412efad3eadf4e32bffa85bbe2.zip
Fix to make ports work with bsd.port.mk rev. 1.306.
${MACHINE_ARCH}--freebsd${OSREL} is now passed to CONFIGURE_ARGS if GNU_CONFIGURE is defined. Take the target out of CONFIGURE_ARGS of some ports that added it explicitly; define it as ${MACHINE_ARCH}--freebsd if the port doesn't like the ${OSREL} part; define it as something else (such as ${MACHINE_ARCH}--freebsdelf if the port requires that; define it as an empty string if the port doesn't like it at all. The last might be a sign that a GNU_CONFIGURE port actually doesn't use GNU's version of configure at all; but I don't have time to go look at them all, we'll fix them as time goes on. At least we've got much fewer "-unknown-"s in the tree as the result. :)
Diffstat (limited to 'editors/emacs19')
-rw-r--r--editors/emacs19/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/editors/emacs19/Makefile b/editors/emacs19/Makefile
index 480951ed501f..f33d5dd72256 100644
--- a/editors/emacs19/Makefile
+++ b/editors/emacs19/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.35 1999/01/23 14:28:19 simokawa Exp $
+# $Id: Makefile,v 1.36 1999/01/27 07:41:10 fenner Exp $
#
DISTNAME= emacs-19.34b
@@ -14,14 +14,14 @@ MASTER_SITE_SUBDIR= emacs
MAINTAINER= ports@FreeBSD.ORG
EMACS_VERSION= 19.34
-EMACS_ARCH= ${MACHINE_ARCH}--freebsd
-PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${EMACS_ARCH}
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
+PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${CONFIGURE_TARGET}
NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/emacs-19.34
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= ${EMACS_ARCH} --with-x-toolkit --sharedstatedir=/var/run
+CONFIGURE_ARGS= --with-x-toolkit --sharedstatedir=/var/run
STRIP=
MAN1= emacs.1 etags.1 ctags.1