aboutsummaryrefslogtreecommitdiffstats
path: root/editors/emacs20
diff options
context:
space:
mode:
authorcracauer <cracauer@FreeBSD.org>2005-09-24 00:07:16 +0800
committercracauer <cracauer@FreeBSD.org>2005-09-24 00:07:16 +0800
commitaf99c1806303748007242228f9834494ae2e1368 (patch)
treebf72f13312449759897aafc34be7e4544b623913 /editors/emacs20
parentb817b50100a0b3eca07f2a191f5204c4d3935594 (diff)
downloadfreebsd-ports-gnome-af99c1806303748007242228f9834494ae2e1368.tar.gz
freebsd-ports-gnome-af99c1806303748007242228f9834494ae2e1368.tar.zst
freebsd-ports-gnome-af99c1806303748007242228f9834494ae2e1368.zip
Fix allocation of pty for shell-mode.
This was broken for newer FreeBSDs which give out pty names /dev/pty[pqrsPQRS][0123456789abcdefghijklmnopqrstuv] emacs, manually searching, stopped at a gap of 3 entries. But the new naming scheme allows a gap of 28. Set to 30 just in case. Actually there's no good reason not to set that to 256, it's not that 512 system calls kill us everytime someone opens a shell in emacs. Bump portsrevision so that it gets picked up by portupgrade. I wonder whether other emacsens are affected, too...
Diffstat (limited to 'editors/emacs20')
-rw-r--r--editors/emacs20/Makefile2
-rw-r--r--editors/emacs20/files/patch-ch13
2 files changed, 12 insertions, 3 deletions
diff --git a/editors/emacs20/Makefile b/editors/emacs20/Makefile
index ff4b58d25b34..53133624f1a6 100644
--- a/editors/emacs20/Makefile
+++ b/editors/emacs20/Makefile
@@ -7,7 +7,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES+= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= emacs
diff --git a/editors/emacs20/files/patch-ch b/editors/emacs20/files/patch-ch
index f68aed045a8d..02301bd363c5 100644
--- a/editors/emacs20/files/patch-ch
+++ b/editors/emacs20/files/patch-ch
@@ -1,5 +1,5 @@
---- src/process.c.orig Tue Jul 1 16:24:08 2003
-+++ src/process.c Tue Jul 1 16:24:42 2003
+--- src/process.c.original Fri Sep 23 11:49:02 2005
++++ src/process.c Fri Sep 23 11:51:45 2005
@@ -400,6 +400,14 @@
#ifdef HAVE_PTYS
@@ -31,6 +31,15 @@
#endif /* no PTY_NAME_SPRINTF */
#ifdef PTY_OPEN
+@@ -446,7 +454,7 @@
+ if (stat (pty_name, &stb) < 0)
+ {
+ failed_count++;
+- if (failed_count >= 3)
++ if (failed_count >= 30)
+ return -1;
+ }
+ else
@@ -466,7 +474,7 @@
#ifdef PTY_TTY_NAME_SPRINTF
PTY_TTY_NAME_SPRINTF