aboutsummaryrefslogtreecommitdiffstats
path: root/editors/emacs21
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2002-10-06 20:19:58 +0800
committernobutaka <nobutaka@FreeBSD.org>2002-10-06 20:19:58 +0800
commite4aacf22cc020ddf237b232a06204814d947e5ce (patch)
tree7ad0391c033801e14a47245bb581ab7ac244f4f2 /editors/emacs21
parenta3a227bc8bbd445c7e5e9112bc022483561b4049 (diff)
downloadfreebsd-ports-gnome-e4aacf22cc020ddf237b232a06204814d947e5ce.tar.gz
freebsd-ports-gnome-e4aacf22cc020ddf237b232a06204814d947e5ce.tar.zst
freebsd-ports-gnome-e4aacf22cc020ddf237b232a06204814d947e5ce.zip
Add patches to support sparc64.
Submitted by: tmm
Diffstat (limited to 'editors/emacs21')
-rw-r--r--editors/emacs21/files/patch-configure.in3
-rw-r--r--editors/emacs21/files/patch-src:alloc.c14
-rw-r--r--editors/emacs21/files/patch-src:m:sparc.h11
3 files changed, 27 insertions, 1 deletions
diff --git a/editors/emacs21/files/patch-configure.in b/editors/emacs21/files/patch-configure.in
index 3362fe0736b6..a8f299a7bff4 100644
--- a/editors/emacs21/files/patch-configure.in
+++ b/editors/emacs21/files/patch-configure.in
@@ -1,6 +1,6 @@
--- configure.in.orig Fri Oct 19 23:09:18 2001
+++ configure.in Mon Oct 22 21:19:32 2001
-@@ -179,6 +179,15 @@
+@@ -179,6 +179,16 @@
machine='' opsys='' unported=no
case "${canonical}" in
@@ -10,6 +10,7 @@
+ case "${canonical}" in
+ alpha*-*-freebsd*) machine=alpha ;;
+ i[3456]86-*-freebsd*) machine=intel386 ;;
++ sparc64-*-freebsd*) machine=sparc ;;
+ esac
+ ;;
+
diff --git a/editors/emacs21/files/patch-src:alloc.c b/editors/emacs21/files/patch-src:alloc.c
new file mode 100644
index 000000000000..0ae9270b0d1f
--- /dev/null
+++ b/editors/emacs21/files/patch-src:alloc.c
@@ -0,0 +1,14 @@
+--- src/alloc.c.orig Thu Sep 12 13:50:01 2002
++++ src/alloc.c Thu Sep 12 13:48:11 2002
+@@ -3723,7 +3723,11 @@
+ /* This trick flushes the register windows so that all the state of
+ the process is contained in the stack. */
+ #ifdef sparc
++#ifdef __sparc64__
++ asm ("flushw");
++#else
+ asm ("ta 3");
++#endif
+ #endif
+
+ /* Save registers that we need to see on the stack. We need to see
diff --git a/editors/emacs21/files/patch-src:m:sparc.h b/editors/emacs21/files/patch-src:m:sparc.h
new file mode 100644
index 000000000000..8d594f5b5cef
--- /dev/null
+++ b/editors/emacs21/files/patch-src:m:sparc.h
@@ -0,0 +1,11 @@
+--- src/m/sparc.h.orig Thu Sep 12 02:25:09 2002
++++ src/m/sparc.h Thu Sep 12 12:33:36 2002
+@@ -89,7 +89,7 @@
+ #define PURESIZE 130000
+ #endif
+
+-#if !defined (__NetBSD__) && !defined (__linux__) && !defined (__OpenBSD__)
++#if !defined (__NetBSD__) && !defined (__linux__) && !defined (__OpenBSD__) && !defined(__FreeBSD__)
+ /* This really belongs in s/sun.h. */
+
+ /* Say that the text segment of a.out includes the header;