aboutsummaryrefslogtreecommitdiffstats
path: root/editors/f4l
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2007-10-22 04:00:25 +0800
committernox <nox@FreeBSD.org>2007-10-22 04:00:25 +0800
commitabf7adf1131b85ab6f14c43d831a46a001e05d83 (patch)
tree0f0c2f3ce495574767f281b3c624a622c955abde /editors/f4l
parent1ceb7a517a2959f7055cfa74d0c4673c775bd328 (diff)
downloadfreebsd-ports-gnome-abf7adf1131b85ab6f14c43d831a46a001e05d83.tar.gz
freebsd-ports-gnome-abf7adf1131b85ab6f14c43d831a46a001e05d83.tar.zst
freebsd-ports-gnome-abf7adf1131b85ab6f14c43d831a46a001e05d83.zip
Fix build with GCC 4.2
Approved by: shaun (maintainer, via irc)
Diffstat (limited to 'editors/f4l')
-rw-r--r--editors/f4l/Makefile6
-rw-r--r--editors/f4l/files/patch-src_flagStonePort_transform-cxx-bsd_transform_FSDefineSound.h10
2 files changed, 10 insertions, 6 deletions
diff --git a/editors/f4l/Makefile b/editors/f4l/Makefile
index ae511ca4559c..f0a1807182a5 100644
--- a/editors/f4l/Makefile
+++ b/editors/f4l/Makefile
@@ -26,12 +26,6 @@ PLIST_FILES= bin/${PORTNAME}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile with GCC 4.2
-.endif
-.endif
-
do-configure:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake
diff --git a/editors/f4l/files/patch-src_flagStonePort_transform-cxx-bsd_transform_FSDefineSound.h b/editors/f4l/files/patch-src_flagStonePort_transform-cxx-bsd_transform_FSDefineSound.h
new file mode 100644
index 000000000000..9fda58cc5237
--- /dev/null
+++ b/editors/f4l/files/patch-src_flagStonePort_transform-cxx-bsd_transform_FSDefineSound.h
@@ -0,0 +1,10 @@
+Index: src/flagStonePort/transform-cxx-bsd/transform/FSDefineSound.h
+@@ -137,7 +137,7 @@
+ @param bytes the sound data.
+ @param length the number of bytes in the sound data.
+ */
+- FSDefineSound::FSDefineSound(int anIdentifier, int encoding, int rate, int channels, int sampleSize, int count, byte* bytes, size_t length);
++ FSDefineSound(int anIdentifier, int encoding, int rate, int channels, int sampleSize, int count, byte* bytes, size_t length);
+
+ FSDefineSound(const FSDefineSound& rhs);
+