aboutsummaryrefslogtreecommitdiffstats
path: root/editors/fine
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2001-03-11 13:01:04 +0800
committersteve <steve@FreeBSD.org>2001-03-11 13:01:04 +0800
commitb6679516f174616a60f3cfbe7498793c18658a65 (patch)
treecf9ac5c315197e72e665895d86207c2c5a1b87d6 /editors/fine
parent57156ba907e0997b744cb722c78a0aa0f5cab004 (diff)
downloadfreebsd-ports-gnome-b6679516f174616a60f3cfbe7498793c18658a65.tar.gz
freebsd-ports-gnome-b6679516f174616a60f3cfbe7498793c18658a65.tar.zst
freebsd-ports-gnome-b6679516f174616a60f3cfbe7498793c18658a65.zip
Use '-O0' when compiling on the Alpha to avoid internal compiler errors.
Diffstat (limited to 'editors/fine')
-rw-r--r--editors/fine/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/editors/fine/Makefile b/editors/fine/Makefile
index 091a060a4a75..1f59a6eee76f 100644
--- a/editors/fine/Makefile
+++ b/editors/fine/Makefile
@@ -19,6 +19,12 @@ USE_GMAKE= yes
USE_QT2= yes
WRKSRC= ${WRKDIR}/fine
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -O0
+.endif
+
do-install:
@${MKDIR} ${PREFIX}/share/fine
${INSTALL_DATA} ${WRKSRC}/.editor ${PREFIX}/share/fine/editor
@@ -27,4 +33,4 @@ do-install:
.endfor
${INSTALL_PROGRAM} ${WRKSRC}/fine ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>