aboutsummaryrefslogtreecommitdiffstats
path: root/editors/flim-emacs
diff options
context:
space:
mode:
authorshige <shige@FreeBSD.org>1999-10-14 23:07:39 +0800
committershige <shige@FreeBSD.org>1999-10-14 23:07:39 +0800
commitaf9024d4b72aaa73adb803fa5c1b6f048bd95252 (patch)
treeae67480bfb6213a5490499ba7bd8ffb638a5587e /editors/flim-emacs
parent036e7974eed2638ee19aeb5067f37edcb5e296b3 (diff)
downloadfreebsd-ports-gnome-af9024d4b72aaa73adb803fa5c1b6f048bd95252.tar.gz
freebsd-ports-gnome-af9024d4b72aaa73adb803fa5c1b6f048bd95252.tar.zst
freebsd-ports-gnome-af9024d4b72aaa73adb803fa5c1b6f048bd95252.zip
Fix flim-elisp compile problem.
Fix `@unexec rmdir' command in PLIST. Pkg_delete does not return an error, even if there is other FLIM_COOKIEs in the cookies directory.
Diffstat (limited to 'editors/flim-emacs')
-rw-r--r--editors/flim-emacs/files/patch-aa12
-rw-r--r--editors/flim-emacs/pkg-plist2
2 files changed, 11 insertions, 3 deletions
diff --git a/editors/flim-emacs/files/patch-aa b/editors/flim-emacs/files/patch-aa
index 450d2b6f8af6..bbe4ab40628d 100644
--- a/editors/flim-emacs/files/patch-aa
+++ b/editors/flim-emacs/files/patch-aa
@@ -1,5 +1,5 @@
---- FLIM-CFG.orig Tue Sep 15 15:26:08 1998
-+++ FLIM-CFG Sun May 9 01:33:26 1999
+--- FLIM-CFG.orig Mon May 31 18:23:26 1999
++++ FLIM-CFG Thu Oct 14 23:56:32 1999
@@ -8,6 +8,8 @@
(add-to-list 'load-path
@@ -9,3 +9,11 @@
(if (boundp 'LISPDIR)
(progn
+@@ -19,6 +21,7 @@
+ (if (boundp 'VERSION_SPECIFIC_LISPDIR)
+ (add-to-list 'load-path VERSION_SPECIFIC_LISPDIR))
+
++(require 'emu)
+ (require 'install)
+
+ (add-latest-path "custom")
diff --git a/editors/flim-emacs/pkg-plist b/editors/flim-emacs/pkg-plist
index aea5bf19bdb6..fc7514552dae 100644
--- a/editors/flim-emacs/pkg-plist
+++ b/editors/flim-emacs/pkg-plist
@@ -44,4 +44,4 @@
info/mime-en.info
@exec install-info %D/info/mime-en.info %D/info/dir
share/flim/%%FLIM_COOKIE%%
-@unexec /bin/rmdir %D/share/flim
+@unexec /bin/rmdir %D/share/flim || true