aboutsummaryrefslogtreecommitdiffstats
path: root/editors/flim
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2017-07-29 05:45:20 +0800
committerjkim <jkim@FreeBSD.org>2017-07-29 05:45:20 +0800
commit37f42e3731b6421168cc6d1376fe8e064a767d16 (patch)
treea79f71211dc0ed6f08a805235e59f1fc3946e774 /editors/flim
parent184408c6f2a3d7e6645a3e28cf294fc9a0943e2e (diff)
downloadfreebsd-ports-gnome-37f42e3731b6421168cc6d1376fe8e064a767d16.tar.gz
freebsd-ports-gnome-37f42e3731b6421168cc6d1376fe8e064a767d16.tar.zst
freebsd-ports-gnome-37f42e3731b6421168cc6d1376fe8e064a767d16.zip
Set MAKEINFO to the full path of makeinfo when USES=makeinfo is set.
PR: 221027 Reviewed by: mat Approved by: portmgr (antoine)
Diffstat (limited to 'editors/flim')
-rw-r--r--editors/flim/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/flim/Makefile b/editors/flim/Makefile
index 8f2b7ccf0146..23ab1fc19363 100644
--- a/editors/flim/Makefile
+++ b/editors/flim/Makefile
@@ -60,7 +60,7 @@ BUILD_DEPENDS+= nkf:japanese/nkf
.endif
# makeinfo stuff
-MAKEINFO= makeinfo --no-split --no-validate
+MAKEINFO_FLAGS= --no-split --no-validate
MAKEINFO_EMACS= ${EMACS_CMD} -no-site-file -no-init-file -batch
MAKEINFO_EMACS_FLAGS= -e texinfo-format-buffer -f save-buffer
@@ -109,14 +109,14 @@ info-build:
for i in mime-en.texi; do \
${MV} $${i} $${i}.jis ; \
${CAT} $${i}.jis | nkf -e > $${i} ; \
- ${MAKEINFO} $${i} || ${TRUE} ; \
+ ${MAKEINFO} ${MAKEINFO_FLAGS} $${i} || ${TRUE} ; \
done)
.if defined(EMACS_HAS_MULE) && (${EMACS_HAS_MULE} == "YES")
@(cd ${WRKSRC} ; \
for i in mime-ja.texi; do \
${MV} $${i} $${i}.jis ; \
${CAT} $${i}.jis | nkf -e > $${i} ; \
- ${MAKEINFO} $${i} || ${TRUE} ; \
+ ${MAKEINFO} ${MAKEINFO_FLAGS} $${i} || ${TRUE} ; \
done)
.endif