aboutsummaryrefslogtreecommitdiffstats
path: root/editors/fpc-ide
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-07-24 19:21:27 +0800
committeracm <acm@FreeBSD.org>2006-07-24 19:21:27 +0800
commitbe8c2fc2f0a9dbc5795cca72bab530cd95ac8cf9 (patch)
treea3a2f4268e8fe61cde513b3aae848bcf90394d28 /editors/fpc-ide
parentf17c49926cffd90046cb36851ca50d5d2a825410 (diff)
downloadfreebsd-ports-gnome-be8c2fc2f0a9dbc5795cca72bab530cd95ac8cf9.tar.gz
freebsd-ports-gnome-be8c2fc2f0a9dbc5795cca72bab530cd95ac8cf9.tar.zst
freebsd-ports-gnome-be8c2fc2f0a9dbc5795cca72bab530cd95ac8cf9.zip
- The big change on ports of freepascal, now all ports are compiled
- Adding entry for lang/fpc-utils Approved by: garga (mentor)
Diffstat (limited to 'editors/fpc-ide')
-rw-r--r--editors/fpc-ide/Makefile23
-rw-r--r--editors/fpc-ide/pkg-plist17
2 files changed, 38 insertions, 2 deletions
diff --git a/editors/fpc-ide/Makefile b/editors/fpc-ide/Makefile
index ec6fafe50b52..b0aa86767269 100644
--- a/editors/fpc-ide/Makefile
+++ b/editors/fpc-ide/Makefile
@@ -8,13 +8,32 @@
CATEGORIES= editors lang
PKGNAMESUFFIX= -ide
-MAINTAINER= acardenas@bsd.org.pe
+MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal integrated IDE/compiler
-RUN_DEPENDS= ${UNITSDIR}/fv/Package.fpc:${PORTSDIR}/devel/fpc-fv
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
+ fpcmake:${PORTSDIR}/lang/fpc-utils \
+ ${UNITSDIR}/gdbint/Package.fpc:${PORTSDIR}/devel/fpc-gdbint \
+ ${UNITSDIR}/ibase/Package.fpc:${PORTSDIR}/databases/fpc-ibase \
+ ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
+ ${UNITSDIR}/md5/Package.fpc:${PORTSDIR}/security/fpc-md5 \
+ ${UNITSDIR}/mysql/Package.fpc:${PORTSDIR}/databases/fpc-mysql \
+ ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
+ ${UNITSDIR}/odbc/Package.fpc:${PORTSDIR}/databases/fpc-odbc \
+ ${UNITSDIR}/oracle/Package.fpc:${PORTSDIR}/databases/fpc-oracle \
+ ${UNITSDIR}/pasjpeg/Package.fpc:${PORTSDIR}/graphics/fpc-pasjpeg \
+ ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
+ ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads \
+ ${UNITSDIR}/postgres/Package.fpc:${PORTSDIR}/databases/fpc-postgres \
+ ${UNITSDIR}/regexpr/Package.fpc:${PORTSDIR}/devel/fpc-regexpr \
+ ${UNITSDIR}/sqlite/Package.fpc:${PORTSDIR}/databases/fpc-sqlite \
+ ${UNITSDIR}/fcl/Package.fpc:${PORTSDIR}/devel/fpc-fcl \
+ ${UNITSDIR}/fv/Package.fpc:${PORTSDIR}/devel/fpc-fv
UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
UNITPREFIX= # none
MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${PORTNAME}/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR} ${PORTNAME}/compiler ${PORTNAME}/rtl ${PORTNAME}/fv
.include "${MASTERDIR}/Makefile"
diff --git a/editors/fpc-ide/pkg-plist b/editors/fpc-ide/pkg-plist
new file mode 100644
index 000000000000..bf74d5ae8dae
--- /dev/null
+++ b/editors/fpc-ide/pkg-plist
@@ -0,0 +1,17 @@
+bin/fp
+lib/fpc/%%PORTVERSION%%/ide/fp.ans
+lib/fpc/%%PORTVERSION%%/ide/gplprog.pt
+lib/fpc/%%PORTVERSION%%/ide/gplunit.pt
+lib/fpc/%%PORTVERSION%%/ide/program.pt
+lib/fpc/%%PORTVERSION%%/ide/unit.pt
+lib/fpc/%%PORTVERSION%%/ide/cvsco.tdf
+lib/fpc/%%PORTVERSION%%/ide/cvsdiff.tdf
+lib/fpc/%%PORTVERSION%%/ide/cvsup.tdf
+lib/fpc/%%PORTVERSION%%/ide/grep.tdf
+lib/fpc/%%PORTVERSION%%/ide/tpgrep.tdf
+share/doc/fpc-%%PORTVERSION%%/ide/readme.ide
+@dirrm share/doc/fpc-%%PORTVERSION%%/ide
+@dirrmtry share/doc/fpc-%%PORTVERSION%%
+@dirrm lib/fpc/%%PORTVERSION%%/ide
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc