aboutsummaryrefslogtreecommitdiffstats
path: root/editors/gedit-plugins/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-04-10 13:56:28 +0800
committermarcus <marcus@FreeBSD.org>2009-04-10 13:56:28 +0800
commit06fff123f04648e578283b13f71108c1671ae751 (patch)
treee04217d1bf9d69846902902125c156a81eae643b /editors/gedit-plugins/Makefile
parentf488e4c3be8f7b25040ce1258e89a5550fb33bf8 (diff)
downloadfreebsd-ports-gnome-06fff123f04648e578283b13f71108c1671ae751.tar.gz
freebsd-ports-gnome-06fff123f04648e578283b13f71108c1671ae751.tar.zst
freebsd-ports-gnome-06fff123f04648e578283b13f71108c1671ae751.zip
Presenting GNOME 2.26 for FreeBSD. See
http://library.gnome.org/misc/release-notes/2.26/ for a list of what's new. On the FreeBSD front, we introduced a port of libxul 1.9 as an alternative for Firefox 2.0 as a Gecko provider. Almost all of the Gecko consumers can make use of this provider by setting: WITH_GECKO=libxul The GNOME 2.26 port was done by ahze, kwm, marcus, and mezz with contributions by Joseph S. Atkinson, Peter Wemm, Eric L. Chen, Martin Matuska, Craig Butler, and Pawel Worach.
Diffstat (limited to 'editors/gedit-plugins/Makefile')
-rw-r--r--editors/gedit-plugins/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index 5581f112acbd..7dcb9f3caed5 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -3,12 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/gedit-plugins/Makefile,v 1.33 2008/10/26 20:28:27 marcus Exp $
+# $MCom: ports/editors/gedit-plugins/Makefile,v 1.36 2009/03/17 13:37:37 kwm Exp $
#
PORTNAME= gedit-plugins
-PORTVERSION= 2.22.5
-PORTREVISION= 1
+PORTVERSION= 2.26.0
CATEGORIES= editors gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -33,6 +32,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= gedit-show-tabbar-plugin.schemas
+OPTIONS= PYTHON "Build plugins that depend on python" off
+
.if defined(PACKAGE_BUILDING)
.undef WITHOUT_GNOME
WITH_GNOME= yes
@@ -40,7 +41,7 @@ WITH_GNOME= yes
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mpygtksourceview}!="" && ${ARCH}!="sparc64"
+.if ${HAVE_GNOME:Mpygtksourceview}!="" && ${ARCH}!="sparc64" || defined(WITH_PYTHON)
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"
USE_GNOME+= pygtksourceview