aboutsummaryrefslogtreecommitdiffstats
path: root/editors/gedit-plugins
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-09-25 11:07:43 +0800
committeradamw <adamw@FreeBSD.org>2003-09-25 11:07:43 +0800
commitc502a114bd55d19071afcc832d7a0eed51be2ed5 (patch)
tree24903afdf4dfdb896b2273fdb4004865a8a792cd /editors/gedit-plugins
parentc9251465035d80ad21361c6bfa6239cbcbf4d12d (diff)
downloadfreebsd-ports-gnome-c502a114bd55d19071afcc832d7a0eed51be2ed5.tar.gz
freebsd-ports-gnome-c502a114bd55d19071afcc832d7a0eed51be2ed5.tar.zst
freebsd-ports-gnome-c502a114bd55d19071afcc832d7a0eed51be2ed5.zip
Add gedit-plugins, some plugins for gedit2. They're neat.
Obtained from: marcuscom
Diffstat (limited to 'editors/gedit-plugins')
-rw-r--r--editors/gedit-plugins/Makefile27
-rw-r--r--editors/gedit-plugins/distinfo1
-rw-r--r--editors/gedit-plugins/files/patch-configure10
-rw-r--r--editors/gedit-plugins/pkg-descr1
-rw-r--r--editors/gedit-plugins/pkg-plist8
5 files changed, 47 insertions, 0 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
new file mode 100644
index 000000000000..3766b80b5c5b
--- /dev/null
+++ b/editors/gedit-plugins/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gedit-plugins
+# Date created: 19 September 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gedit-plugins
+PORTVERSION= 2.3.5
+CATEGORIES= editors gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Plugins for gedit2
+
+BUILD_DEPENDS= gedit:${PORTSDIR}/editors/gedit2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_PERL5= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget
+
+.include <bsd.port.mk>
diff --git a/editors/gedit-plugins/distinfo b/editors/gedit-plugins/distinfo
new file mode 100644
index 000000000000..f05e408cbfd4
--- /dev/null
+++ b/editors/gedit-plugins/distinfo
@@ -0,0 +1 @@
+MD5 (gedit-plugins-2.3.5.tar.bz2) = 6925b3f5150a0e265abeb6d4657728d1
diff --git a/editors/gedit-plugins/files/patch-configure b/editors/gedit-plugins/files/patch-configure
new file mode 100644
index 000000000000..0823124aa20e
--- /dev/null
+++ b/editors/gedit-plugins/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Fri Sep 19 22:52:09 2003
++++ configure Fri Sep 19 22:52:44 2003
+@@ -18474,6 +18474,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/editors/gedit-plugins/pkg-descr b/editors/gedit-plugins/pkg-descr
new file mode 100644
index 000000000000..9edebc33fc6b
--- /dev/null
+++ b/editors/gedit-plugins/pkg-descr
@@ -0,0 +1 @@
+Various plugins for gedit2.
diff --git a/editors/gedit-plugins/pkg-plist b/editors/gedit-plugins/pkg-plist
new file mode 100644
index 000000000000..1a1b5e30a7ec
--- /dev/null
+++ b/editors/gedit-plugins/pkg-plist
@@ -0,0 +1,8 @@
+lib/gedit-2/plugins/ascii.gedit-plugin
+lib/gedit-2/plugins/cvschangelog.gedit-plugin
+lib/gedit-2/plugins/diff.gedit-plugin
+lib/gedit-2/plugins/libasciitable.so
+lib/gedit-2/plugins/libcvschangelog.so
+lib/gedit-2/plugins/libdiff.so
+share/gnome/gedit-2/glade/asciitable.glade2
+share/gnome/gedit-2/glade/diff.glade2