aboutsummaryrefslogtreecommitdiffstats
path: root/editors/gedit
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-04-10 13:56:28 +0800
committermarcus <marcus@FreeBSD.org>2009-04-10 13:56:28 +0800
commit06fff123f04648e578283b13f71108c1671ae751 (patch)
treee04217d1bf9d69846902902125c156a81eae643b /editors/gedit
parentf488e4c3be8f7b25040ce1258e89a5550fb33bf8 (diff)
downloadfreebsd-ports-gnome-06fff123f04648e578283b13f71108c1671ae751.tar.gz
freebsd-ports-gnome-06fff123f04648e578283b13f71108c1671ae751.tar.zst
freebsd-ports-gnome-06fff123f04648e578283b13f71108c1671ae751.zip
Presenting GNOME 2.26 for FreeBSD. See
http://library.gnome.org/misc/release-notes/2.26/ for a list of what's new. On the FreeBSD front, we introduced a port of libxul 1.9 as an alternative for Firefox 2.0 as a Gecko provider. Almost all of the Gecko consumers can make use of this provider by setting: WITH_GECKO=libxul The GNOME 2.26 port was done by ahze, kwm, marcus, and mezz with contributions by Joseph S. Atkinson, Peter Wemm, Eric L. Chen, Martin Matuska, Craig Butler, and Pawel Worach.
Diffstat (limited to 'editors/gedit')
-rw-r--r--editors/gedit/Makefile18
-rw-r--r--editors/gedit/distinfo6
-rw-r--r--editors/gedit/files/patch-configure18
-rw-r--r--editors/gedit/files/patch-gedit_gedit-module.c11
-rw-r--r--editors/gedit/pkg-plist72
5 files changed, 60 insertions, 65 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 92aa6d158841..636185cd11ee 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/gedit/Makefile,v 1.91 2008/11/25 00:59:25 marcus Exp $
+# $MCom: ports/editors/gedit/Makefile,v 1.97 2009/03/16 08:01:49 kwm Exp $
#
PORTNAME= gedit
-PORTVERSION= 2.24.3
+PORTVERSION= 2.26.0
CATEGORIES= editors gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -54,15 +54,11 @@ CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|make|${GMAKE}|g' \
- ${WRKSRC}/bindings/python/Makefile.in
-
-pre-build:
- ${MKDIR} ${WRKSRC}/bindings/python/.deps
-.for ff in gedit_la-gedit.Plo gedit_la-geditcommands.Plo gedit_la-geditutils.Plo
- ${TOUCH} ${WRKSRC}/bindings/python/.deps/${ff}
-.endfor
+#pre-build:
+# ${MKDIR} ${WRKSRC}/bindings/python/.deps
+#.for ff in gedit_la-gedit.Plo gedit_la-geditcommands.Plo gedit_la-geditutils.Plo
+# ${TOUCH} ${WRKSRC}/bindings/python/.deps/${ff}
+#.endfor
post-install:
@-update-desktop-database
diff --git a/editors/gedit/distinfo b/editors/gedit/distinfo
index c3d0f1c885ea..14b1f2704313 100644
--- a/editors/gedit/distinfo
+++ b/editors/gedit/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gedit-2.24.3.tar.bz2) = 48ed6c5c156791cffc219a7d7390da57
-SHA256 (gnome2/gedit-2.24.3.tar.bz2) = 37f5dc0df169a2e8756b1c29e9283a323a1ec132888493a07c8d4e98c29b16f2
-SIZE (gnome2/gedit-2.24.3.tar.bz2) = 4078641
+MD5 (gnome2/gedit-2.26.0.tar.bz2) = 577b30e6f17f6dce0af7be3e522d6058
+SHA256 (gnome2/gedit-2.26.0.tar.bz2) = c1fde28ba54e2b6b9457b7a21e40f88989428838d2ef6e9fbd496955442d3552
+SIZE (gnome2/gedit-2.26.0.tar.bz2) = 4198506
diff --git a/editors/gedit/files/patch-configure b/editors/gedit/files/patch-configure
deleted file mode 100644
index 6bfadb0af650..000000000000
--- a/editors/gedit/files/patch-configure
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.orig Wed Dec 14 09:07:01 2005
-+++ configure Wed Dec 14 09:07:01 2005
-@@ -22216,6 +22216,7 @@
- if eval "test \"\${$as_ac_var+set}\" = set"; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
-+ LIBS="-lintl $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -22304,6 +22305,7 @@
- cat >>confdefs.h <<_ACEOF
- #define `echo "HAVE_$ac_func" | $as_tr_cpp` 1
- _ACEOF
-+LIBS="-lintl $LIBS"
-
- fi
- done
diff --git a/editors/gedit/files/patch-gedit_gedit-module.c b/editors/gedit/files/patch-gedit_gedit-module.c
deleted file mode 100644
index b12781557ee5..000000000000
--- a/editors/gedit/files/patch-gedit_gedit-module.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- gedit/gedit-module.c.orig Fri Jan 6 12:19:53 2006
-+++ gedit/gedit-module.c Fri Jan 6 12:20:21 2006
-@@ -142,7 +142,7 @@ gedit_module_unload (GTypeModule *gmodul
-
- gedit_debug_message (DEBUG_PLUGINS, "Unloading %s", module->path);
-
-- g_module_close (module->library);
-+ /*g_module_close (module->library);*/
-
- module->library = NULL;
- module->type = 0;
diff --git a/editors/gedit/pkg-plist b/editors/gedit/pkg-plist
index 4648fe458b3a..156f54593334 100644
--- a/editors/gedit/pkg-plist
+++ b/editors/gedit/pkg-plist
@@ -9,18 +9,29 @@ include/gedit-%%VERSION%%/gedit/gedit-encodings.h
include/gedit-%%VERSION%%/gedit/gedit-file-chooser-dialog.h
include/gedit-%%VERSION%%/gedit/gedit-help.h
include/gedit-%%VERSION%%/gedit/gedit-message-area.h
+include/gedit-%%VERSION%%/gedit/gedit-message-bus.h
+include/gedit-%%VERSION%%/gedit/gedit-message-type.h
+include/gedit-%%VERSION%%/gedit/gedit-message.h
include/gedit-%%VERSION%%/gedit/gedit-metadata-manager.h
include/gedit-%%VERSION%%/gedit/gedit-notebook.h
include/gedit-%%VERSION%%/gedit/gedit-panel.h
+include/gedit-%%VERSION%%/gedit/gedit-plugin-loader.h
include/gedit-%%VERSION%%/gedit/gedit-plugin.h
include/gedit-%%VERSION%%/gedit/gedit-prefs-manager-app.h
include/gedit-%%VERSION%%/gedit/gedit-prefs-manager.h
include/gedit-%%VERSION%%/gedit/gedit-progress-message-area.h
include/gedit-%%VERSION%%/gedit/gedit-statusbar.h
+include/gedit-%%VERSION%%/gedit/gedit-status-combo-box.h
include/gedit-%%VERSION%%/gedit/gedit-tab.h
include/gedit-%%VERSION%%/gedit/gedit-utils.h
include/gedit-%%VERSION%%/gedit/gedit-view.h
include/gedit-%%VERSION%%/gedit/gedit-window.h
+lib/gedit-2/plugin-loaders/libcloader.a
+lib/gedit-2/plugin-loaders/libcloader.la
+lib/gedit-2/plugin-loaders/libcloader.so
+%%PYTHON%%lib/gedit-2/plugin-loaders/libpythonloader.a
+%%PYTHON%%lib/gedit-2/plugin-loaders/libpythonloader.la
+%%PYTHON%%lib/gedit-2/plugin-loaders/libpythonloader.so
lib/gedit-2/plugins/changecase.gedit-plugin
lib/gedit-2/plugins/docinfo.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/externaltools.gedit-plugin
@@ -45,8 +56,6 @@ lib/gedit-2/plugins/docinfo.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.py
%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.pyc
%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.pyo
-%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.ui
-%%PYTHON%%lib/gedit-2/plugins/externaltools/tools.ui
lib/gedit-2/plugins/filebrowser.gedit-plugin
lib/gedit-2/plugins/indent.gedit-plugin
lib/gedit-2/plugins/libchangecase.a
@@ -84,6 +93,9 @@ lib/gedit-2/plugins/modelines.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/pythonconsole/__init__.py
%%PYTHON%%lib/gedit-2/plugins/pythonconsole/__init__.pyc
%%PYTHON%%lib/gedit-2/plugins/pythonconsole/__init__.pyo
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole/config.py
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole/config.pyc
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole/config.pyo
%%PYTHON%%lib/gedit-2/plugins/pythonconsole/console.py
%%PYTHON%%lib/gedit-2/plugins/pythonconsole/console.pyc
%%PYTHON%%lib/gedit-2/plugins/pythonconsole/console.pyo
@@ -131,7 +143,6 @@ lib/gedit-2/plugins/sample.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/snippets/__init__.py
%%PYTHON%%lib/gedit-2/plugins/snippets/__init__.pyc
%%PYTHON%%lib/gedit-2/plugins/snippets/__init__.pyo
-%%PYTHON%%lib/gedit-2/plugins/snippets/snippets.ui
lib/gedit-2/plugins/sort.gedit-plugin
lib/gedit-2/plugins/spell.gedit-plugin
lib/gedit-2/plugins/taglist.gedit-plugin
@@ -143,7 +154,9 @@ share/applications/gedit.desktop
%%DOCSDIR%%/GeditDocument.html
%%DOCSDIR%%/GeditEncodingsOptionMenu.html
%%DOCSDIR%%/GeditFileChooserDialog.html
+%%DOCSDIR%%/GeditMessage.html
%%DOCSDIR%%/GeditMessageArea.html
+%%DOCSDIR%%/GeditMessageBus.html
%%DOCSDIR%%/GeditNotebook.html
%%DOCSDIR%%/GeditPanel.html
%%DOCSDIR%%/GeditPlugin.html
@@ -153,6 +166,7 @@ share/applications/gedit.desktop
%%DOCSDIR%%/GeditView.html
%%DOCSDIR%%/GeditWindow.html
%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/gedit-GeditMessageType.html
%%DOCSDIR%%/gedit-GeditPrintJob.html
%%DOCSDIR%%/gedit-GeditPrintJobPreview.html
%%DOCSDIR%%/gedit-gedit-convert.html
@@ -176,11 +190,16 @@ share/gedit-2/icons/gedit-plugin.png
share/gedit-2/logo/gedit-logo.png
@exec mkdir -p %D/share/gedit-2/plugins/changecase
share/gedit-2/plugins/docinfo/docinfo.ui
+%%PYTHON%%share/gedit-2/plugins/externaltools/ui/tools.ui
+%%PYTHON%%share/gedit-2/plugins/externaltools/ui/outputpanel.ui
share/gedit-2/plugins/filebrowser/gedit-file-browser-widget-ui.xml
@exec mkdir -p %D/share/gedit-2/plugins/indent
+share/gedit-2/plugins/modelines/language-mappings
+%%PYTHON%%share/gedit-2/plugins/pythonconsole/ui/config.ui
@exec mkdir -p %D/share/gedit-2/plugins/sample
-%%PYTHON%%share/gedit-2/plugins/snippets/c++.xml
%%PYTHON%%share/gedit-2/plugins/snippets/c.xml
+%%PYTHON%%share/gedit-2/plugins/snippets/chdr.xml
+%%PYTHON%%share/gedit-2/plugins/snippets/cpp.xml
%%PYTHON%%share/gedit-2/plugins/snippets/css.xml
%%PYTHON%%share/gedit-2/plugins/snippets/docbook.xml
%%PYTHON%%share/gedit-2/plugins/snippets/global.xml
@@ -198,19 +217,20 @@ share/gedit-2/plugins/filebrowser/gedit-file-browser-widget-ui.xml
%%PYTHON%%share/gedit-2/plugins/snippets/sh.xml
%%PYTHON%%share/gedit-2/plugins/snippets/snippets.xml
%%PYTHON%%share/gedit-2/plugins/snippets/tcl.xml
+%%PYTHON%%share/gedit-2/plugins/snippets/ui/snippets.ui
%%PYTHON%%share/gedit-2/plugins/snippets/xml.xml
share/gedit-2/plugins/sort/sort.ui
share/gedit-2/plugins/spell/languages-dialog.ui
share/gedit-2/plugins/spell/spell-checker.ui
+share/gedit-2/plugins/taglist/HTML.tags.gz
+share/gedit-2/plugins/taglist/Latex.tags.gz
+share/gedit-2/plugins/taglist/XSLT.tags.gz
+share/gedit-2/plugins/taglist/XUL.tags.gz
share/gedit-2/plugins/time/time.ui
%%PYTHON%%share/gedit-2/plugins/tools/build
%%PYTHON%%share/gedit-2/plugins/tools/open-terminal-here
%%PYTHON%%share/gedit-2/plugins/tools/remove-trailing-spaces
%%PYTHON%%share/gedit-2/plugins/tools/run-command
-share/gedit-2/taglist/HTML.tags.gz
-share/gedit-2/taglist/Latex.tags.gz
-share/gedit-2/taglist/XSLT.tags.gz
-share/gedit-2/taglist/XUL.tags.gz
share/gedit-2/ui/gedit-encodings-dialog.ui
share/gedit-2/ui/gedit-open-location-dialog.ui
share/gedit-2/ui/gedit-preferences-dialog.ui
@@ -257,10 +277,6 @@ share/gnome/help/gedit/es/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/es/figures/gedit_window.png
share/gnome/help/gedit/es/gedit.xml
share/gnome/help/gedit/es/legal.xml
-share/gnome/help/gedit/eu/figures/gedit_recent_files_menu_icon.png
-share/gnome/help/gedit/eu/figures/gedit_window.png
-share/gnome/help/gedit/eu/gedit.xml
-share/gnome/help/gedit/eu/legal.xml
share/gnome/help/gedit/fi/figures/gedit_format_bold.png
share/gnome/help/gedit/fi/figures/gedit_format_italic.png
share/gnome/help/gedit/fi/figures/gedit_format_strikethrough.png
@@ -325,9 +341,6 @@ share/gnome/help/gedit/pt_BR/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/pt_BR/figures/gedit_window.png
share/gnome/help/gedit/pt_BR/gedit.xml
share/gnome/help/gedit/pt_BR/legal.xml
-share/gnome/help/gedit/ro/figures/gedit_window.png
-share/gnome/help/gedit/ro/gedit.xml
-share/gnome/help/gedit/ro/legal.xml
share/gnome/help/gedit/ru/figures/gedit_format_bold.png
share/gnome/help/gedit/ru/figures/gedit_format_italic.png
share/gnome/help/gedit/ru/figures/gedit_format_strikethrough.png
@@ -344,6 +357,14 @@ share/gnome/help/gedit/sv/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/sv/figures/gedit_window.png
share/gnome/help/gedit/sv/gedit.xml
share/gnome/help/gedit/sv/legal.xml
+share/gnome/help/gedit/th/figures/gedit_format_bold.png
+share/gnome/help/gedit/th/figures/gedit_format_italic.png
+share/gnome/help/gedit/th/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/th/figures/gedit_format_underline.png
+share/gnome/help/gedit/th/figures/gedit_recent_files_menu_icon.png
+share/gnome/help/gedit/th/figures/gedit_window.png
+share/gnome/help/gedit/th/gedit.xml
+share/gnome/help/gedit/th/legal.xml
share/gnome/help/gedit/uk/figures/gedit_format_bold.png
share/gnome/help/gedit/uk/figures/gedit_format_italic.png
share/gnome/help/gedit/uk/figures/gedit_format_strikethrough.png
@@ -380,6 +401,7 @@ share/locale/af/LC_MESSAGES/gedit.mo
share/locale/am/LC_MESSAGES/gedit.mo
share/locale/ar/LC_MESSAGES/gedit.mo
share/locale/as/LC_MESSAGES/gedit.mo
+share/locale/ast/LC_MESSAGES/gedit.mo
share/locale/az/LC_MESSAGES/gedit.mo
share/locale/be/LC_MESSAGES/gedit.mo
share/locale/be@latin/LC_MESSAGES/gedit.mo
@@ -468,7 +490,6 @@ share/omf/gedit/gedit-bg.omf
share/omf/gedit/gedit-da.omf
share/omf/gedit/gedit-de.omf
share/omf/gedit/gedit-es.omf
-share/omf/gedit/gedit-eu.omf
share/omf/gedit/gedit-fi.omf
share/omf/gedit/gedit-fr.omf
share/omf/gedit/gedit-hu.omf
@@ -477,9 +498,9 @@ share/omf/gedit/gedit-ja.omf
share/omf/gedit/gedit-ko.omf
share/omf/gedit/gedit-oc.omf
share/omf/gedit/gedit-pt_BR.omf
-share/omf/gedit/gedit-ro.omf
share/omf/gedit/gedit-ru.omf
share/omf/gedit/gedit-sv.omf
+share/omf/gedit/gedit-th.omf
share/omf/gedit/gedit-uk.omf
share/omf/gedit/gedit-zh_CN.omf
share/omf/gedit/gedit-zh_HK.omf
@@ -493,12 +514,12 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrm share/gnome/help/gedit/zh_CN
@dirrm share/gnome/help/gedit/uk/figures
@dirrm share/gnome/help/gedit/uk
+@dirrm share/gnome/help/gedit/th/figures
+@dirrm share/gnome/help/gedit/th
@dirrm share/gnome/help/gedit/sv/figures
@dirrm share/gnome/help/gedit/sv
@dirrm share/gnome/help/gedit/ru/figures
@dirrm share/gnome/help/gedit/ru
-@dirrm share/gnome/help/gedit/ro/figures
-@dirrm share/gnome/help/gedit/ro
@dirrm share/gnome/help/gedit/pt_BR/figures
@dirrm share/gnome/help/gedit/pt_BR
@dirrm share/gnome/help/gedit/oc/figures
@@ -515,8 +536,6 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrm share/gnome/help/gedit/fr
@dirrm share/gnome/help/gedit/fi/figures
@dirrm share/gnome/help/gedit/fi
-@dirrm share/gnome/help/gedit/eu/figures
-@dirrm share/gnome/help/gedit/eu
@dirrm share/gnome/help/gedit/es/figures
@dirrm share/gnome/help/gedit/es
@dirrm share/gnome/help/gedit/de/figures
@@ -529,16 +548,22 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrm share/gnome/help/gedit/C
@dirrm share/gnome/help/gedit
@dirrm share/gedit-2/ui
-@dirrm share/gedit-2/taglist
%%PYTHON%%@dirrm share/gedit-2/plugins/tools
@dirrm share/gedit-2/plugins/time
+@dirrm share/gedit-2/plugins/taglist
@dirrm share/gedit-2/plugins/spell
@dirrm share/gedit-2/plugins/sort
+%%PYTHON%%@dirrm share/gedit-2/plugins/snippets/ui
%%PYTHON%%@dirrm share/gedit-2/plugins/snippets/lang
%%PYTHON%%@dirrm share/gedit-2/plugins/snippets
@dirrm share/gedit-2/plugins/sample
+%%PYTHON%%@dirrm share/gedit-2/plugins/pythonconsole/ui
+%%PYTHON%%@dirrm share/gedit-2/plugins/pythonconsole
+@dirrm share/gedit-2/plugins/modelines
@dirrm share/gedit-2/plugins/indent
@dirrm share/gedit-2/plugins/filebrowser
+%%PYTHON%%@dirrm share/gedit-2/plugins/externaltools/ui
+%%PYTHON%%@dirrm share/gedit-2/plugins/externaltools
@dirrm share/gedit-2/plugins/docinfo
@dirrm share/gedit-2/plugins/changecase
@dirrm share/gedit-2/plugins
@@ -552,6 +577,7 @@ share/omf/gedit/gedit-zh_TW.omf
%%PYTHON%%@dirrm lib/gedit-2/plugins/pythonconsole
%%PYTHON%%@dirrm lib/gedit-2/plugins/externaltools
@dirrmtry lib/gedit-2/plugins
+@dirrmtry lib/gedit-2/plugin-loaders
@dirrmtry lib/gedit-2
@dirrm include/gedit-%%VERSION%%/gedit
@dirrm include/gedit-%%VERSION%%
@@ -593,5 +619,7 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as