aboutsummaryrefslogtreecommitdiffstats
path: root/editors/gmanedit/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-07-28 09:27:25 +0800
committermarcus <marcus@FreeBSD.org>2002-07-28 09:27:25 +0800
commitfb947f30bcadeb21a00a493326557efe11001959 (patch)
tree6d8b26970c83974ea2ccde5837953d228ebc9279 /editors/gmanedit/Makefile
parent4ef0ee5c0742eddefe891581a58a37d2093b25fe (diff)
downloadfreebsd-ports-gnome-fb947f30bcadeb21a00a493326557efe11001959.tar.gz
freebsd-ports-gnome-fb947f30bcadeb21a00a493326557efe11001959.tar.zst
freebsd-ports-gnome-fb947f30bcadeb21a00a493326557efe11001959.zip
Use USE_GNOMENG.
Diffstat (limited to 'editors/gmanedit/Makefile')
-rw-r--r--editors/gmanedit/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/editors/gmanedit/Makefile b/editors/gmanedit/Makefile
index ba80cec22f4b..20bad88faaaa 100644
--- a/editors/gmanedit/Makefile
+++ b/editors/gmanedit/Makefile
@@ -18,7 +18,8 @@ USE_REINPLACE= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -28,12 +29,8 @@ ALL_TARGET= clean all
post-extract:
@${RM} -rf ${WRKSRC}/config.cache
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
- 's|\$(datadir)/gnome/|\$(datadir)/|g'
- @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
- 's|\$(datadir)/locale|\$(prefix)/share/locale|g'
.include <bsd.port.mk>