aboutsummaryrefslogtreecommitdiffstats
path: root/editors/gphpedit/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-12-22 15:30:30 +0800
committermezz <mezz@FreeBSD.org>2004-12-22 15:30:30 +0800
commit4a47f2caaa578abec99316c7645840eb14fc9c94 (patch)
treee1520526b6c67eea490e717f06db55210d12dd1c /editors/gphpedit/Makefile
parent3e5dd825533ff87c4387fe359cb251520d72e266 (diff)
downloadfreebsd-ports-gnome-4a47f2caaa578abec99316c7645840eb14fc9c94.tar.gz
freebsd-ports-gnome-4a47f2caaa578abec99316c7645840eb14fc9c94.tar.zst
freebsd-ports-gnome-4a47f2caaa578abec99316c7645840eb14fc9c94.zip
gPHPEdit is a Gnome2 text editor optimised for editing PHP, HTML and CSS
files. It supports editing multiple documents with a tabbed interface, PHP syntax checking, PHP/HTML syntax highlighting, a function list for all open documents, incremental search, pop-up function hints, and block (un)indentation. WWW: http://www.gphpedit.org/ PR: ports/74204 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
Diffstat (limited to 'editors/gphpedit/Makefile')
-rw-r--r--editors/gphpedit/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/editors/gphpedit/Makefile b/editors/gphpedit/Makefile
new file mode 100644
index 000000000000..73e71eef2571
--- /dev/null
+++ b/editors/gphpedit/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: gphpedit
+# Date created: 2004-11-21
+# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gphpedit
+PORTVERSION= 0.9.50
+CATEGORIES= editors gnome
+MASTER_SITES= http://www.gphpedit.org/download/store/
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= PHP, HTML and CSS development environment for GNOME 2.x
+
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack libgnomeui libgtkhtml
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_PHP)
+USE_PHP= yes
+WANT_PHP_CLI= yes
+.endif
+
+.if !defined(WITHOUT_PHPDOC)
+RUN_DEPENDS+= ${LOCALBASE}/share/doc/php-en/about.html:${PORTSDIR}/lang/php_doc
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_PHP) || !defined(WITHOUT_PHPDOC)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} " "
+.endif
+.if !defined(WITHOUT_PHP)
+ @${ECHO_MSG} "WITHOUT_PHP=yes to not install php, debug script will not work without it."
+.endif
+.if !defined(WITHOUT_PHPDOC)
+ @${ECHO_MSG} "WITHOUT_PHPDOC=yes to not install php_doc, help will be disable."
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share/gnome|g' \
+ ${WRKSRC}/src/main.h
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share/gnome|g' \
+ ${WRKSRC}/src/calltip.c ${WRKSRC}/src/main_window.c
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/src/tab.c
+
+.include <bsd.port.mk>