aboutsummaryrefslogtreecommitdiffstats
path: root/editors/gphpedit
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-12-22 15:30:30 +0800
committermezz <mezz@FreeBSD.org>2004-12-22 15:30:30 +0800
commit4a47f2caaa578abec99316c7645840eb14fc9c94 (patch)
treee1520526b6c67eea490e717f06db55210d12dd1c /editors/gphpedit
parent3e5dd825533ff87c4387fe359cb251520d72e266 (diff)
downloadfreebsd-ports-gnome-4a47f2caaa578abec99316c7645840eb14fc9c94.tar.gz
freebsd-ports-gnome-4a47f2caaa578abec99316c7645840eb14fc9c94.tar.zst
freebsd-ports-gnome-4a47f2caaa578abec99316c7645840eb14fc9c94.zip
gPHPEdit is a Gnome2 text editor optimised for editing PHP, HTML and CSS
files. It supports editing multiple documents with a tabbed interface, PHP syntax checking, PHP/HTML syntax highlighting, a function list for all open documents, incremental search, pop-up function hints, and block (un)indentation. WWW: http://www.gphpedit.org/ PR: ports/74204 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
Diffstat (limited to 'editors/gphpedit')
-rw-r--r--editors/gphpedit/Makefile52
-rw-r--r--editors/gphpedit/distinfo2
-rw-r--r--editors/gphpedit/files/patch-gphpedit.desktop.in10
-rw-r--r--editors/gphpedit/files/patch-src-Makefile.in11
-rw-r--r--editors/gphpedit/files/patch-src::gtkscintilla2::Makefile37
-rw-r--r--editors/gphpedit/files/patch-src::gtkscintilla2::gtk::makefile48
-rw-r--r--editors/gphpedit/files/patch-src::tab.c99
-rw-r--r--editors/gphpedit/pkg-descr7
-rw-r--r--editors/gphpedit/pkg-plist5
9 files changed, 271 insertions, 0 deletions
diff --git a/editors/gphpedit/Makefile b/editors/gphpedit/Makefile
new file mode 100644
index 000000000000..73e71eef2571
--- /dev/null
+++ b/editors/gphpedit/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: gphpedit
+# Date created: 2004-11-21
+# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gphpedit
+PORTVERSION= 0.9.50
+CATEGORIES= editors gnome
+MASTER_SITES= http://www.gphpedit.org/download/store/
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= PHP, HTML and CSS development environment for GNOME 2.x
+
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack libgnomeui libgtkhtml
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_PHP)
+USE_PHP= yes
+WANT_PHP_CLI= yes
+.endif
+
+.if !defined(WITHOUT_PHPDOC)
+RUN_DEPENDS+= ${LOCALBASE}/share/doc/php-en/about.html:${PORTSDIR}/lang/php_doc
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_PHP) || !defined(WITHOUT_PHPDOC)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} " "
+.endif
+.if !defined(WITHOUT_PHP)
+ @${ECHO_MSG} "WITHOUT_PHP=yes to not install php, debug script will not work without it."
+.endif
+.if !defined(WITHOUT_PHPDOC)
+ @${ECHO_MSG} "WITHOUT_PHPDOC=yes to not install php_doc, help will be disable."
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share/gnome|g' \
+ ${WRKSRC}/src/main.h
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share/gnome|g' \
+ ${WRKSRC}/src/calltip.c ${WRKSRC}/src/main_window.c
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/src/tab.c
+
+.include <bsd.port.mk>
diff --git a/editors/gphpedit/distinfo b/editors/gphpedit/distinfo
new file mode 100644
index 000000000000..6aab040ea02b
--- /dev/null
+++ b/editors/gphpedit/distinfo
@@ -0,0 +1,2 @@
+MD5 (gphpedit-0.9.50.tar.gz) = 5683f1f196d8c80bdad587a043423046
+SIZE (gphpedit-0.9.50.tar.gz) = 829535
diff --git a/editors/gphpedit/files/patch-gphpedit.desktop.in b/editors/gphpedit/files/patch-gphpedit.desktop.in
new file mode 100644
index 000000000000..2ac91a6a5e4e
--- /dev/null
+++ b/editors/gphpedit/files/patch-gphpedit.desktop.in
@@ -0,0 +1,10 @@
+--- gphpedit.desktop.in.orig Sat Dec 18 14:14:16 2004
++++ gphpedit.desktop.in Sat Dec 18 14:14:39 2004
+@@ -5,5 +5,5 @@
+ Terminal=false
+ MultipleArgs=true
+ Type=Application
+-Categories=Application;Development;X-Red-Hat-Base;
+-Icon=/usr/share/pixmaps/gphpedit.png
++Categories=Application;Development
++Icon=gphpedit.png
diff --git a/editors/gphpedit/files/patch-src-Makefile.in b/editors/gphpedit/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..dcbbec9a32f9
--- /dev/null
+++ b/editors/gphpedit/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sun Nov 21 17:31:35 2004
++++ src/Makefile.in Sun Nov 21 17:32:14 2004
+@@ -495,7 +495,7 @@
+ -g -Wall -DGTK -DSCI_LEXER
+
+ gtkscintilla2/libgtkscintilla2.a:
+- cd gtkscintilla2 && make libgtkscintilla2.a && cd ..
++ @cd gtkscintilla2 && $(MAKE) libgtkscintilla2.a && cd ..
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/editors/gphpedit/files/patch-src::gtkscintilla2::Makefile b/editors/gphpedit/files/patch-src::gtkscintilla2::Makefile
new file mode 100644
index 000000000000..ab700aae66bf
--- /dev/null
+++ b/editors/gphpedit/files/patch-src::gtkscintilla2::Makefile
@@ -0,0 +1,37 @@
+--- src/gtkscintilla2/Makefile.orig Wed Nov 3 07:27:52 2004
++++ src/gtkscintilla2/Makefile Sat Dec 18 14:10:04 2004
+@@ -2,7 +2,7 @@
+
+ NAME = GtkScintilla2
+ LIB_NAME = gtkscintilla2
+-VERSION = 0.1.0
++VERSION = 0
+ PREFIX = $(shell pkg-config --variable=prefix gtk+-2.0)
+
+ SCINTILLA_DIR = ./scintilla
+@@ -10,12 +10,12 @@
+ SCINTILLA_LIB = $(SCINTILLA_DIR)/bin/scintilla.a
+ SCINTILLA_IFACE = $(SCINTILLA_INCLUDE)/Scintilla.iface
+ LEXERS = $(wildcard $(SCINTILLA_DIR)/gtk/Lex*.o)
+-CFLAGS = $(shell pkg-config --cflags gtk+-2.0) -g -Wall -DGTK -DSCI_LEXER
+-LDFLAGS_PRE = $(shell pkg-config --libs gtk+-2.0) -DGTK2
++CFLAGS += $(shell pkg-config --cflags gtk+-2.0 gthread-2.0) -Wall -DGTK -DSCI_LEXER -DPIC -fpic
++LDFLAGS_PRE = $(shell pkg-config --libs gtk+-2.0 gthread-2.0) -DGTK2
+ LDFLAGS_POST = $(LEXERS) $(SCINTILLA_LIB) -lstdc++
+
+-CC = gcc
+-LD = gcc
++CC ?= gcc
++LD = $(CC)
+ AR = ar
+
+ STATIC_LIB = lib$(LIB_NAME).a
+@@ -23,7 +23,7 @@
+
+ LIB_DIR = $(PREFIX)/lib
+ INCLUDE_DIR = $(PREFIX)/include/$(LIB_NAME)
+-PKG_CONFIG_DIR = $(PREFIX)/lib/pkgconfig
++PKG_CONFIG_DIR = $(PREFIX)/libdata/pkgconfig
+
+ all: $(STATIC_LIB) $(SHARED_LIB)
+
diff --git a/editors/gphpedit/files/patch-src::gtkscintilla2::gtk::makefile b/editors/gphpedit/files/patch-src::gtkscintilla2::gtk::makefile
new file mode 100644
index 000000000000..7cdb9452a40b
--- /dev/null
+++ b/editors/gphpedit/files/patch-src::gtkscintilla2::gtk::makefile
@@ -0,0 +1,48 @@
+--- src/gtkscintilla2/scintilla/gtk/makefile.orig Wed Nov 3 07:44:13 2004
++++ src/gtkscintilla2/scintilla/gtk/makefile Sat Dec 18 14:06:07 2004
+@@ -8,7 +8,7 @@
+ # To force GTK+ 1 build, define GTK1 on the make command line.
+
+ .SUFFIXES: .cxx .o .h .a
+-CC = g++
++CC ?= g++
+ AR = ar
+ RANLIB = touch
+
+@@ -31,29 +31,29 @@
+ endif
+
+ ifdef DEBUG
+-CXXFLAGS=-DDEBUG -g $(CXXBASEFLAGS) $(THREADFLAGS)
++CXXFLAGS+=-DDEBUG -g $(CXXBASEFLAGS) $(THREADFLAGS)
+ else
+-CXXFLAGS=-DNDEBUG -Os $(CXXBASEFLAGS) $(THREADFLAGS)
++CXXFLAGS+=-DNDEBUG $(CXXBASEFLAGS) $(THREADFLAGS)
+ endif
+
+ # If explicit setting of GTK1 or GTK2 then use that else look for
+ # pkg-config which is an OK indication that GTK2 is available
+ ifdef GTK2
+-CONFIGFLAGS=pkg-config --cflags gtk+-2.0
++CONFIGFLAGS=pkg-config --cflags gtk+-2.0 gthread-2.0
+ else
+ ifdef GTK1
+-CONFIGFLAGS=gtk-config --cflags
++CONFIGFLAGS=gtk-config --cflags gthread
+ else
+ ifneq (,$(findstring /,$(shell whereis pkg-config)))
+-CONFIGFLAGS=pkg-config --cflags gtk+-2.0
++CONFIGFLAGS=pkg-config --cflags gtk+-2.0 gthread-2.0
+ else
+-CONFIGFLAGS=gtk-config --cflags
++CONFIGFLAGS=gtk-config --cflags gthread
+ endif
+ endif
+ endif
+
+ .cxx.o:
+- $(CC) `$(CONFIGFLAGS)` $(CXXFLAGS) -c $<
++ $(CC) -DPIC -fpic `$(CONFIGFLAGS)` $(CXXFLAGS) -c $<
+
+ LEXOBJS=LexCPP.o LexCSS.o LexEScript.o LexHTML.o LexPerl.o LexSQL.o LexVB.o
+
diff --git a/editors/gphpedit/files/patch-src::tab.c b/editors/gphpedit/files/patch-src::tab.c
new file mode 100644
index 000000000000..a3861f673415
--- /dev/null
+++ b/editors/gphpedit/files/patch-src::tab.c
@@ -0,0 +1,99 @@
+--- src/tab.c.orig Sat Dec 18 14:32:38 2004
++++ src/tab.c Sat Dec 18 14:46:22 2004
+@@ -407,46 +407,81 @@
+ GString *tab_help_find_helpfile(gchar *command)
+ {
+ GString *long_filename = NULL;
+-
+- // For Redhat/Fedora Core and sensible distrubutions...
+- long_filename = tab_help_try_filename("/usr/share/doc/phpmanual/function.", command, ".html");
++
++ /* br (Brazillian) */
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-br/function.", command, ".html");
++ if (long_filename)
++ return long_filename;
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-br/ref.", command, ".html");
++ if (long_filename)
++ return long_filename;
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-br/", command, NULL);
++ if (long_filename)
++ return long_filename;
++
++ /* de (German) */
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-de/function.", command, ".html");
++ if (long_filename)
++ return long_filename;
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-de/ref.", command, ".html");
++ if (long_filename)
++ return long_filename;
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-de/", command, NULL);
++ if (long_filename)
++ return long_filename;
++
++ /* en (English) */
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-en/function.", command, ".html");
++ if (long_filename)
++ return long_filename;
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-en/ref.", command, ".html");
++ if (long_filename)
++ return long_filename;
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-en/", command, NULL);
++ if (long_filename)
++ return long_filename;
++
++ /* es (Spanish) */
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-es/function.", command, ".html");
+ if (long_filename)
+ return long_filename;
+- long_filename = tab_help_try_filename("/usr/share/doc/phpmanual/ref.", command, ".html");
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-es/ref.", command, ".html");
+ if (long_filename)
+ return long_filename;
+- long_filename = tab_help_try_filename("/usr/share/doc/phpmanual/", command, NULL);
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-es/", command, NULL);
+ if (long_filename)
+ return long_filename;
+
+- // For Gentoo, as much as I love it - it's twatty to put docs in a version specific folder like this!
+- long_filename = tab_help_try_filename("/usr/doc/php-docs-200403/html/function.", command, ".html");
++ /* fr (French) */
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-fr/function.", command, ".html");
+ if (long_filename)
+ return long_filename;
+- long_filename = tab_help_try_filename("/usr/doc/php-docs-200403/html/ref.", command, ".html");
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-fr/ref.", command, ".html");
+ if (long_filename)
+ return long_filename;
+- long_filename = tab_help_try_filename("/usr/doc/php-docs-200403/html/", command, NULL);
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-fr/", command, NULL);
+ if (long_filename)
+ return long_filename;
+
+- long_filename = tab_help_try_filename("/usr/share/doc/php-docs-200403/html/function.", command, ".html");
++ /* ja (Japanese) */
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-ja/function.", command, ".html");
+ if (long_filename)
+ return long_filename;
+- long_filename = tab_help_try_filename("/usr/share/doc/php-docs-200403/html/ref.", command, ".html");
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-ja/ref.", command, ".html");
+ if (long_filename)
+ return long_filename;
+- long_filename = tab_help_try_filename("/usr/share/doc/php-docs-200403/html/", command, NULL);
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-ja/", command, NULL);
+ if (long_filename)
+ return long_filename;
+
+- long_filename = tab_help_try_filename("/usr/doc/php-docs-4.2.3/html/function.", command, ".html");
++ /* pl (Polish) */
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-pl/function.", command, ".html");
+ if (long_filename)
+ return long_filename;
+- long_filename = tab_help_try_filename("/usr/doc/php-docs-4.2.3/html/ref.", command, ".html");
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-pl/ref.", command, ".html");
+ if (long_filename)
+ return long_filename;
+- long_filename = tab_help_try_filename("/usr/doc/php-docs-4.2.3/html/", command, NULL);
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-pl/", command, NULL);
+ if (long_filename)
+ return long_filename;
+
diff --git a/editors/gphpedit/pkg-descr b/editors/gphpedit/pkg-descr
new file mode 100644
index 000000000000..60a48593e96e
--- /dev/null
+++ b/editors/gphpedit/pkg-descr
@@ -0,0 +1,7 @@
+gPHPEdit is a Gnome2 text editor optimised for editing PHP, HTML and CSS
+files. It supports editing multiple documents with a tabbed interface, PHP
+syntax checking, PHP/HTML syntax highlighting, a function list for all open
+documents, incremental search, pop-up function hints, and block
+(un)indentation.
+
+WWW: http://www.gphpedit.org/
diff --git a/editors/gphpedit/pkg-plist b/editors/gphpedit/pkg-plist
new file mode 100644
index 000000000000..bc6ece9e0db6
--- /dev/null
+++ b/editors/gphpedit/pkg-plist
@@ -0,0 +1,5 @@
+bin/gphpedit
+share/gnome/applications/gphpedit.desktop
+share/gnome/gphpedit/php-gphpedit.api
+share/gnome/pixmaps/gphpedit.png
+@dirrm share/gnome/gphpedit