aboutsummaryrefslogtreecommitdiffstats
path: root/editors/gphpedit
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-12-25 15:04:17 +0800
committernovel <novel@FreeBSD.org>2005-12-25 15:04:17 +0800
commit6d7f33a425248d02c85e01ed7bff6588cb661be7 (patch)
treeb6826815df2901077b02de68b528b381db1fdd0b /editors/gphpedit
parente7479173d7e95c892fe17027e632df84b06a0a32 (diff)
downloadfreebsd-ports-gnome-6d7f33a425248d02c85e01ed7bff6588cb661be7.tar.gz
freebsd-ports-gnome-6d7f33a425248d02c85e01ed7bff6588cb661be7.tar.zst
freebsd-ports-gnome-6d7f33a425248d02c85e01ed7bff6588cb661be7.zip
- Make it search for php docs in that location where lang/php_doc installs
them - Bump PORTREVISION Reported by: Mark Nowiasz <buckaroo@gmx.de>
Diffstat (limited to 'editors/gphpedit')
-rw-r--r--editors/gphpedit/Makefile3
-rw-r--r--editors/gphpedit/files/patch-src::tab.c17
2 files changed, 16 insertions, 4 deletions
diff --git a/editors/gphpedit/Makefile b/editors/gphpedit/Makefile
index 73172063284f..c763f3bd360e 100644
--- a/editors/gphpedit/Makefile
+++ b/editors/gphpedit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gphpedit
PORTVERSION= 0.9.80
+PORTREVISION= 1
CATEGORIES= editors gnome
MASTER_SITES= http://www.gphpedit.org/download/store/ \
http://ftp.ceid.upatras.gr/pub/linux/gentoo/distfiles/ \
@@ -44,7 +45,7 @@ pre-everything::
.endif
post-extract:
- cd ${WRKSRC}/src/gtkscintilla2 && ${GMAKE} clean
+ @cd ${WRKSRC}/src/gtkscintilla2 && ${GMAKE} clean
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share/gnome|g' \
diff --git a/editors/gphpedit/files/patch-src::tab.c b/editors/gphpedit/files/patch-src::tab.c
index bd360b14aa73..bffe258785dc 100644
--- a/editors/gphpedit/files/patch-src::tab.c
+++ b/editors/gphpedit/files/patch-src::tab.c
@@ -1,8 +1,19 @@
---- src/tab.c.orig Thu Dec 22 21:13:51 2005
-+++ src/tab.c Thu Dec 22 22:08:18 2005
-@@ -521,55 +521,55 @@
+--- src/tab.c.orig Sun Oct 16 13:24:52 2005
++++ src/tab.c Sun Dec 25 09:48:30 2005
+@@ -520,56 +520,66 @@
+ {
GString *long_filename = NULL;
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-en/function.", command, ".html");
++ if (long_filename)
++ return long_filename;
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-en/ref.", command, ".html");
++ if (long_filename)
++ return long_filename;
++ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/php-en/", command, NULL);
++ if (long_filename)
++ return long_filename;
++
// For Redhat/Fedora Core and other sensible distrubutions...
- long_filename = tab_help_try_filename("/usr/share/doc/phpmanual/function.", command, ".html");
+ long_filename = tab_help_try_filename("%%LOCALBASE%%/share/doc/phpmanual/function.", command, ".html");