aboutsummaryrefslogtreecommitdiffstats
path: root/editors/hnb/Makefile
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2003-04-09 07:25:26 +0800
committerpat <pat@FreeBSD.org>2003-04-09 07:25:26 +0800
commit42de40cf4d6a62e7dc62f2cb9b01ee8ea18b19b4 (patch)
treeebb9adbfc8d102dbb7933b514eb123c120b43483 /editors/hnb/Makefile
parent7fbb2893d18e27e1f8cf562a7ae3c3557567425a (diff)
downloadfreebsd-ports-gnome-42de40cf4d6a62e7dc62f2cb9b01ee8ea18b19b4.tar.gz
freebsd-ports-gnome-42de40cf4d6a62e7dc62f2cb9b01ee8ea18b19b4.tar.zst
freebsd-ports-gnome-42de40cf4d6a62e7dc62f2cb9b01ee8ea18b19b4.zip
Update to 1.9.17
PR: ports/50734 Submitted by: obraun
Diffstat (limited to 'editors/hnb/Makefile')
-rw-r--r--editors/hnb/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/editors/hnb/Makefile b/editors/hnb/Makefile
index 31a82dad101a..0f38c7d9191e 100644
--- a/editors/hnb/Makefile
+++ b/editors/hnb/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hnb
-PORTVERSION= 1.9.8
+PORTVERSION= 1.9.17
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,13 +15,24 @@ MAINTAINER= pat@FreeBSD.org
COMMENT= Hierarchical NoteBook a data organizer
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+USE_REINPLACE= yes
USE_GMAKE= yes
ALL_TARGET=
MAN1= hnb.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CFLAGS=|CFLAGS+=|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^CFLAGS/d' ${WRKSRC}/libcli/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hnb ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/../doc/hnb.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for FILE in Documentation.hnb Documentation.html hnbrc
+ ${INSTALL_DATA} ${WRKSRC}/../doc/${FILE} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>