aboutsummaryrefslogtreecommitdiffstats
path: root/editors/jed
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2009-12-21 22:53:02 +0800
committergarga <garga@FreeBSD.org>2009-12-21 22:53:02 +0800
commit9b78792498c85b8046b1ac90f47a4be6432f36ef (patch)
tree93c21db927d01e500247cc58a0e484855c6d9a52 /editors/jed
parentd594123e99788ea04b4c0602b3e007deaf7f15bc (diff)
downloadfreebsd-ports-gnome-9b78792498c85b8046b1ac90f47a4be6432f36ef.tar.gz
freebsd-ports-gnome-9b78792498c85b8046b1ac90f47a4be6432f36ef.tar.zst
freebsd-ports-gnome-9b78792498c85b8046b1ac90f47a4be6432f36ef.zip
After upgrade to 0.99.19 jed was freezing when called with -c, fix it now.
Reported by: andrew clarke <mail@ozzmosis.com> Obtained from: Author by email
Diffstat (limited to 'editors/jed')
-rw-r--r--editors/jed/Makefile3
-rw-r--r--editors/jed/files/patch-src_unix.c24
2 files changed, 26 insertions, 1 deletions
diff --git a/editors/jed/Makefile b/editors/jed/Makefile
index 3a9a0c634e57..3ff57ca774e7 100644
--- a/editors/jed/Makefile
+++ b/editors/jed/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jed
PORTVERSION= 0.99.19
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ftp://space.mit.edu/pub/davis/jed/v${PORTVERSION:R}/ \
ftp://ftp.uni-stuttgart.de/pub/unix/misc/slang/jed/v${PORTVERSION:R}/ \
@@ -17,7 +18,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= garga@FreeBSD.org
COMMENT= A SLang-based text editor
-LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
CONFLICTS= jed-devel-[0-9]*
diff --git a/editors/jed/files/patch-src_unix.c b/editors/jed/files/patch-src_unix.c
new file mode 100644
index 000000000000..c567e6d14229
--- /dev/null
+++ b/editors/jed/files/patch-src_unix.c
@@ -0,0 +1,24 @@
+--- src/unix.c
++++ src/unix.c
+@@ -211,8 +211,19 @@ static void set_process_group (void)
+ {
+ pid_t pid = getpid ();
+ Startup_PGID = getpgid (pid);
+- (void) tcsetpgrp (Read_FD, pid);
+- (void) setpgid (pid, pid);
++ if (-1 == tcsetpgrp (Read_FD, pid))
++ {
++ fprintf (stderr, "tcsetpgrp failed\n");
++ Terminal_PGID = -1;
++ return;
++ }
++ if (-1 == setpgid (pid, pid))
++ {
++ fprintf (stderr, "setpgid failed\n");
++ (void) tcsetpgrp (Read_FD, Startup_PGID);
++ Terminal_PGID = -1;
++ return;
++ }
+ }
+ #endif
+ }